Frame Relay issue.
Kalabin
Member Posts: 64 ■■□□□□□□□□
in CCNA & CCENT
This is the setup.
Limerick (2501) --- Cork (2620) --- Belfast (2501) --- Adtran -- Galway (2501)
The issue is with the frame relay connection between Belfast and Galway. During the lab this morning both were showing Up and Up, but I was unable to ping the two device's. Also, sh ip route did show the two directly connected devices, with the IP of the network for the serial connection. Also the frame-relay mapping's showed that the DLCI's used were static. Part of me is wondering if the Adtran emulator was acting up, and someone changed the DLCI mapping's on it.
I'll post the two config's below and if ya see something please do let me know. I will not be able to do any troubleshooting on it until monday when I go to the lab again.
Belfast
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Belfast
!
enable secret 5 $1$SkII$DpcFny63lMgEWM6WiCIWM.
enable password cisco
!
username Cork password 0 cisco
ip subnet-zero
!
!
!
interface Ethernet0
ip address 155.155.10.1 255.255.255.192
ip helper-address 155.155.255.245
no ip directed-broadcast
!
interface Serial0
ip address 155.155.255.246 255.255.255.252
no ip directed-broadcast
encapsulation ppp
no ip mroute-cache
no fair-queue
ppp authentication chap
no shutdown
!
interface Serial1
no ip address
no ip directed-broadcast
encapsulation frame-relay IETF
no shutdown
!
interface Serial1.304 point-to-point
description PVC to Galway, DLCI 304
ip address 155.155.255.241 255.255.255.252
no ip directed-broadcast
frame-relay interface-dlci 304
!
router ospf 1
redistribute rip
network 155.155.10.0 0.0.0.63 area 0
network 155.155.255.240 0.0.0.7 area 0
!
ip classless
!
!
line con 0
password cisco
login
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end
Galway
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Galway
!
!
ip subnet-zero
!
!
!
interface Ethernet0
ip address 155.155.0.1 255.255.252.0
ip helper-address 155.155.255.241
no ip directed-broadcast
no shutdown
!
interface Serial0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
!
interface Serial1
no ip address
no ip directed-broadcast
encapsulation frame-relay IETF
logging event subif-link-status
logging event dlci-status-change
no shutdown
!
interface Serial1.403 point-to-point
description PVC to Belfast, DLCI 403
ip address 155.155.255.242 255.255.255.252
no ip directed-broadcast
frame-relay interface-dlci 403
!
router rip
version 2
redistribute ospf 1
network 155.155.0.0
!
ip classless
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end
Limerick (2501) --- Cork (2620) --- Belfast (2501) --- Adtran -- Galway (2501)
The issue is with the frame relay connection between Belfast and Galway. During the lab this morning both were showing Up and Up, but I was unable to ping the two device's. Also, sh ip route did show the two directly connected devices, with the IP of the network for the serial connection. Also the frame-relay mapping's showed that the DLCI's used were static. Part of me is wondering if the Adtran emulator was acting up, and someone changed the DLCI mapping's on it.
I'll post the two config's below and if ya see something please do let me know. I will not be able to do any troubleshooting on it until monday when I go to the lab again.
Belfast
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Belfast
!
enable secret 5 $1$SkII$DpcFny63lMgEWM6WiCIWM.
enable password cisco
!
username Cork password 0 cisco
ip subnet-zero
!
!
!
interface Ethernet0
ip address 155.155.10.1 255.255.255.192
ip helper-address 155.155.255.245
no ip directed-broadcast
!
interface Serial0
ip address 155.155.255.246 255.255.255.252
no ip directed-broadcast
encapsulation ppp
no ip mroute-cache
no fair-queue
ppp authentication chap
no shutdown
!
interface Serial1
no ip address
no ip directed-broadcast
encapsulation frame-relay IETF
no shutdown
!
interface Serial1.304 point-to-point
description PVC to Galway, DLCI 304
ip address 155.155.255.241 255.255.255.252
no ip directed-broadcast
frame-relay interface-dlci 304
!
router ospf 1
redistribute rip
network 155.155.10.0 0.0.0.63 area 0
network 155.155.255.240 0.0.0.7 area 0
!
ip classless
!
!
line con 0
password cisco
login
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end
Galway
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Galway
!
!
ip subnet-zero
!
!
!
interface Ethernet0
ip address 155.155.0.1 255.255.252.0
ip helper-address 155.155.255.241
no ip directed-broadcast
no shutdown
!
interface Serial0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
!
interface Serial1
no ip address
no ip directed-broadcast
encapsulation frame-relay IETF
logging event subif-link-status
logging event dlci-status-change
no shutdown
!
interface Serial1.403 point-to-point
description PVC to Belfast, DLCI 403
ip address 155.155.255.242 255.255.255.252
no ip directed-broadcast
frame-relay interface-dlci 403
!
router rip
version 2
redistribute ospf 1
network 155.155.0.0
!
ip classless
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end
Comments
-
Turgon Banned Posts: 6,308 ■■■■■■■■■□Try a show frame-relay pvc on both Belfast and Galway and see what you get to see if that Adtran is playing up in terms of offering you DLCIs.
-
Kalabin Member Posts: 64 ■■□□□□□□□□Yeah, I did that while in class. It showed the same DLCI mapping's that I have on my config listed. I'm really leaning towards something on that Adtran. Otherwise though does the config look correct for the frame relay?
-
Turgon Banned Posts: 6,308 ■■■■■■■■■□Kalabin wrote:Yeah, I did that while in class. It showed the same DLCI mapping's that I have on my config listed. I'm really leaning towards something on that Adtran. Otherwise though does the config look correct for the frame relay?
If the adtran is your frame switch and the frame routes there have been changed then you will have some problems. Certainly get it checked out.
The configs you have posted are either incomplete or wrong. You are redistributing protocols at both ends but on each side you are missing the config of the routing protocol you are redistributing from. -
Kalabin Member Posts: 64 ■■□□□□□□□□So, for the redistribute your saying that the router running OSPF as it's routing protocol should be Redistributing OSPF? And same for RIP?
-
Turgon Banned Posts: 6,308 ■■■■■■■■■□Kalabin wrote:So, for the redistribute your saying that the router running OSPF as it's routing protocol should be Redistributing OSPF? And same for RIP?
What I mean is..according to your config Galway is
router rip
version 2
redistribute ospf 1
network 155.155.0.0
redistributing ospf into rip.
But from your config there ospf isn't running. Its not configured.
Belfast is running ospf and redistributing rip into that process.
rip isn't running on Belfast.
Sort that out, try a reload and see how you get on. -
Kalabin Member Posts: 64 ■■□□□□□□□□I think im a bit confused at this point. Galway is running RIP V2, Belfast is running OSPF. Now, if galway is running RIP V2, wouldnt you redistribute the OSPF routing update's to the RIP network? Since Belfast is running OSPF.
So, in my thinking Galway is recieving routing info from Belfast via OSPF. You have to specify on Galway to redistribute those update's via RIP V2. So in the RIP V2 routing statement's you would input the Redistribute OSPF.
Then just the reverse on Belfast. It's using OSPF, but recieving RIP V2 update's from Galway, so it need's to Redistribute those under OSPF. Again im most likely complete backward's on this. As this was a vaguely covered topic in the Acadamy.
Too add to this, Limerick -- Cork -- Belfast are all running OSPF. Belfast connect's to Galway via frame-relay. Galway is running RIP V2 on their network. Or supposed to be rather. -
Turgon Banned Posts: 6,308 ■■■■■■■■■□Kalabin wrote:I think im a bit confused at this point. Galway is running RIP V2, Belfast is running OSPF. Now, if galway is running RIP V2, wouldnt you redistribute the OSPF routing update's to the RIP network? Since Belfast is running OSPF.
So, in my thinking Galway is recieving routing info from Belfast via OSPF. You have to specify on Galway to redistribute those update's via RIP V2. So in the RIP V2 routing statement's you would input the Redistribute OSPF.
Then just the reverse on Belfast. It's using OSPF, but recieving RIP V2 update's from Galway, so it need's to Redistribute those under OSPF. Again im most likely complete backward's on this. As this was a vaguely covered topic in the Acadamy.
Too add to this, Limerick -- Cork -- Belfast are all running OSPF. Belfast connect's to Galway via frame-relay. Galway is running RIP V2 on their network. Or supposed to be rather.
You have a simple problem and it will be a simple solution. Regarding redistribution, look at the configs you have posted for the Belfast and Galway routers. In each case they are redistributing a protocol that is not running on that router according to the configurations you have posted.
ergo..if you are going to redistribute rip into ospf on a router, it's a good idea to have rip configured and running on that router! Same for ospf redistributed into rip..best off have ospf configured and running on that router.
Otherwise you have nothing to redistribute! -
Kalabin Member Posts: 64 ■■□□□□□□□□Ahh, so for the OSPF router it should be redistrubiting OSPF, and RIP redistributing RIP..