OSPF Problem.

vinsousavinsousa Member Posts: 1 ■□□□□□□□□□
I have 2 Cisco 2501 Routers running OSPF. I am advertising all the networks that are directly connected to both routers.

The problem is that RouterB cannot see this network 192.168.10.0 255.255.255.0 which is directly connected to RouterA.

I have copied and pasted all the information that maybe needed. Any help would be appreciated.

From RouterA
RouterA#sh run
Building configuration...

Current configuration : 1058 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterA
!
enable secret 5 $1$lMX8$dXrUrY4zhM/eT43LevY5S/
!
ip subnet-zero
ip host RouterB 192.168.20.2
!
!
interface Ethernet0
description RouterA LAN Connection
ip address 192.168.10.1 255.255.255.0
!
interface Serial0
description WAN Connection to Serial0 on RouterB
ip address 192.168.20.1 255.255.255.0
ip ospf network point-to-point
no fair-queue
!
interface Serial1
no ip address
shutdown
!
router ospf 2
log-adjacency-changes
network 192.168.10.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0
network 192.168.30.0 0.0.0.255 area 0
!
router ospf 1
log-adjacency-changes
network 168.168.10.0 0.0.0.255 area 0
network 168.168.20.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0
!
ip http server

ip http server
ip classless
!

line con 0
exec-timeout 0 0
password cisco
login
line aux 0
password cisco
login
line vty 0 4
password cisco
login
!
!
end


RouterB

RouterB#sh run
Building configuration...

Current configuration : 922 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname RouterB
!
boot system tftp IOS_image 192.168.30.2
enable secret 5 $1$S60W$ApiZjDupNUSbNQVGJUhys/
!
ip subnet-zero
ip host RouterA 192.168.20.1
!

interface Ethernet0
description RouterB LAN connection
ip address 192.168.30.1 255.255.255.0
!
interface Serial0
description WAN Connection To Serial0 on RouterA
ip address 192.168.20.2 255.255.255.0
clockrate 64000
no fair-queue
!
interface Serial1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 192.168.20.0 0.0.0.255 area 0
network 192.168.30.0 0.0.0.255 area 0
!
ip http server
ip classless
!
banner motd ^C This is a SECURE Router. Unauthorized access only!^C
!
line con 0
password 7 060506324F41
login
line aux 0
password 7 060506324F41
login
line vty 0 4
password 7 060506324F41
login
!
end


RouterA#sh ip ospf interface
Serial0 is up, line protocol is up
Internet Address 192.168.20.1/24, Area 0
Process ID 1, Router ID 192.168.10.1, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:02
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 192.168.30.1
Suppress hello for 0 neighbor(s)
Ethernet0 is up, line protocol is up
Internet Address 192.168.10.1/24, Area 0
Process ID 2, Router ID 192.168.20.1, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.20.1, Interface address 192.168.10.1
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:07
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)

RouterB#sh ip ospf interface
Serial0 is up, line protocol is up
Internet Address 192.168.20.2/24, Area 0
Process ID 1, Router ID 192.168.30.1, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:03
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 4 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 192.168.10.1
Suppress hello for 0 neighbor(s)
Ethernet0 is up, line protocol is up
Internet Address 192.168.30.1/24, Area 0
Process ID 1, Router ID 192.168.30.1, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.30.1, Interface address 192.168.30.1
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:08
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)


RouterA#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
192.168.30.1 0 FULL/ - 00:00:31 192.168.20.2 Serial0

RouterB#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
192.168.10.1 0 FULL/ - 00:00:39 192.168.20.1 Serial0


RouterA#sh ip ospf database

OSPF Router with ID (192.168.10.1) (Process ID 1)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
192.168.10.1 192.168.10.1 1000 0x8000000E 0x00B178 2
192.168.20.1 192.168.20.1 2185 0x80000002 0x00068E 3
192.168.30.1 192.168.30.1 1001 0x80000002 0x00413E 3

OSPF Router with ID (192.168.20.1) (Process ID 2)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
192.168.20.1 192.168.20.1 38 0x80000004 0x004570 1
192.168.30.1 192.168.30.1 2184 0x80000003 0x0099DA 3


RouterB#sh ip ospf database

OSPF Router with ID (192.168.30.1) (Process ID 1)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
192.168.10.1 192.168.10.1 1013 0x8000000E 0x00B178 2
192.168.20.1 192.168.20.1 2199 0x80000002 0x00068E 3
192.168.30.1 192.168.30.1 1014 0x80000002 0x00413E 3


RouterA#sh ip ospf
Routing Process "ospf 1" with ID 192.168.10.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:17:40.116 ago
SPF algorithm executed 17 times
Area ranges are
Number of LSA 3. Checksum Sum 0x00F944
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0

Routing Process "ospf 2" with ID 192.168.20.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
External flood list length 0
Area BACKBONE(0) (Inactive)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:35:35.844 ago
SPF algorithm executed 3 times
Area ranges are
Number of LSA 2. Checksum Sum 0x00DF4A
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0


RouterB#sh ip ospf
Routing Process "ospf 1" with ID 192.168.30.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 2
Area has no authentication
SPF algorithm last executed 00:18:19.372 ago
SPF algorithm executed 2 times
Area ranges are
Number of LSA 3. Checksum Sum 0x00F944
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0


RouterA#sh ip route

Gateway of last resort is not set

O 192.168.30.0/24 [110/74] via 192.168.20.2, 00:19:43, Serial0
C 192.168.10.0/24 is directly connected, Ethernet0
C 192.168.20.0/24 is directly connected, Serial0


RouterB#sh ip route

C 192.168.30.0/24 is directly connected, Ethernet0
C 192.168.20.0/24 is directly connected, Serial0


Now this is a lab that I got from a book. Any ideas why the Routing table on RouterB doesn't see the 192.168.10.0 network?

Comments

  • shednikshednik Member Posts: 2,005
    I don't see why you have this defined in ospf no interfaces match that network statement
    network 168.168.10.0 0.0.0.255 area 0
    network 168.168.20.0 0.0.0.255 area 0
    


    Other than that at first glance things seem to be ok I'd remove those to statements unless there is an explicit reason for it being there and do a clear ip route * on RouterB with some debugs on and watch OSPF do its work.

    EDIT: also I noticed this on RouterA
    router ospf 2
    log-adjacency-changes
    network 192.168.10.0 0.0.0.255 area 0
    network 192.168.20.0 0.0.0.255 area 0
    network 192.168.30.0 0.0.0.255 area 0
    

    192.168.30.0 is not an network on RouterA either so I'm not sure why you have that on there try those changes and let us know how it goes.
  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    Why do you have 2 ospf processes on routerA? , if you look at the "show ip ospf interface" output you will see the e0 is not in process 1, it is in process 2.Since s0 is in process 1 it is advertising all process 1 info and hence e0 info isnt being sent.Remove process 2 config and all will be good.
    vinsousa wrote:
    router ospf 2
    log-adjacency-changes
    network 192.168.10.0 0.0.0.255 area 0
    network 192.168.20.0 0.0.0.255 area 0
    network 192.168.30.0 0.0.0.255 area 0
    !
    router ospf 1
    log-adjacency-changes
    network 168.168.10.0 0.0.0.255 area 0
    network 168.168.20.0 0.0.0.255 area 0
    network 192.168.10.0 0.0.0.255 area 0
    network 192.168.20.0 0.0.0.255 area 0
    !


    RouterA#sh ip ospf interface
    Serial0 is up, line protocol is up
    Internet Address 192.168.20.1/24, Area 0
    Process ID 1, Router ID 192.168.10.1, Network Type POINT_TO_POINT, Cost: 64
    Transmit Delay is 1 sec, State POINT_TO_POINT,
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:02
    Index 1/1, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 1, maximum is 1
    Last flood scan time is 0 msec, maximum is 4 msec
    Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 192.168.30.1
    Suppress hello for 0 neighbor(s)
    Ethernet0 is up, line protocol is up
    Internet Address 192.168.10.1/24, Area 0
    Process ID 2, Router ID 192.168.20.1, Network Type BROADCAST, Cost: 10
    Transmit Delay is 1 sec, State DR, Priority 1
    Designated Router (ID) 192.168.20.1, Interface address 192.168.10.1
    No backup designated router on this network
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
    Index 1/1, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 0, maximum is 0
    Last flood scan time is 0 msec, maximum is 0 msec
    Neighbor Count is 0, Adjacent neighbor count is 0
    Suppress hello for 0 neighbor(s)

    RouterB#sh ip ospf interface
    Serial0 is up, line protocol is up
    Internet Address 192.168.20.2/24, Area 0
    Process ID 1, Router ID 192.168.30.1, Network Type POINT_TO_POINT, Cost: 64
    Transmit Delay is 1 sec, State POINT_TO_POINT,
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:03
    Index 2/2, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 1, maximum is 1
    Last flood scan time is 4 msec, maximum is 4 msec
    Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 192.168.10.1
    Suppress hello for 0 neighbor(s)
    Ethernet0 is up, line protocol is up
    Internet Address 192.168.30.1/24, Area 0
    Process ID 1, Router ID 192.168.30.1, Network Type BROADCAST, Cost: 10
    Transmit Delay is 1 sec, State DR, Priority 1
    Designated Router (ID) 192.168.30.1, Interface address 192.168.30.1
    No backup designated router on this network
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:08
    Index 1/1, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 0, maximum is 0
    Last flood scan time is 0 msec, maximum is 0 msec
    Neighbor Count is 0, Adjacent neighbor count is 0
    Suppress hello for 0 neighbor(s)
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • shednikshednik Member Posts: 2,005
    EdTheLad wrote:
    Why do you have 2 ospf processes on routerA? , if you look at the "show ip ospf interface" output you will see the e0 is not in process 1, it is in process 2.Since s0 is in process 1 it is advertising all process 1 info and hence e0 info isnt being sent.Remove process 2 config and all will be good.

    I was wondering that myself but since it was from a lab book I figured they had some meaning behind it...now that you pointed that out ed I see what you mean.
  • APAAPA Member Posts: 959
    EdTheLad wrote:
    Why do you have 2 ospf processes on routerA? , if you look at the "show ip ospf interface" output you will see the e0 is not in process 1, it is in process 2.Since s0 is in process 1 it is advertising all process 1 info and hence e0 info isnt being sent.Remove process 2 config and all will be good.
    vinsousa wrote:
    router ospf 2
    log-adjacency-changes
    network 192.168.10.0 0.0.0.255 area 0
    network 192.168.20.0 0.0.0.255 area 0
    network 192.168.30.0 0.0.0.255 area 0
    !
    router ospf 1
    log-adjacency-changes
    network 168.168.10.0 0.0.0.255 area 0
    network 168.168.20.0 0.0.0.255 area 0
    network 192.168.10.0 0.0.0.255 area 0
    network 192.168.20.0 0.0.0.255 area 0
    !


    RouterA#sh ip ospf interface
    Serial0 is up, line protocol is up
    Internet Address 192.168.20.1/24, Area 0
    Process ID 1, Router ID 192.168.10.1, Network Type POINT_TO_POINT, Cost: 64
    Transmit Delay is 1 sec, State POINT_TO_POINT,
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:02
    Index 1/1, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 1, maximum is 1
    Last flood scan time is 0 msec, maximum is 4 msec
    Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 192.168.30.1
    Suppress hello for 0 neighbor(s)
    Ethernet0 is up, line protocol is up
    Internet Address 192.168.10.1/24, Area 0
    Process ID 2, Router ID 192.168.20.1, Network Type BROADCAST, Cost: 10
    Transmit Delay is 1 sec, State DR, Priority 1
    Designated Router (ID) 192.168.20.1, Interface address 192.168.10.1
    No backup designated router on this network
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
    Index 1/1, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 0, maximum is 0
    Last flood scan time is 0 msec, maximum is 0 msec
    Neighbor Count is 0, Adjacent neighbor count is 0
    Suppress hello for 0 neighbor(s)

    RouterB#sh ip ospf interface
    Serial0 is up, line protocol is up
    Internet Address 192.168.20.2/24, Area 0
    Process ID 1, Router ID 192.168.30.1, Network Type POINT_TO_POINT, Cost: 64
    Transmit Delay is 1 sec, State POINT_TO_POINT,
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:03
    Index 2/2, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 1, maximum is 1
    Last flood scan time is 4 msec, maximum is 4 msec
    Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 192.168.10.1
    Suppress hello for 0 neighbor(s)
    Ethernet0 is up, line protocol is up
    Internet Address 192.168.30.1/24, Area 0
    Process ID 1, Router ID 192.168.30.1, Network Type BROADCAST, Cost: 10
    Transmit Delay is 1 sec, State DR, Priority 1
    Designated Router (ID) 192.168.30.1, Interface address 192.168.30.1
    No backup designated router on this network
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:08
    Index 1/1, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 0, maximum is 0
    Last flood scan time is 0 msec, maximum is 0 msec
    Neighbor Count is 0, Adjacent neighbor count is 0
    Suppress hello for 0 neighbor(s)

    what he said :D

    Fix up your network statements in process 1....... Remove process 2 config as without a process 2 config on router B it will never create the neighbor adjacency as Router B is in Process 1 and ROuter A has one interface in process 1 (hence you see al the routes for theses interfaces) and one interface e0 is in process 2 which has no way of advertising to Router B....

    CCNA | CCNA:Security | CCNP | CCIP
    JNCIA:JUNOS | JNCIA:EX | JNCIS:ENT | JNCIS:SEC
    JNCIS:SP | JNCIP:SP
Sign In or Register to comment.