Training Exam Kit MS Press Runtime Error

After I've installed the practice tests and try to launch them I get a Run-time error '-2147319779 (8002801d)': Automation error Library not registered.

I've tried uninstalling and reinstalling the practice tests with no luck. I also checked the errata and corrections page for this title and it doesn't mention anything. Has anybody else experienced this? If so do you have any possible solutions.

Comments

  • astorrsastorrs Posts: 3,139Member ■■■■■■□□□□
    undomiel wrote:
    Eww... even if you're running FRx don't do that (giving users Full Control on the HKCR key is just asking for problems). Oh and you have my sympathies if you have to deal with FRx - if you don't know what it is pray you never find out.

    Here's two different things to try that worked for others having the same problem with those tests.

    1) From a command prompt run:
    regsvr32 C:\Windows\System32\Vsocx6.ocx

    Only if that doesn't work then give this a try:
    Hi All;

    The problem turns out to be related to the User Account Control somehow.

    Uninstall the program from Control Panel first or by running the CD again
    and picking remove. Then in control panel select the User Accounts and select
    to turn off the User Account Control for the moment. Or if it is turned off,
    turn it on.

    Then close up control panel and reinstall the software. See if the program
    runs before and after turning the UAC back on or vice versa.

    Sorry about that.

    Have a great day!
    John Hecht
    MeasureUp Customer Support
    678 356 5050
  • whistlerwhistler Posts: 108Member
    I have had this problem a couple of times with 70-620 and 70-620 in Vista.

    IIRC either use Run As Administrator or press and hold the shift key or ctl key when starting the setup program.
  • Tyrant1919Tyrant1919 Senior Member Posts: 519Member ■■■□□□□□□□
    I think I just ran it in compatability mode to resolve the issue on my work Vista machine.
    A+/N+/S+/L+/Svr+
    MCSA:03/08/12/16 MCSE:03s/EA08/Core Infra
    CCNA
  • dotnetfreakdotnetfreak Posts: 1Member ■□□□□□□□□□
    I just registered in this forums just to say that this: regsvr32 C:\Windows\System32\Vsocx6.ocx

    Worked for me Im using vista and was receiving the library not registered error

    Thank you very much
  • khokheqakhokheqa Posts: 2Member ■□□□□□□□□□
    Just try to install Latest Java 6.0 version to fix ur problem. These tests run with java that is the apprpiate solution.
  • konfukonfu Posts: 1Member ■□□□□□□□□□
    Just installing java will NOT fix this specific problem.

    The first solution mentioned by astorrs will fix the problem:

    Run regsvr32 C:\Windows\System32\Vsocx6.ocx

    or if you are on Windows Vista 64 bit:

    Run regsvr32 C:\Windows\sysWOW64\Vsocx6.ocx
  • KevInOzKevInOz Posts: 2Member ■□□□□□□□□□
    Thanks konfu for this explicit answer, including the 64 bit answer.
Sign In or Register to comment.