Problem with a BSCI lab
I'm doing a BSCI Lab. I configured P1R1, P1R2, P1R3 and P1R4 as OSPF and P2R1, P2R2, P2R3 and P2R4 as EIGRP. Now I can't make P1R1, P1R2, P1R3, P2R1, P2R2, BBR2 and BBR1 communicate through the frame. I'm using GNS3 emulator. I got this lab from a friend of my and he also gave me the initial configuration, but he didn't give me the goal of the lab. If anybody has done this lab before can you please explain me if I need to configure everything as OSPF and BGP or EIGRP and BGP. I will post the config on my next post
Comments
-
amb1s1 Member Posts: 408BBR1 Config
version 12.3 service timestamps debug datetime localtime show-timezone service timestamps log datetime localtime show-timezone no service password-encryption ! hostname BBR1 ! boot-start-marker boot-end-marker ! ! no aaa new-model ip subnet-zero ! ! ip cef no ip domain lookup ip host P1R1 10.1.1.1 10.1.0.1 10.11.0.1 172.31.1.1 172.31.11.1 10.200.200.11 ip host P1R2 10.1.2.2 10.1.0.2 10.11.0.2 172.31.1.2 172.31.11.2 10.200.200.12 ip host P1R3 10.1.1.3 10.1.3.3 10.200.200.13 ip host P1R4 10.1.3.4 10.1.2.4 10.200.200.14 ip host P2R1 10.2.1.1 10.2.0.1 10.22.0.1 172.31.2.1 172.31.22.1 10.200.200.21 ip host P2R2 10.2.2.2 10.2.0.2 10.22.0.2 172.31.2.2 172.31.22.2 10.200.200.22 ip host P2R3 10.2.1.3 10.2.3.3 10.200.200.23 ip host P2R4 10.2.3.4 10.2.2.4 10.200.200.24 ip host bbr2 10.254.0.2 172.31.11.4 172.31.22.4 172.31.33.4 172.31.44.4 ip host bbr1 10.254.0.1 172.31.1.3 172.31.2.3 172.31.3.3 172.31.4.3 ! ip audit po max-events 100 ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! interface FastEthernet0/0 description - Backbone LAN Connection ip address 10.254.0.1 255.255.255.0 ip rip send version 2 ip rip receive version 2 duplex auto speed auto ! interface Serial1/0 description - Interface for Frame Relay Multipoint ip address 172.31.1.20 255.255.255.0 encapsulation frame-relay shutdown serial restart-delay 0 no frame-relay inverse-arp ! interface Serial1/0.1 multipoint description - Frame Relay DLCI 111 and 112 for Pod 1 bandwidth 64 ip address 172.31.1.3 255.255.255.0 ip rip send version 1 2 ip rip receive version 1 2 ip ospf network non-broadcast frame-relay map ip 172.31.1.1 111 broadcast frame-relay map ip 172.31.1.2 112 broadcast ! interface Serial1/0.2 multipoint description - Frame Relay DLCI 121 and 122 for Pod 2 bandwidth 64 ip address 172.31.2.3 255.255.255.0 ip rip send version 1 2 ip rip receive version 1 2 ip ospf network non-broadcast frame-relay map ip 172.31.2.1 121 broadcast frame-relay map ip 172.31.2.2 122 broadcast ! interface Serial1/1 no ip address shutdown serial restart-delay 0 ! interface Serial1/2 no ip address shutdown serial restart-delay 0 ! interface Serial1/3 no ip address shutdown serial restart-delay 0 ! router eigrp 1 network 10.254.0.0 0.0.0.255 network 172.31.0.0 distribute-list 1 in no auto-summary no eigrp log-neighbor-changes ! router ospf 1 router-id 100.100.100.100 log-adjacency-changes redistribute connected metric 50 subnets network 172.31.0.0 0.0.255.255 area 0 neighbor 172.31.2.1 neighbor 172.31.2.2 neighbor 172.31.1.1 neighbor 172.31.1.2 ! router rip network 10.0.0.0 network 172.31.0.0 distribute-list 1 in ! router bgp 64998 no synchronization bgp log-neighbor-changes network 10.254.0.0 mask 255.255.255.0 network 172.31.1.0 mask 255.255.255.0 network 172.31.2.0 mask 255.255.255.0 neighbor 10.254.0.2 remote-as 64999 neighbor 10.254.0.3 remote-as 64997 neighbor 172.31.1.1 remote-as 65001 neighbor 172.31.1.2 remote-as 65001 neighbor 172.31.2.1 remote-as 65002 neighbor 172.31.2.2 remote-as 65002 no auto-summary ! no ip http server no ip http secure-server ip classless ip route 192.168.1.0 255.255.255.0 172.31.1.1 ip route 192.168.2.0 255.255.255.0 172.31.2.1 ip route 192.168.11.0 255.255.255.0 172.31.1.2 ip route 192.168.22.0 255.255.255.0 172.31.2.2 ! ! access-list 1 deny 0.0.0.0 access-list 1 permit any ! ! ! ! ! ! line con 0 exec-timeout 1000 0 privilege level 15 logging synchronous line aux 0 line vty 0 4 exec-timeout 1000 0 password cisco logging synchronous login ! ! end
BBR2version 12.3 service timestamps debug datetime msec service timestamps log datetime msec no service password-encryption ! hostname BBR2 ! boot-start-marker boot-end-marker ! ! no aaa new-model ip subnet-zero ! ! ip cef no ip domain lookup ip host P1R1 10.1.1.1 10.1.0.1 10.11.0.1 172.31.1.1 172.31.11.1 10.200.200.11 ip host P1R2 10.1.2.2 10.1.0.2 10.11.0.2 172.31.1.2 172.31.11.2 10.200.200.12 ip host P1R3 10.1.1.3 10.1.3.3 10.200.200.13 ip host P1R4 10.1.3.4 10.1.2.4 10.200.200.14 ip host P2R1 10.2.1.1 10.2.0.1 10.22.0.1 172.31.2.1 172.31.22.1 10.200.200.21 ip host P2R2 10.2.2.2 10.2.0.2 10.22.0.2 172.31.2.2 172.31.22.2 10.200.200.22 ip host P2R3 10.2.1.3 10.2.3.3 10.200.200.23 ip host P2R4 10.2.3.4 10.2.2.4 10.200.200.24 ip host bbr2 10.254.0.2 172.31.11.4 172.31.22.4 172.31.33.4 172.31.44.4 ip host bbr1 10.254.0.1 172.31.1.3 172.31.2.3 172.31.3.3 172.31.4.3 ! ip audit po max-events 100 ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! interface FastEthernet0/0 description - Backbone LAN Connection ip address 10.254.0.2 255.255.255.0 duplex auto speed auto ! interface Serial1/0 description - Interface for Frame Relay Multipoint for OSPF Lab 4.3 no ip address encapsulation frame-relay shutdown serial restart-delay 0 no frame-relay inverse-arp ! interface Serial1/0.1 multipoint description - Frame Relay DLCI 211 and 212 for Pod 1 bandwidth 64 ip address 172.31.11.4 255.255.255.0 ip ospf network point-to-multipoint frame-relay map ip 172.31.11.1 211 broadcast frame-relay map ip 172.31.11.2 212 broadcast no frame-relay inverse-arp ! interface Serial1/0.2 multipoint description - Frame Relay DLCI 221 and 222 for Pod 2 bandwidth 64 ip address 172.31.22.4 255.255.255.0 ip ospf network point-to-multipoint frame-relay map ip 172.31.22.1 221 broadcast frame-relay map ip 172.31.22.2 222 broadcast ! interface Serial1/1 no ip address shutdown serial restart-delay 0 ! interface Serial1/2 no ip address shutdown serial restart-delay 0 ! interface Serial1/3 no ip address shutdown serial restart-delay 0 ! router eigrp 1 network 10.0.0.0 no auto-summary ! router ospf 1 router-id 200.200.200.200 log-adjacency-changes redistribute connected metric 50 subnets network 172.31.0.0 0.0.255.255 area 0 ! router rip version 2 passive-interface FastEthernet0/0 passive-interface Serial1/0.1 passive-interface Serial1/0.2 network 10.0.0.0 ! router bgp 64999 no synchronization bgp log-neighbor-changes network 172.31.11.0 mask 255.255.255.0 network 172.31.22.0 mask 255.255.255.0 neighbor 10.254.0.1 remote-as 64998 neighbor 10.254.0.3 remote-as 64997 neighbor 172.31.11.1 remote-as 65001 neighbor 172.31.11.2 remote-as 65001 neighbor 172.31.22.1 remote-as 65002 neighbor 172.31.22.2 remote-as 65002 no auto-summary ! no ip http server no ip http secure-server ip classless ! ! ! ! ! ! ! ! line con 0 exec-timeout 1000 0 privilege level 15 logging synchronous line aux 0 line vty 0 4 exec-timeout 1000 0 password cisco logging synchronous login ! ! end
-
amb1s1 Member Posts: 408Im only going to post BBR1, BBR2 and P1R1.
P1R1version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname P1R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
ip cef
no ip domain lookup
ip host bbr2 172.31.11.4 172.31.22.4 172.31.33.4 172.31.44.4 10.254.0.2
ip host bbr1 172.31.1.3 172.31.2.3 172.31.3.3 172.31.4.3 10.254.0.1
ip host P1R4 10.1.3.4 10.1.2.4 10.200.200.14
ip host P1R3 10.1.1.3 10.1.3.3 10.200.200.13
ip host P1R2 10.1.2.2 10.1.0.2 10.11.0.2 172.31.1.2 172.31.11.2 10.200.200.12
ip host P1R1 10.1.1.1 10.1.0.1 10.11.0.1 172.31.1.1 172.31.11.1 10.200.200.11
!
ip audit po max-events 100
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description - LAN connection to P1R3
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
description - Frame Relay connection to BBR1, DLCI 111
bandwidth 64
ip address 172.31.1.1 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 172.31.1.3 111 broadcast
no frame-relay inverse-arp
!
interface Serial1/1
description - HDLC connection to P1R2
bandwidth 64
ip address 10.1.0.1 255.255.255.0
serial restart-delay 0
clock rate 64000
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 10.1.0.0 0.0.0.255 area 0
network 10.1.1.0 0.0.0.255 area 1
!
no ip http server
no ip http secure-server
no ip classless
!
!
!
!
!
!
!
!
line con 0
exec-timeout 1000 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 1000 0
logging synchronous
no login
!
!
end -
mikej412 Member Posts: 10,086 ■■■■■■■■■■I think that's the topology used by Building Scalable Cisco Internetworks (BSCI) (Authorized Self-Study Guide) (link is to the latest 3rd edition).
There is no "single lab" for that topology -- there is an entire book.:mike: Cisco Certifications -- Collect the Entire Set! -
kpjungle Member Posts: 426mikej412 wrote:I think that's the topology used by Building Scalable Cisco Internetworks (BSCI) (Authorized Self-Study Guide) (link is to the latest 3rd edition).
There is no "single lab" for that topology -- there is an entire book.
Yep, I can confirm that. It seems to be the framework they use for all the labs in the Self-Study guide. In the first labs which ive done, you only use one pod (left or right side). So the configuration changes from time to time.Studying for CCNP (All done) -
tech-airman Member Posts: 953amb1s1 wrote:I'm doing a BSCI Lab. I configured P1R1, P1R2, P1R3 and P1R4 as OSPF and P2R1, P2R2, P2R3 and P2R4 as EIGRP. Now I can't make P1R1, P1R2, P1R3, P2R1, P2R2, BBR2 and BBR1 communicate through the frame. I'm using GNS3 emulator. I got this lab from a friend of my and he also gave me the initial configuration, but he didn't give me the goal of the lab. If anybody has done this lab before can you please explain me if I need to configure everything as OSPF and BGP or EIGRP and BGP. I will post the config on my next post
amb1s1,
Do you have a Frame Relay Switch router? -
scheistermeister Member Posts: 748 ■□□□□□□□□□From that config you interfaces are shutdown...Give a man fire and he'll be warm for a day. Set a man on fire and he'll be warm for the rest of his life.
-
amb1s1 Member Posts: 408I try to do no shut on the sub-interface on the BBR1 and BBR2 router, but they stay down. And about the frame switch, yes I have one.
-
scheistermeister Member Posts: 748 ■□□□□□□□□□amb1s1 wrote:I try to do no shut on the sub-interface on the BBR1 and BBR2 router, but they stay down. And about the frame switch, yes I have one.
Do it on the real interface.Give a man fire and he'll be warm for a day. Set a man on fire and he'll be warm for the rest of his life. -
amb1s1 Member Posts: 408I just did and the sub-interface are still down.
BBR1(config-if)#do sh ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.254.0.1 YES NVRAM up up
Serial1/0 unassigned YES NVRAM up up
Serial1/0.1 172.31.1.3 YES NVRAM down down
Serial1/0.2 172.31.2.3 YES NVRAM down down -
tech-airman Member Posts: 953amb1s1 wrote:I try to do no shut on the sub-interface on the BBR1 and BBR2 router, but they stay down. And about the frame switch, yes I have one.
amb1s1,
What routing protocol(s) are configured for the frame relay cloud? -
mikej412 Member Posts: 10,086 ■■■■■■■■■■amb1s1 wrote:Any help why the sub-interface won't turn up?amb1s1 wrote:And about the frame switch, yes I have one.
If you're using real hardware -- what are you using as your frame relay switch? Powered on? Configured properly? Cabled correctly?:mike: Cisco Certifications -- Collect the Entire Set! -
amb1s1 Member Posts: 408I'm using Dynamips with GNS3 and I'm using Frame switch. About which protocol i'm using, I used the initial config that my friend gave me and I can see that BBR1 have BGP, RIP, OSPF and EIGRP on its config.
-
mikej412 Member Posts: 10,086 ■■■■■■■■■■amb1s1 wrote:I'm using Dynamips with GNS3 and I'm using Frame switch.
I had issues loading existing Dynagen net files into GNS3 and getting them to work, which is one of the reasons I uninstalled it. The fact that it sucked down resources like there was no tomorrow was another reason.:mike: Cisco Certifications -- Collect the Entire Set! -
amb1s1 Member Posts: 408It was settup for Dynagen and I changed couple of things to make it work on GNS3.
-
amb1s1 Member Posts: 408I had issues loading existing Dynagen net files into GNS3 and getting them to work, which is one of the reasons I uninstalled it. The fact that it sucked down resources like there was no tomorrow was another reason.