Frame Relay LAB with PAT for my LAB
Hi ppl,
I need a little help from experts, I configure a simple Frame Relay Lab
Ok, here's is my network scenario
I have 3 routers R1 as ISP, R2 as FR SWITCH and R3 as Client
R1 ISP has Serial connection from R2 which is my FRSW and I can ping in both direction from R1 to R3 via FRSW
Now, on R1 I configure my interface Fasth connecting to my real NIC, so that I can perform PAT to have real connection
From R1 I can now ping my real networks from 192.7.3.0 to 255/30
I tried this from WAN/LAN using leased line simulation (not FRAME RELAY) and it did work
From R3 to R2 to R1 to the REAL networks I can ping and also use I have succesfully connecte to my proxy server.
But when I tried the Frame Relay Lab it did not work, from R3 to R2 acting as my FRSW to R1
I can't ping the real networks except only the interface that has PAT configuration (my fastehternet).
I am thinking about add route command but for sure it is for outside translation
Can I connect to real networks using my R3 .
I am doing for my QOS LAB
Though I can use LAN simulation I want to test FRTS and other stuff.
For your reference here's my config:
R1 as my ISP :
ISP#sh run
Building configuration...
Current configuration : 1446 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
bandwidth 2048
no ip address
ip nat inside
ip virtual-reassembly
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/0.1 point-to-point
ip address 172.16.1.1 255.255.255.252
frame-relay interface-dlci 201
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
description INTERNETCON
ip address 192.7.3.13 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
router eigrp 10
network 172.16.1.0 0.0.0.3
network 192.7.3.0
auto-summary
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
ip nat source list 101 interface FastEthernet2/0 overload
!
access-list 1 permit any
access-list 101 permit ip any any
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R2 as my FRSW
FRWSWITCH#sh run
Building configuration...
Current configuration : 1327 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FRWSWITCH
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
ip cef
!
ip audit po max-events 100
frame-relay switching
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface ATM1/0
no ip address
shutdown
no atm ilmi-keepalive
!
interface Serial3/0
bandwidth 2048
no ip address
encapsulation frame-relay
logging event subif-link-status
logging event dlci-status-change
clock rate 56000
no frame-relay inverse-arp
frame-relay intf-type dce
frame-relay route 201 interface Serial3/1 102
!
interface Serial3/1
bandwidth 2048
no ip address
encapsulation frame-relay
logging event subif-link-status
logging event dlci-status-change
clock rate 56000
no frame-relay inverse-arp
frame-relay intf-type dce
frame-relay route 102 interface Serial3/0 201
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
ip classless
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
!
end
And R3 as my client
Building configuration...
Current configuration : 1243 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname COMPA
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
bandwidth 2048
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/0.1 point-to-point
ip address 172.16.1.2 255.255.255.252
frame-relay interface-dlci 102
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 10
network 172.16.1.0 0.0.0.3
network 192.168.1.0
no auto-summary
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
COMPA#
Can you please help me with my simple lab, I need R3 to communicate to the real networks.
THANK YOU
I need a little help from experts, I configure a simple Frame Relay Lab
Ok, here's is my network scenario
I have 3 routers R1 as ISP, R2 as FR SWITCH and R3 as Client
R1 ISP has Serial connection from R2 which is my FRSW and I can ping in both direction from R1 to R3 via FRSW
Now, on R1 I configure my interface Fasth connecting to my real NIC, so that I can perform PAT to have real connection
From R1 I can now ping my real networks from 192.7.3.0 to 255/30
I tried this from WAN/LAN using leased line simulation (not FRAME RELAY) and it did work
From R3 to R2 to R1 to the REAL networks I can ping and also use I have succesfully connecte to my proxy server.
But when I tried the Frame Relay Lab it did not work, from R3 to R2 acting as my FRSW to R1
I can't ping the real networks except only the interface that has PAT configuration (my fastehternet).
I am thinking about add route command but for sure it is for outside translation
Can I connect to real networks using my R3 .
I am doing for my QOS LAB
Though I can use LAN simulation I want to test FRTS and other stuff.
For your reference here's my config:
R1 as my ISP :
ISP#sh run
Building configuration...
Current configuration : 1446 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
bandwidth 2048
no ip address
ip nat inside
ip virtual-reassembly
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/0.1 point-to-point
ip address 172.16.1.1 255.255.255.252
frame-relay interface-dlci 201
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
description INTERNETCON
ip address 192.7.3.13 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
router eigrp 10
network 172.16.1.0 0.0.0.3
network 192.7.3.0
auto-summary
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
ip nat source list 101 interface FastEthernet2/0 overload
!
access-list 1 permit any
access-list 101 permit ip any any
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R2 as my FRSW
FRWSWITCH#sh run
Building configuration...
Current configuration : 1327 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FRWSWITCH
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
ip cef
!
ip audit po max-events 100
frame-relay switching
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface ATM1/0
no ip address
shutdown
no atm ilmi-keepalive
!
interface Serial3/0
bandwidth 2048
no ip address
encapsulation frame-relay
logging event subif-link-status
logging event dlci-status-change
clock rate 56000
no frame-relay inverse-arp
frame-relay intf-type dce
frame-relay route 201 interface Serial3/1 102
!
interface Serial3/1
bandwidth 2048
no ip address
encapsulation frame-relay
logging event subif-link-status
logging event dlci-status-change
clock rate 56000
no frame-relay inverse-arp
frame-relay intf-type dce
frame-relay route 102 interface Serial3/0 201
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
ip classless
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
!
end
And R3 as my client
Building configuration...
Current configuration : 1243 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname COMPA
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
bandwidth 2048
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/0.1 point-to-point
ip address 172.16.1.2 255.255.255.252
frame-relay interface-dlci 102
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 10
network 172.16.1.0 0.0.0.3
network 192.168.1.0
no auto-summary
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
COMPA#
Can you please help me with my simple lab, I need R3 to communicate to the real networks.
THANK YOU
Comments
-
MACattack Member Posts: 121WellI guess I solve my problem, for those who read my post thank you.
I found the solution I need to apply my ip nat to my sub interface.