GNS3/Dynamips console problem

TalicTalic Member Posts: 423
I'm having a problem consoling into anything in GNS3. I have Putty installed and Telnet enabled in Vista 64 but it just gives me a error that says "The system cannot find the file specified".

The weird thing is it works fine on my laptop with Ubuntu just fine and I didn't do anything different.

Comments

  • rfult001rfult001 Member Posts: 407
    Dynamips and GNS3 don't play well with Vista at all. Run it in XP or Linux and it will work fine.
    icon_confused.gif
  • TalicTalic Member Posts: 423
    *sighs* I was hoping it wasn't that. Vista 64 has been playing well with any app. I've thrown at it.

    The lame thing is my machine doesn't play well with dual booting Linux either. I've tried doing everything imaginable to boot about 5 different Linux distros without any success. I've used MBR altering software in windows, replacing the MBR with grub, and not even the all mighty Ubuntu would want to work on a dual boot either.

    So yeah, Vista 64 can be pretty nasty when it doesn't want to do something it doesn't want to do icon_lol.gif

    Lame thing is the 32 bit version of Vista on my laptop accepted Ubuntu and any other Linux distro just fine.
  • ashrafneoashrafneo Member Posts: 10 ■□□□□□□□□□
    Hey! man I was having the same problem in Vista 32.
    The problem is the path to putty is not properly put into Preferences page in GNS3.
    Because I downloaded putty as a standlone .exe it does not get installed like a regular app.
    Therefore there is not a program file/putty folder. I suspect you have the same problem
    Find where putty is located in ur HD. Copy the Folderpath. then open GNS3. edit -> preferences.
    under terminal command there should be something like:
    C:\Program Files\Putty\putty.exe -telnet %h %p

    Paste ur folder path in here: and add "-telnet %h %p" lineFor ex. mine was in my docs.:

    C:\Users\VistaUSER\Documents\putty.exe -telnet %h %p
    Or you could just create the Putty folder in Program Files and drag and drop putty.exe in there.
    Hope this solves your problem
  • dynamikdynamik Banned Posts: 12,314 ■■■■■■■■□□
    Yea, you might want to run through the tutorial and make sure you've got everything setup right. I run it in Vista 64 with no problems.
Sign In or Register to comment.