Using a Subnetted IP address on a network

cmccul002cmccul002 Member Posts: 56 ■■□□□□□□□□
I was using Packet Tracer to setup a 3 router network connected with serial cables. I was trying to use 192.168.15.0 /30. So i have the networks 192.168.15.0 thru 192.168.15.3 (only using 15.1 and 15.2) another interface has the network 192.168.15.4 thru 192.168.15.7 (using 15.5 and 15.6)

I know this limits hosts, but it was enough. I set the interfaces IP address and Netmask. When I try to configure RIP and put in network 192.168.15.0 and then network 192.168.15.4 when i do a show run it just lists 192.168.15.0. Is this possible? or what am I doing wrong.

Comments

  • TalicTalic Member Posts: 423
    I think your doing your subnets wrong. The first connection should be 192.168.15.1 and .2, the broadcast is .3. The next network address is 192.168.15.4, so the next host addresses are 192.168.15.5 and .6 and so forth.
  • dynamikdynamik Banned Posts: 12,312 ■■■■■■■■■□
    I believe that's just how RIP works; it's enabled per classful network. If it's not working with subnets, make sure you're using version 2 along with no auto-summary.
  • /usr/usr Member Posts: 1,768
    Your subnetting is correct.

    What version of RIP are you using?

    It seems to me that your config is right. Are you not able to ping a remote host or something?
  • shednikshednik Member Posts: 2,005
    RIP v1 is a classfull routing protocol you can't do a /30 network only /8, /16, & /24. If using version 2 you will need to turn off auto-summary for it to utilize the VLSM.
  • cmccul002cmccul002 Member Posts: 56 ■■□□□□□□□□
    Update

    Im using Rip v2

    I can ping throughout the whole network, yet when I do a show run under rip it just shows 192.168.15.0

    I assume this is normal?
  • mattrgeemattrgee Member Posts: 201
    Yes it's normal assuming RIP is using auto-summary.

    As others have said, you need to do a 'no auto-summary' in order to use classless networks. You are specifying a 255.255.255.252 network which is a /30 classless mask. You have RIP running classfull mode (auto-summary) therefore it is summarising your /30 mask to the nearest class which is /24 hence why you only see the first 3 octets and not the last.

    Try this:

    Turn off auto-summary
    Remove the network statements
    Re-enter the network statements as you did originally.
    Now what do you see?
Sign In or Register to comment.