Keeping mapped drives mapped.

/usr/usr Member Posts: 1,768
I'm sure I should be aware of how to fix this problem, but I'm not.

Suppose I have a mapped drive that is used to run some application. After a while, or even on a reboot, running the application produces an error message. The fix to this problem is to open My Computer and double click the mapped drive. At this point, no authentication is necessary, it's like XP just has to be "reminded" that the connection still exists. After this, the application that relies on the mapped drive works just fine.

I have set the mapped drive to keep the connection persistent via the GUI option.

Do I have to set it via the net use /persistent command?

Comments

  • blargoeblargoe Self-Described Huguenot NC, USAMember Posts: 4,174 ■■■■■■■■■□
    JUST this one drive is having the problem, all others are fine?

    What is the os of the computer that hosts the mapped drive? I'm thinking there was something like this that was fixed in Server 2003 SP2.. but it's been a while since I've seen this occur
    IT guy since 12/00

    Recent: 11/2019 - RHCSA (RHEL 7); 2/2019 - Updated VCP to 6.5 (just a few days before VMware discontinued the re-cert policy...)
    Working on: RHCE/Ansible
    Future: Probably continued Red Hat Immersion, Possibly VCAP Design, or maybe a completely different path. Depends on job demands...
  • /usr/usr Member Posts: 1,768
    Nah, it's both drives I've mapped on the machine.

    XP SP3.
  • brad-brad- Member Posts: 1,218
    have you tried doing a net start script to remap them when the user logs in?

    something like "Net use x: \\servername\sharename /yes"
  • /usr/usr Member Posts: 1,768
    No, I haven't. There has to be a way to do this without using a script. I don't recall ever having this problem before (we have multiple people at work that run programs that use mapped drives as their start path).

    The drive is staying mapped and connected. Meaning when you open My Computer, regardless of a reboot, you will still see the drive there in a connected state (no X on it). When you double click it, it comes right up with no authentication necessary.

    The problem comes when the user tries to run the application without first opening the drive.
  • /usr/usr Member Posts: 1,768
    I mean, I guess I can just create a small batch file and just put it in the startup folder. I was just hoping to avoid that.
  • sprkymrksprkymrk Member Posts: 4,884 ■■■□□□□□□□
    Happens every time they launch the application, or just the first time they launch it after logging in/starting the computer?
    All things are possible, only believe.
  • vsmith3rdvsmith3rd Member Posts: 142 ■■■□□□□□□□
    Why would you want to avoid the batch file in the startup folder? This should run for 2 seconds, and be done. Plus it would resolve your issue.
    Certified Lunatic.
  • /usr/usr Member Posts: 1,768
    It doesn't resolve the issue now, because with WPA-PSK enabled, the batch files runs before the wireless connection is initialized.

    Hmmm....
Sign In or Register to comment.