Router on a stick problems

edster01edster01 Member Posts: 4 ■□□□□□□□□□
hey guys, so I'm trying to configure a basic router on a stick, followed a few guides and i think im doing everything right. any suggestions?

So I have a router --> switch --> two PC's

here the outputs:

ROUTER:

Router#sh run
Building configuration...

Current configuration : 851 bytes
!
version 12.2
no service password-encryption
!
hostname Router
!
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 172.17.98.1 255.255.255.128
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 172.17.98.129 255.255.255.128
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
!
interface Serial0/1
no ip address
shutdown
!
interface Serial0/2
no ip address
shutdown
!
interface Serial0/3
no ip address
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
shutdown
!
ip classless
!
!
!
!
!
line con 0
logging synchronous
line vty 0 4
login
!
!
end

SWITCH ONE:

Building configuration...

Current configuration : 1159 bytes
!
version 12.1
no service password-encryption
!
hostname Switch
!
!
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 172.17.98.2 255.255.255.128
!
interface Vlan20
ip address 172.17.98.130 255.255.255.128
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
en

OTHER INFO:

VLAN 10: 172.17.98.0/25
VLAN 20: 172.17.98.128/25

each vlan is its own subnet.

PC1:

IP: 172.17.98.3
SUB: 255.255.255.128
DG: 172.17.98.1

PC2:

172.17.98.31
255.255.255.128
172.17.98.129

SH VLAN:

Switch#sh vlan

VLAN Name Status Ports
----


1 default active Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
10 Kids active Fa0/2
20 Adults active Fa0/3
30 Animals active Fa0/4
99 Management active
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
----





----


1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
--More--

I did this in packet tracer, so I attached the file here, if you think that would be easier to troubleshoot. I just cant seem to figure out whats wrong. When a show arp command is done on the router i see nothing and im not sure why. what am i missing or have wrong?


http://www.yousendit.com/transfer.php?action=batch_download&batch_id=TTZuYURFMVhRYStGa1E9PQ

Thanks very much!![/b]

Comments

  • edster01edster01 Member Posts: 4 ■□□□□□□□□□
  • jmc012jmc012 Member Posts: 134
    Change IP on pc2, both PC's are on the same subnet. PC2's Default Gateway is on a different subnet than pc2.
  • edster01edster01 Member Posts: 4 ■□□□□□□□□□
    wow, i cant believe I didn't see that.

    Thanks jmc012, its much appreciated!
  • jmc012jmc012 Member Posts: 134
    I was fighting with exactly the same layout last week. icon_smile.gif I've been trying to work out as many simulator problems as I can before I try to take the test. I found the best thing after working on a problem for hours, is to forget about it for awhile and then come back to it. Usually the problem comes right to mind.
    Jim
  • kctxaukctxau Member Posts: 130
    jmc012 wrote:
    Change IP on pc2, both PC's are on the same subnet. PC2's Default Gateway is on a different subnet than pc2.
    Meaning change the default gateway address to the same IP address for both ?
  • jmc012jmc012 Member Posts: 134
    In this configuration he has sub-interfaces set up on the same physical interface on the router to be able to route between Vlans. Each sub-interface has a different IP on a different subnet so the PC's would need to be on separate subnets with different default gateways addresses for each of the sub-interfaces on the router.
  • TurgonTurgon Banned Posts: 6,308 ■■■■■■■■■□
    kctxau wrote:
    jmc012 wrote:
    Change IP on pc2, both PC's are on the same subnet. PC2's Default Gateway is on a different subnet than pc2.
    Meaning change the default gateway address to the same IP address for both ?

    Nope.

    Change PC2's ip address. This is no good because the gateway is not on it's subnet.

    172.17.98.31
    255.255.255.128
    172.17.98.129

    Change PC2's ip address to one from the 172.17.98.128 subnet and you should be good to go.
  • edster01edster01 Member Posts: 4 ■□□□□□□□□□
    thanks guys for your amazing help. but now i got myself into more trouble!

    I added another switch and a few more PC's. everything works great! so i decided to add another link from the two switches, that way, if one link went down, the network will still stay up.

    I configured PVST and STP, and modified the priority values. Now if i remember, the low priority becomes root, so i made sure that the S0 switch had a lower priority then s1. Although when i use th command sh spanning-tree and i look at which switch was elected the bridge, S1 always becomes the bridge, even tho the S0 priority is lower.

    the funny thing is, as soon as i remove the redundancy link, the whole network fine and amazing!

    im stuck.

    http://www.yousendit.com/transfer.php?action=batch_download&batch_id=TTZrT2pPZ2pkMnQzZUE9PQ
  • miller811miller811 Member Posts: 897
    looking at your config switch 0 and switch 1 still have the default priority
    since they are tied, it defaults to the mac address,. and switch 1 has a lower mac address so it become the root bridge on all vlans.

    from switch 0's perspecitive

    Priority 32769
    Address 0001.427D.B359
    Cost 19
    Port 5(FastEthernet0/5)
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
    Address 000C.85A4.C2D4
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
    Aging Time 20

    From switch 1's perspecitve
    VLAN0001
    Spanning tree enabled protocol rstp
    Root ID Priority 32769
    Address 0001.427D.B359
    This bridge is the root
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
    Address 0001.427D.B359
    Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
    Aging Time 20
    I don't claim to be an expert, but I sure would like to become one someday.

    Quest for 11K pages read in 2011
    Page Count total to date - 1283
Sign In or Register to comment.