OSPF issue in Olive

hakim.kasmanhakim.kasman Member Posts: 2 ■□□□□□□□□□
Hi all,
I'm from Malaysia and this is my 1st post. Currently I'm working with Juniper product and I'm preparing for my JNCIA-M exam.

I've setup Olive in Qemu and able to run RIP in the Olive. The problem that I'm having is OSPF. I've configured OSPF in the Olive but I'm not able to ping the loopback IP address of the other end.

I configured 3 olive in the same area (area 0) and all of them able to see each other (show ospf route) but I'm not able to ping other end loopbackIP.

Does anyone ever encounter this problem?

Router: Central-01
[edit]
[email protected]# show protocols ospf
area 0.0.0.10 {
interface fxp0.10;
interface fxp0.11;
}

[email protected]# show interfaces
fxp0 {
vlan-tagging;
unit 1 {
vlan-id 1;
family inet {
address 172.16.1.1/31;
}
}
unit 2 {
vlan-id 2;
family inet {
address 172.16.2.1/31;
}
}
unit 10 {
vlan-id 10;
family inet {
address 10.10.1.1/31;
}
}
unit 11 {
vlan-id 11;
family inet {
address 10.10.2.1/31;
}
}
}
lo0 {
unit 0 {
family inet {
address 192.168.5.5/32;
}
}
}

[email protected]> show ospf route
Prefix Path Route NH Metric NextHop Nexthop
Type Type Type Interface addr/label
192.168.6.6 Intra Router IP 1 fxp0.10 10.10.1.0
192.168.7.7 Intra Router IP 1 fxp0.11 10.10.2.0
10.10.1.0/31 Intra Network IP 1 fxp0.10
10.10.2.0/31 Intra Network IP 1 fxp0.11

[email protected]> show route protocol ospf

inet.0: 10 destinations, 10 routes (10 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

224.0.0.5/32 *[OSPF/10] 00:37:59, metric 1
MultiRecv

__juniper_private2__.inet.0: 1 destinations, 1 routes (0 active, 0 holddown, 1 hidden)

[email protected]> ping 10.10.1.0
PING 10.10.1.0 (10.10.1.0): 56 data bytes
64 bytes from 10.10.1.0: icmp_seq=0 ttl=64 time=1.851 ms
^C
--- 10.10.1.0 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max/stddev = 1.851/1.851/1.851/0.000 ms

[email protected]> ping 10.10.2.0
PING 10.10.2.0 (10.10.2.0): 56 data bytes
64 bytes from 10.10.2.0: icmp_seq=0 ttl=64 time=2.453 ms
^C
--- 10.10.2.0 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max/stddev = 2.453/2.453/2.453/0.000 ms

[email protected]> ping 192.168.6.6
PING 192.168.6.6 (192.168.6.6): 56 data bytes
ping: sendto: No route to host
^C
--- 192.168.6.6 ping statistics ---
1 packets transmitted, 0 packets received, 100% packet loss

[email protected]> ping 192.168.7.7
PING 192.168.7.7 (192.168.7.7): 56 data bytes
ping: sendto: No route to host
^C
--- 192.168.7.7 ping statistics ---
1 packets transmitted, 0 packets received, 100% packet loss

Router: Central-02
[edit]
[email protected]# show protocols ospf
area 0.0.0.10 {
interface fxp0.10;
}

[edit]
[email protected]# show interfaces
fxp0 {
vlan-tagging;
unit 1 {
vlan-id 1;
family inet {
address 192.168.100.1/24;
}
}
unit 10 {
vlan-id 10;
family inet {
address 10.10.1.0/31;
}
}
}
lo0 {
unit 0 {
family inet {
address 192.168.6.6/32;
}
}
}

Router: Central-03
[edit]
[email protected]# show protocols ospf
area 0.0.0.10 {
interface fxp0.10;
}

[edit]
[email protected]# show interfaces
fxp0 {
vlan-tagging;
unit 1 {
vlan-id 1;
family inet {
address 192.168.101.1/24;
}
}
unit 10 {
vlan-id 11;
family inet {
address 10.10.2.0/31;
}
}
}
lo0 {
unit 0 {
family inet {
address 192.168.7.7/32;
}
}
}

Comments

Sign In or Register to comment.