Options

Chasing Connectivity Problems

boostinbadgerboostinbadger Member Posts: 256
I have three routers: FRS_2610, R2_1721, R3_1721. Each one has one WIC 2A/S. The FRS uses both and the other two use S0. FRS is the DCE for both S0 and S1 and has a clock rate of 115200 on both interfaces. Here are the addresses and routes:

FRS_2610
S0 - 172.12.123.1/24
S1 - 172.12.123.4/24
loopback - 1.1.1.1
show ip route:
Gateway of last resort is 172.12.123.2 to network 0.0.0.0
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
172.12.0.0/24 is subnetted, 1 subnets
C 172.12.123.0 is directly connected, Serial0/1
is directly connected, Serial0/0
S* 0.0.0.0/0 [1/0] via 172.12.123.2


R2_1721
S0 - 172.12.123.2/24
loopback - 2.2.2.2
show ip route:
Gateway of last resort is not set
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
172.12.0.0/24 is subnetted, 1 subnets
C 172.12.123.0 is directly connected, Serial0


R3_1721
S0 - 172.12.123.3/24
loopback - 3.3.3.3
show ip route:
Gateway of last resort is not set
2.0.0.0/24 is subnetted, 1 subnets
S 2.2.2.0 [1/0] via 172.12.123.4
3.0.0.0/24 is subnetted, 1 subnets
C 3.3.3.0 is directly connected, Loopback0
172.12.0.0/24 is subnetted, 1 subnets
C 172.12.123.0 is directly connected, Serial0

I can ping all interfaces then I try to ping R2's loopback from R3 and it fails. After I do that, at least one interface will not be able to ping another until I do a shut/no shut.

Has anyone else run into this before?

Comments

  • Options
    BADfish10BADfish10 Member Posts: 88 ■■□□□□□□□□
    Hi

    from your config it looks like every interface you have is in the same subnet.
    172.12.123.x
    255.255.255.0
    and unless i'm mistaken that will not work from a routing perspective Please correct if i am wrong.

    For serial interfaces 1 to 1 you might want to look at using a /30 subnet as well so:
    172.12.123.0 mask 255.255.255.252
    interface ip 172.12.123.1 and 172.12.123.2
    172.12.123.4 mask 255.255.255.252
    interface 172.12.123.5 and 172.12.123.6

    Cheers

    James
  • Options
    kalebkspkalebksp Member Posts: 1,033 ■■■■■□□□□□
    Are you doing frame relay? If so, the frame-relay switch doesn't get an IP address. It's a switch, moving packets at layer 2.
  • Options
    boostinbadgerboostinbadger Member Posts: 256
    I will be doing frame relay at some point. Right now I am using the FRS as a hub and R2 and R3 as spokes. I am doing this word for word from The Bryant Advantage book.
  • Options
    kalebkspkalebksp Member Posts: 1,033 ■■■■■□□□□□
    So you're not using frame relay, right? If that's the case then BADfish10 would be correct. The FRS router thinks it has two interfaces connecting to the same network, and therefor that it can reach R2 and R3 from either interface. Each link needs it's own subnet.
  • Options
    boostinbadgerboostinbadger Member Posts: 256
    That is correct. I am not using frame relay. I will have to come up with a better addressing scheme.
  • Options
    boostinbadgerboostinbadger Member Posts: 256
    I understand why this wouldn't work now, but according to the manual I have it set correctly. This is how it reads:

    Frame Relay (serial interfaces, all routers) 172.12.123.x/24
    R2's loopback 2.2.2.2/24
    R3's loopback 3.3.3.3/24

    Where did I go wrong? When I assigned the WIC 2A/S on the FRS with .1 and .4?
  • Options
    kalebkspkalebksp Member Posts: 1,033 ■■■■■□□□□□
    It sounds like the manual is using frame relay. A frame relay topology doesn't work the same as a point to point topology.

    As I mentioned before a frame relay switch is similar to an Ethernet switch, it's ports don't get assigned IP addresses, all it does is move frames from one port to another port based on the layer 2 address (DLCIs). The biggest difference between a frame relay and Ethernet switch is that you have to statically configure the mappings of ports to layer 2 addresses. Which is why you want the two routers in the same subnet when they're connected via a switch, and you want them in different subnets when they are connected via another router.

    EDIT: I added that last sentence above, I forgot to finish my thought.
  • Options
    boostinbadgerboostinbadger Member Posts: 256
    It shows three routers all connected to a frame relay cloud. Two routers having a loopback. It mentions frame relay but says that it isn't important for this particular lab. He calls it a hub and spoke network with R1 being the hub and R2 and R3 the spokes.

    If anyone has The Bryant Advantage Ultimate CCNA manual it is Chapter 8 of ICND 1.
  • Options
    kalebkspkalebksp Member Posts: 1,033 ■■■■■□□□□□
    That's a pretty typical frame relay point-to-multipoint/hub-and-spoke lab. I'm not sure why he would say that the frame relay part wasn't important, because it won't work with out that. Maybe he was just using it as an example, and not yet expecting you to configure it. In a lab configuration, that frame relay cloud is another router configured as a FR switch. So to do that lab you would need a total of four routers.
  • Options
    boostinbadgerboostinbadger Member Posts: 256
    I think you are right. I don't think I was necessarily supposed to configure that. That topology is part of the larger one that I will be using later. I actually have a rack with four routers and three switches for when it comes time for all of that. I was using the left over routers when I configured the network in question. Thanks kalebksp
  • Options
    boostinbadgerboostinbadger Member Posts: 256
    On another note, why would all the routers be happy pinging each other until I tried to ping the loopback on R2 from R3? I guess it all worked until it had to use the statically configured route???
  • Options
    kalebkspkalebksp Member Posts: 1,033 ■■■■■□□□□□
    Honestly, I'm not sure why it worked until you tried pinging loopbacks. Maybe someone who knows more than myself can answer that.
  • Options
    mamonomamono Member Posts: 776 ■■□□□□□□□□
    What are the full configs for each?
  • Options
    BADfish10BADfish10 Member Posts: 88 ■■□□□□□□□□
    On another note, why would all the routers be happy pinging each other until I tried to ping the loopback on R2 from R3? I guess it all worked until it had to use the statically configured route???

    i did a Quick lab and i dont think that all worked before compleatly! well that was not what i got bare in mind i was the wrong side of several stella's though!
    any way from hub pinging spoke's all grovy then ping hub from spoke 1 all fine but then hub from spoke 2 gave an unreachable was sort of expecting it not to supprised.
    doing a sh ip route on the Hub gave me a fun output will post when i get home.
    in the diagram are you looking at are you sure there is not a different ip in the 3rd octet on 1 of the links i know i have fun trying to see them sometimes.

    Cheers

    J
  • Options
    boostinbadgerboostinbadger Member Posts: 256
    I thought I might be looking at the addresses wrong too. I went over them several times but I have it right.

    Here are the configs:

    FRS_2610#show conf
    Using 985 out of 29688 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname FRS_2610
    !
    boot-start-marker
    boot-end-marker
    !
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    ip audit po max-events 100
    !
    interface Loopback0
    ip address 1.1.1.1 255.255.255.0
    !
    interface Ethernet0/0
    no ip address
    shutdown
    half-duplex
    !
    interface Serial0/0
    ip address 172.12.123.1 255.255.255.0
    clock rate 115200
    no fair-queue
    !
    interface Serial0/1
    ip address 172.12.123.4 255.255.255.0
    clock rate 115200
    !
    ip http server
    no ip http secure-server
    ip classless
    ip route 0.0.0.0 0.0.0.0 172.12.123.2
    !
    line con 0
    exec-timeout 0 0
    password 7 001012050F570E040039
    logging synchronous
    login
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    password 7 120D0414190709062533
    logging synchronous
    login
    line vty 5 15
    exec-timeout 0 0
    password 7 120D0414190709062533
    logging synchronous
    login
    !
    end


    R2_1721#show conf
    Using 615 out of 29688 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname R2_1721
    !
    boot system flash c1700-y-mz.122-4.YA2.bin
    !
    ip subnet-zero
    no ip domain-lookup
    !
    interface Loopback0
    ip address 2.2.2.2 255.255.255.0
    !
    interface FastEthernet0
    no ip address
    shutdown
    speed auto
    !
    interface Serial0
    ip address 172.12.123.2 255.255.255.0
    !
    interface Serial1
    no ip address
    shutdown
    !
    ip classless
    no ip http server
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    password
    logging synchronous
    login
    line aux 0
    line vty 0 4
    no login
    !
    end


    R3_1721#show conf
    Using 649 out of 29688 bytes
    !
    version 12.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname R3_1721
    !
    ip subnet-zero
    !
    interface Loopback0
    ip address 3.3.3.3 255.255.255.0
    !
    interface FastEthernet0
    no ip address
    shutdown
    speed auto
    !
    interface Serial0
    ip address 172.12.123.3 255.255.255.0
    no fair-queue
    !
    interface Serial1
    no ip address
    shutdown
    !
    ip classless
    ip route 2.2.2.0 255.255.255.0 172.12.123.4
    no ip http server
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    password 7 03105A080D03244E4111
    logging synchronous
    login
    line aux 0
    line vty 0 4
    !
    no scheduler allocate
    end




    I took out a bunch of "!"
  • Options
    boostinbadgerboostinbadger Member Posts: 256
    I know we have established this but it was clearly in the addressing. I moved on to freshen up on RIP and designed the IP scheme with class A private and have it working properly. Each router has its own loopback and I can freely ping all interfaces; physical and logical. I have verified the adverts with the debug command and show ip route rip as well.
  • Options
    BADfish10BADfish10 Member Posts: 88 ■■□□□□□□□□
    Defo looks that way! Good luck with the rip labs,
    did you check the website of the material provider as they some times publish there bluper as part of there updated online Apendix icon_redface.gif.
    also i have been working my way through Cisco press stuffs were most loop back interfaces are /32 subnets Eg 1.1.1.1 255.255.255.255 this should not have any effect to the labs you are doing just wondering if there was a reason to give a /24 subnet mentioned in your material.

    Cheers

    J
  • Options
    boostinbadgerboostinbadger Member Posts: 256
    You are right about the mask. It should have been /32.
  • Options
    boostinbadgerboostinbadger Member Posts: 256
    I set up my 2610 as a frame switch between two routers but I can't get serial 0/1 to show active. Here is the config:

    FRS_2610#show conf
    Using 1174 out of 29688 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname FRS_2610
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$vDB0$iH1Ss3L6YHyaVv/CSn5O40
    enable password 7 010707075007030D2E54
    !
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    no ip domain lookup
    !
    ip audit po max-events 100
    frame-relay switching
    !
    interface Ethernet0/0
    no ip address
    shutdown
    half-duplex
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    logging event subif-link-status
    logging event dlci-status-change
    clock rate 56000
    no frame-relay inverse-arp
    frame-relay intf-type dce
    frame-relay route 122 interface Serial0/1 221
    !
    interface Serial0/1
    no ip address
    encapsulation frame-relay
    logging event subif-link-status
    logging event dlci-status-change
    clock rate 56000
    no frame-relay inverse-arp
    frame-relay intf-type dce
    frame-relay route 221 interface Serial0/0 122
    !
    ip http server
    no ip http secure-server
    ip classless
    !
    line con 0
    exec-timeout 0 0
    password 7 120D0414190709062533
    logging synchronous
    login
    line aux 0
    line vty 0 4
    !
    end

    FRS_2610#show frame route
    Input Intf Input Dlci Output Intf Output Dlci Status
    Serial0/0 122 Serial0/1 221 active
    Serial0/1 221 Serial0/0 122 inactive
  • Options
    BADfish10BADfish10 Member Posts: 88 ■■□□□□□□□□
    Ok i am not sure if there is somthing funky you are trying to do here so tell me if there is.

    i may be wrong but i dont think you need the Clock rate as it is Frame relay also are you trying to get sub interfaces working ?

    i would have a guess at!

    Interface Serial0/0
    encapsulation frame-relay IETF
    frame-relay interface-dlci 221

    remember the Dlci is localy significant only check on the frame relay switch

    interface Serial0/1
    encapsulation frame-relay IETF
    frame-relay interface-dlci 122

    Is there 2 frame relay switches ?

    is this the same 3 router setup you were doing before ?

    Cheers

    J
  • Options
    mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    I can't get serial 0/1 to show active
    If this is a back-to-back cable, are you sure you have the DCE end on the FRS router?

    do a show controllers serial 0/1 and see that it recognizes the cable.

    The router on the other end is up and configured, right?
    :mike: Cisco Certifications -- Collect the Entire Set!
  • Options
    boostinbadgerboostinbadger Member Posts: 256
    My bad. I forgot to mention that I completely started over. I am using three routers now. One is a frame switch.

    The back to back cable was positioned correctly. Both routers are up and configured.
Sign In or Register to comment.