Voice VLans... Trunk and access mode

jonmo2578jonmo2578 Member Posts: 14 ■□□□□□□□□□
Hey guys..

We have got some 2950s and 3500s switches which have got IP phones plugged in and are working fine. Ports are currently configured as trunks and voice traffic has been put into the separate voice vlan 222.. IP phones and the end PCs are correctly picking up their associated VLans..

I have just tried to put the ports into access mode and respecify the voice vlan as follows..

int fa 0/4
switchport mode access
switchport voice vlan 222
** we dont use any additional prioritization for voice on the LAN..

Anyway, once I make the change, the end PC picks up the correct native access VLan and works fine..
However, tHe IP phone loses registration with the call manager and just cycles on Configuring IP.. On full factory reset it appears that it now cannot pick up any IP address at all, so Im guessing the switch does not recognise the phone device at all and doesnt issue the correct voice Vlan ( 222 )..

As soon as I put the port back into trunk mode, everything is happy and the phone and pc pick up their correct vlans..

This is happening with both our 2950s and 3500s..

Has anyone had this problem or have any suggestions ??.. Probably forgotten something really simple !!..

Thanks in advance...

Comments

  • mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    Is the DHCP server accessible from the new voice vlan?

    Did you define a new scope for the new subnet for that new vlan?

    Is the DHCP server in that VLAN now or do you have an ip-helper command configured somewhere?

    Is routing enabled somewhere for that new voice vlan?

    Can a PC put in that in that vlan ping the CallManager server? Can it ping the FTP server?
    :mike: Cisco Certifications -- Collect the Entire Set!
  • PStefanovPStefanov Member Posts: 79 ■■□□□□□□□□
    You must configure the ports to the phones as trunks or leave them in any of the dynamic modes (you've got to lab this, but I think it's ok), but you must not configure them in access mode. The reason why is because a special 802.1Q rudimentary trunk is created when using a separate vlan for voice and for data. The native vlan of the trunk is the vlan used by PCs attached to the phones and the voice vlan is used by phones.
  • jonmo2578jonmo2578 Member Posts: 14 ■□□□□□□□□□
    Thanks for all your responses guys..

    Had a trawl through the official cisco forum site last night and it turns out that this is a common problem with older 2950s and 3500s.. An update to the IOS allows this to work in access mode..

    Cheers

    Jon.
  • dumontrdumontr Registered Users Posts: 2 ■□□□□□□□□□
    jonmo2578 wrote: »
    Hey guys..

    We have got some 2950s and 3500s switches which have got IP phones plugged in and are working fine. Ports are currently configured as trunks and voice traffic has been put into the separate voice vlan 222.. IP phones and the end PCs are correctly picking up their associated VLans..

    I have just tried to put the ports into access mode and respecify the voice vlan as follows..

    int fa 0/4
    switchport mode access
    switchport voice vlan 222
    ** we dont use any additional prioritization for voice on the LAN..

    Anyway, once I make the change, the end PC picks up the correct native access VLan and works fine..
    However, tHe IP phone loses registration with the call manager and just cycles on Configuring IP.. On full factory reset it appears that it now cannot pick up any IP address at all, so Im guessing the switch does not recognise the phone device at all and doesnt issue the correct voice Vlan ( 222 )..

    As soon as I put the port back into trunk mode, everything is happy and the phone and pc pick up their correct vlans..

    This is happening with both our 2950s and 3500s..

    Has anyone had this problem or have any suggestions ??.. Probably forgotten something really simple !!..

    Thanks in advance...


    on the router did you set up a sub interface IE
    router#(config)interface fast0/0.222
    encapsulation PPP
    ip address the gate way to the scope in DHCP
    ip helper-address ( ip address of the DHCP Server)

    also did you set up the options in the DHCP server for the Phones
    242 for Cisco 96XX and 176 for 46XX


    on the switch this works for us

    switchport mode access
    switchport voice vlan 100
    switchport priority extend trust
    srr-queue bandwidth share 10 10 60 20
    srr-queue bandwidth shape 10 0 0 0
    queue-set 2
    priority-queue out
    mls qos trust device cisco-phone
    mls qos trust cos
    auto qos voip cisco-phone
    macro description cisco-phone
    no cdp enable
    spanning-tree portfast
    spanning-tree bpduguard enable
    service-policy input AutoQoS-Police-CiscoPhone
  • pitviperpitviper CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT Member Posts: 1,376 ■■■■■■■□□□
    OP is 2 and a half years old - I think it's safe to assume that he's all set by now :)
    CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT
  • networker050184networker050184 Mod Posts: 11,962 Mod
    pitviper wrote: »
    OP is 2 and a half years old - I think it's safe to assume that he's all set by now :)

    And I highly doubt he needs PPP encapsulation there!
    An expert is a man who has made all the mistakes which can be made.
  • mikearamamikearama Member Posts: 749
    This looks like fun. I think I'll start looking for 2 year old posts, and add some comments. Hehe... I need to get my post count up anyway! :)
    There are only 10 kinds of people... those who understand binary, and those that don't.

    CCIE Studies: Written passed: Jan 21/12 Lab Prep: Hours reading: 385. Hours labbing: 110

    Taking a time-out to add the CCVP. Capitalizing on a current IPT pilot project.
  • ITdudeITdude Member Posts: 1,181 ■■■□□□□□□□
    Oldies but goodies!:) icon_wink.gif
    I usually hang out on 224.0.0.10 (FF02::A) and 224.0.0.5 (FF02::5) when I'm in a non-proprietary mood.

    __________________________________________
    Simplicity is the ultimate sophistication.
    (Leonardo da Vinci)
Sign In or Register to comment.