Bad FXS card?

NetwurkNetwurk Posts: 1,155Member ■■■■□□□□□□
I don't claim to be a voice expert, but I can't get my VIC-2FXS to provide a dial tone to any of my analog phones. I've even tried the debug voip ccapi all (which shows you all calls, including any attempt to take a phone off hook).

My thinking is that even if my config isn't good, the FXS port should be able to at least provide a dial tone. Have tried to connect with both crossover and straight-through cables.

Anyone know any other debug or show commands that can help troubleshoot a possible bad FXS card? Running 12.4(T) on a 2691

Comments

  • empc4000xlempc4000xl Posts: 322Member
    Netwurk wrote: »
    I don't claim to be a voice expert, but I can't get my VIC-2FXS to provide a dial tone to any of my analog phones. I've even tried the debug voip ccapi all (which shows you all calls, including any attempt to take a phone off hook).

    My thinking is that even if my config isn't good, the FXS port should be able to at least provide a dial tone. Have tried to connect with both crossover and straight-through cables.

    Anyone know any other debug or show commands that can help troubleshoot a possible bad FXS card? Running 12.4(T) on a 2691

    when its plugged in you should get tone. Reading that you are on a 2691 do you have the voice module. I'm not sure if anything in the 2600 series could use the voice cards without the voice module.
  • mikej412mikej412 Posts: 10,090Member
    Do you have the VIC-2FXS installed in an NM-1V or NM-2V?

    Do you see the voice ports in the configuration and when you do a show version command?

    Do you see the VIC-2FXS when you do a show diag?

    Do you have an AIM-ATM installed?
    :mike: Cisco Certifications -- Collect the Entire Set!
  • NetwurkNetwurk Posts: 1,155Member ■■■■□□□□□□
    It's in a NM-2V paired with a VIC-2FXO

    You can see it in show ver and show diag

    No AIM-ATM is installed, it does have an AIM-VPN which shouldn't affect voice as far as I know
  • mikej412mikej412 Posts: 10,090Member
    Netwurk wrote: »
    My thinking is that even if my config isn't good, the FXS port should be able to at least provide a dial tone. Have tried to connect with both crossover and straight-through cables.
    What is your configuration?

    The VIC-2FXS should accept an RJ-11 plug -- and the cable is just a regular phone cable.

    What does the output of a show voice summary give you?

    What does the output of a show voice port give you (for the port you're plugged in)?

    What does show voice call summary give you?

    Does anything change when you go off hook (lift up the phone handset)?

    What IOS feature set and version are you using.
    :mike: Cisco Certifications -- Collect the Entire Set!
  • NetwurkNetwurk Posts: 1,155Member ■■■■□□□□□□
    Here's the relevant part of the show diag output:

    Slot 1:
    4 PORT Voice PM for MARs Port adapter
    Port adapter is analyzed
    Port adapter insertion time unknown
    EEPROM contents at hardware discovery:
    Hardware revision 1.1 Board revision K0
    Serial number 27000003 Part number 800-02491-02
    FRU Part Number NM-2V=
    Test history 0x0 RMA number 00-00-00
    EEPROM format version 1
    EEPROM contents (hex):
    0x00: 01 65 01 01 01 A1 CD 1F 50 09 BB 02 00 00 00 00
    0x10: A0 00 00 00 01 12 11 17 FF FF FF FF FF FF FF FF
    0x20: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
    0x30: FF FF FF FF FF FF FF FF FF FF FF FF

    VIC Slot 0:
    FXS Voice daughter card (2 port)
    Hardware revision 1.1 Board revision G0
    Serial number 320000001 Part number 800-02493-04
    FRU Part Number VIC-2FXS=
    Test history 0x0 RMA number 00-00-00
    Connector type Wan Module
    EEPROM format version 1
    EEPROM contents (hex):
    0x20: 01 0E 01 01 01 E8 84 F6 50 09 BD 04 00 00 00 00
    0x30: 80 00 00 00 04 03 19 01 FF FF FF FF FF FF FF FF


    Going off hook generates nothing when debugging (unless I take one of my 7940's off hook, then I get tons of code).

    Will try to put together the relevant parts of the config when I have a chance. I have CME running, so the config is huge
  • mrblackmamba343mrblackmamba343 Posts: 136Inactive Imported Users
    can I see a "show run" of the routers config
  • NetwurkNetwurk Posts: 1,155Member ■■■■□□□□□□
    Opened the thread to see if I forgot any show or debug commands to troubleshoot the card.

    No sense posting the whole config as I doubt it's a config issue. I'm going to try to get myself a known good card to test with. Thanks everybody.
  • APAAPA Posts: 959Member
    hey mate,

    Quite possible your FXS card is dead....

    I finally received my 2 x VIC-2FXS today and NM-2V.... got dial tone straight away with no config on the voice ports...

    All I've done is create my pots dial-peers and my voip dial peers... necessary to make actual calls.

    CCNA | CCNA:Security | CCNP | CCIP
    JNCIA:JUNOS | JNCIA:EX | JNCIS:ENT | JNCIS:SEC
    JNCIS:SP | JNCIP:SP
  • NetwurkNetwurk Posts: 1,155Member ■■■■□□□□□□
    A.P.A wrote: »
    hey mate,

    Quite possible your FXS card is dead....

    I finally received my 2 x VIC-2FXS today and NM-2V.... got dial tone straight away with no config on the voice ports...

    All I've done is create my pots dial-peers and my voip dial peers... necessary to make actual calls.

    Yeah I think you are right that the card's DOA

    I waited too long to test it or I might have been able to do something with the 30-day warranty

    But the router rocks as a CME and all my IP Phones play nicely with it so I think I did OK

    icon_cool.gif
  • APAAPA Posts: 959Member
    you should get into the habit of testing bits of hardware as soon as you get it!!! Saves you from the problem you're having now, especially if you get another DOA piece.

    We spend so much on this stuff!!! Worth the time and effort :)

    CCNA | CCNA:Security | CCNP | CCIP
    JNCIA:JUNOS | JNCIA:EX | JNCIS:ENT | JNCIS:SEC
    JNCIS:SP | JNCIP:SP
  • NetwurkNetwurk Posts: 1,155Member ■■■■□□□□□□
    A.P.A wrote: »
    you should get into the habit of testing bits of hardware as soon as you get it!!! Saves you from the problem you're having now, especially if you get another DOA piece.

    We spend so much on this stuff!!! Worth the time and effort :)

    Agree with you there. I thought I had tested everything the day I got it. But I neglected to plug in an analog phone until this week. Oh well. Live and learn.

    :)
  • NetwurkNetwurk Posts: 1,155Member ■■■■□□□□□□
    UPDATE: Finally got another FXS card and like APA said, you can plug a phone in and get a dial tone right away. Glad that solved it, since some of the troubleshooting guides from Cisco made me think I might have a bad NM-2V.

    Popped in this config:

    dial-peer voice 100 pots
    destination-pattern 1234
    port 1/0/0


    And then I could call my IP Phones, so all is good.

    :)
  • Fish!Fish! Posts: 42Member ■■□□□□□□□□
    I have had horrible luck with Cisco FXS ports being bad. In fact just today I received an eBay VIC-2FXS with one bad port. I have an IAD2432 in my lab rack and of its 24 FXS ports only 10 really work. another 8 or so have HORRIBLE line noise, and the balance show perpetually off-hook in show voice port summary, no dial-tone at all.

    An FXS port with default config should give a nice clean dial tone. Anything else is bad hardware (or incompatible! Always check your show diag).
Sign In or Register to comment.