Options

Rip redistribution problem

EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
Sorry no diagram.
I've got 3 routers R1,R4 and R5.

R1 f0/0 is connected to R4 e0/0, subnet 140.1.14.0/24
R4 s1/0 is connected to R5 s1/0 via FR subnet 140.1.245.0/24
R4 s1/1 is connected to R5 s1/1 via ppp subnet 140.1.45.0/24

Rip is running between R1 and R4, and also on the ppp link between R4 and R5.
Ospf is running over the FR link.

Both R4 and R5 are redistributing rip into ospf.My problem is with the network 150.1.1.0 i.e. lo0 of R1 that is being advertised into RIP.


If i change the distance of the route on R5 so that its preferred via RIP, i get a routing loop.

Logs are below, anyone have any idea what i'm missing? I'm not interested in a solution, i want to understand whats happening.


R1

interface Loopback0
ip address 150.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 140.1.14.1 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 140.1.0.0
network 150.1.0.0
no auto-summary
!
!
access-list 1 permit 150.1.1.0
!
route-map lo0 permit 10
match ip address 1
!



R4

interface Loopback0
ip address 150.1.4.4 255.255.255.0
ip ospf network point-to-point
!
interface Ethernet0/0
ip address 140.1.14.4 255.255.255.0
full-duplex
!
interface Serial1/0
ip address 140.1.245.4 255.255.255.0
encapsulation frame-relay
ip ospf priority 0
serial restart-delay 0
frame-relay map ip 140.1.245.5 405 broadcast
no frame-relay inverse-arp
!
interface Serial1/1
ip address 140.1.45.4 255.255.255.0
encapsulation ppp
serial restart-delay 0
!
!
router ospf 1
router-id 4.4.4.4
log-adjacency-changes
redistribute rip metric 100 subnets
network 140.1.245.4 0.0.0.0 area 0
!
router rip
version 2
passive-interface default
no passive-interface Ethernet0/0
no passive-interface Serial1/1
network 140.1.0.0
no auto-summary



R5

interface Loopback0
ip address 150.1.5.5 255.255.255.0
ip ospf network point-to-point
!
!
!
interface Serial1/0
ip address 140.1.245.5 255.255.255.0
encapsulation frame-relay
ip ospf priority 255
serial restart-delay 0
frame-relay map ip 140.1.245.4 504 broadcast
no frame-relay inverse-arp
!
interface Serial1/1
ip address 140.1.45.5 255.255.255.0
encapsulation ppp
serial restart-delay 0
!
!
router ospf 1
router-id 5.5.5.5
log-adjacency-changes
area 3 stub
redistribute rip metric 101 subnets
network 140.1.245.5 0.0.0.0 area 0
neighbor 140.1.245.4
!
router rip
version 2
passive-interface default
no passive-interface Serial1/1
network 140.1.0.0
no auto-summary
!


Rack1R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

140.1.0.0/16 is variably subnetted, 4 subnets, 2 masks
R 140.1.245.0/24 [120/1] via 140.1.14.4, 00:00:06, FastEthernet0/0
C 140.1.14.0/24 is directly connected, FastEthernet0/0
R 140.1.45.0/24 [120/1] via 140.1.14.4, 00:00:06, FastEthernet0/0
R 140.1.45.5/32 [120/1] via 140.1.14.4, 00:00:06, FastEthernet0/0
150.1.0.0/24 is subnetted, 1 subnets
C 150.1.1.0 is directly connected, Loopback0
Rack1R1#



Rack1R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

140.1.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 140.1.245.0/24 is directly connected, Serial1/0
C 140.1.14.0/24 is directly connected, Ethernet0/0
C 140.1.45.0/24 is directly connected, Serial1/1
C 140.1.45.5/32 is directly connected, Serial1/1
150.1.0.0/24 is subnetted, 2 subnets
C 150.1.4.0 is directly connected, Loopback0
R 150.1.1.0 [120/1] via 140.1.14.1, 00:00:09, Ethernet0/0
Rack1R4#



Rack1R5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

140.1.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 140.1.245.0/24 is directly connected, Serial1/0
O E2 140.1.14.0/24 [110/100] via 140.1.245.4, 00:06:12, Serial1/0
C 140.1.45.0/24 is directly connected, Serial1/1
C 140.1.45.4/32 is directly connected, Serial1/1
150.1.0.0/24 is subnetted, 2 subnets
C 150.1.5.0 is directly connected, Loopback0
O E2 150.1.1.0 [110/100] via 140.1.245.4, 00:06:12, Serial1/0



Rack1R4#sh ip rip database
140.1.0.0/16 auto-summary
140.1.14.0/24 directly connected, Ethernet0/0
140.1.45.0/24 directly connected, Serial1/1
140.1.45.5/32 directly connected, Serial1/1
140.1.245.0/24 directly connected, Serial1/0
150.1.0.0/16 auto-summary
150.1.1.0/24
[1] via 140.1.14.1, 00:00:21, Ethernet0/0



Rack1R5#sh ip rip database
140.1.0.0/16 auto-summary
140.1.45.0/24 directly connected, Serial1/1
140.1.45.4/32 directly connected, Serial1/1
140.1.245.0/24 directly connected, Serial1/0
Rack1R5#


Rack1R5#debug ip rip
RIP protocol debugging is on
Rack1R5#
*Mar 1 03:47:18.683: RIP: sending v2 update to 224.0.0.9 via Serial1/1 (140.1.45.5)
*Mar 1 03:47:18.687: RIP: build update entries
*Mar 1 03:47:18.687: 140.1.245.0/24 via 0.0.0.0, metric 1, tag 0
Rack1R5#
*Mar 1 03:47:29.027: RIP: received v2 update from 140.1.45.4 on Serial1/1
*Mar 1 03:47:29.031: 140.1.14.0/24 via 0.0.0.0 in 1 hops
*Mar 1 03:47:29.035: 140.1.245.0/24 via 0.0.0.0 in 1 hops
*Mar 1 03:47:29.035: 150.1.1.0/24 via 0.0.0.0 in 2 hops
Rack1R5#




Rack1R5(config)#access-list 1 permit 150.1.1.0
Rack1R5(config-router)#distance 109 140.1.45.4 0.0.0.0 1

THe route 150.1.1.0/24 is now flapping due to a loop.

Rack1R5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

140.1.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 140.1.245.0/24 is directly connected, Serial1/0
O E2 140.1.14.0/24 [110/100] via 140.1.245.4, 00:10:24, Serial1/0
C 140.1.45.0/24 is directly connected, Serial1/1
C 140.1.45.4/32 is directly connected, Serial1/1
150.1.0.0/24 is subnetted, 2 subnets
C 150.1.5.0 is directly connected, Loopback0
O E2 150.1.1.0 [110/100] via 140.1.245.4, 00:10:24, Serial1/0
Rack1R5#
*Mar 1 03:50:08.587: %SYS-5-CONFIG_I: Configured from console by console
Rack1R5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

140.1.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 140.1.245.0/24 is directly connected, Serial1/0
R 140.1.14.0/24 [109/1] via 140.1.45.4, 00:00:02, Serial1/1
C 140.1.45.0/24 is directly connected, Serial1/1
C 140.1.45.4/32 is directly connected, Serial1/1
150.1.0.0/24 is subnetted, 1 subnets
C 150.1.5.0 is directly connected, Loopback0
Rack1R5#





Rack1R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

140.1.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 140.1.245.0/24 is directly connected, Serial1/0
C 140.1.14.0/24 is directly connected, Ethernet0/0
C 140.1.45.0/24 is directly connected, Serial1/1
C 140.1.45.5/32 is directly connected, Serial1/1
150.1.0.0/24 is subnetted, 2 subnets
C 150.1.4.0 is directly connected, Loopback0
O E2 150.1.1.0 [110/101] via 140.1.245.5, 00:00:06, Serial1/0
Rack1R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

140.1.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 140.1.245.0/24 is directly connected, Serial1/0
C 140.1.14.0/24 is directly connected, Ethernet0/0
C 140.1.45.0/24 is directly connected, Serial1/1
C 140.1.45.5/32 is directly connected, Serial1/1
150.1.0.0/24 is subnetted, 1 subnets
C 150.1.4.0 is directly connected, Loopback0




Rack1R4#debug ip rip
RIP protocol debugging is on
Rack1R4#
*Mar 1 03:55:10.935: RIP: received v2 update from 140.1.14.1 on Ethernet0/0
*Mar 1 03:55:10.939: 150.1.1.0/24 via 0.0.0.0 in 1 hops
Rack1R4#
*Mar 1 03:55:12.035: RIP: received v2 update from 140.1.45.5 on Serial1/1
*Mar 1 03:55:12.039: 140.1.245.0/24 via 0.0.0.0 in 1 hops
*Mar 1 03:55:12.043: 150.1.1.0/24 via 0.0.0.0 in 16 hops (inaccessible)
*Mar 1 03:55:12.947: RIP: sending v2 flash update to 224.0.0.9 via Ethernet0/0 (140.1.14.4)
*Mar 1 03:55:12.947: RIP: build flash update entries - suppressing null update
*Mar 1 03:55:12.947: RIP: sending v2 flash update to 224.0.0.9 via Serial1/1 (140.1.45.4)
*Mar 1 03:55:12.947: RIP: build flash update entries
*Mar 1 03:55:12.947: 150.1.1.0/24 via 0.0.0.0, metric 2, tag 0
*Mar 1 03:55:12.963: RIP:rip_lost_route for 150.1.1.0 255.255.255.0
Rack1R4#
*Mar 1 03:55:14.963: RIP: sending v2 flash update to 224.0.0.9 via Ethernet0/0 (140.1.14.4)
*Mar 1 03:55:14.967: RIP: build flash update entries
*Mar 1 03:55:14.967: 150.1.1.0/24 via 0.0.0.0, metric 16, tag 0
*Mar 1 03:55:14.971: RIP: sending v2 flash update to 224.0.0.9 via Serial1/1 (140.1.45.4)
*Mar 1 03:55:14.971: RIP: build flash update entries
*Mar 1 03:55:14.971: 150.1.1.0/24 via 0.0.0.0, metric 16, tag 0
Rack1R4#
*Mar 1 03:55:16.963: RIP: received v2 update from 140.1.45.5 on Serial1/1
*Mar 1 03:55:16.967: 150.1.1.0/24 via 0.0.0.0 in 16 hops (inaccessible)



Rack1R5#debug ip rip
RIP protocol debugging is on
Rack1R5#
*Mar 1 03:52:15.155: RIP: sending v2 flash update to 224.0.0.9 via Serial1/1 (140.1.45.5)
*Mar 1 03:52:15.159: RIP: build flash update entries - suppressing null update
*Mar 1 03:52:15.179: RIP: received v2 update from 140.1.45.4 on Serial1/1
*Mar 1 03:52:15.183: 150.1.1.0/24 via 0.0.0.0 in 16 hops (inaccessible)
Rack1R5#
*Mar 1 03:52:17.183: RIP: sending v2 flash update to 224.0.0.9 via Serial1/1 (140.1.45.5)
*Mar 1 03:52:17.187: RIP: build flash update entries
*Mar 1 03:52:17.187: 150.1.1.0/24 via 0.0.0.0, metric 16, tag 0
Rack1R5#
*Mar 1 03:52:32.411: RIP: received v2 update from 140.1.45.4 on Serial1/1
*Mar 1 03:52:32.411: 140.1.14.0/24 via 0.0.0.0 in 1 hops
*Mar 1 03:52:32.411: 140.1.245.0/24 via 0.0.0.0 in 1 hops
*Mar 1 03:52:32.411: 150.1.1.0/24 via 0.0.0.0 in 16 hops (inaccessible)
Rack1R5#
*Mar 1 03:52:40.391: RIP: received v2 update from 140.1.45.4 on Serial1/1
*Mar 1 03:52:40.395: 150.1.1.0/24 via 0.0.0.0 in 2 hops
*Mar 1 03:52:41.127: RIP: sending v2 update to 224.0.0.9 via Serial1/1 (140.1.45.5)
*Mar 1 03:52:41.127: RIP: build update entries
*Mar 1 03:52:41.127: 140.1.245.0/24 via 0.0.0.0, metric 1, tag 0
Rack1R5#
*Mar 1 03:52:42.399: RIP: sending v2 flash update to 224.0.0.9 via Serial1/1 (140.1.45.5)
*Mar 1 03:52:42.403: RIP: build flash update entries - suppressing null update
*Mar 1 03:52:42.415: RIP: received v2 update from 140.1.45.4 on Serial1/1
*Mar 1 03:52:42.419: 150.1.1.0/24 via 0.0.0.0 in 16 hops (inaccessible)
Networking, sometimes i love it, mostly i hate it.Its all about the $$$$

Comments

  • Options
    kryollakryolla Member Posts: 785
    Let me see if I can explain it. R4 sends its directly connected ethernet link and the loopback network of R1 to R5 via RIP and OSPF. R5 installs the OSPF routes due to a lower AD. R5 does not having any RIP routes in the RIB so it doesn't do any redistro. So all is good

    R5 changes the AD for the loopback of R1 and now installs it as a RIP route and now redistro it to OSPF. Now R4 has to make a decision because it sees the loopback of R1 via the ethernet link and FR OSPF link and install the OSPF route. R4 then invalidates that network and poisons the route to R5. R4 will then go through this withdraw and advertise loop to R5.

    Hopefully I got this right.
    Studying for CCIE and drinking Home Brew
  • Options
    tech-airmantech-airman Member Posts: 953
    EdTheLad,

    What is your VLSM subnetting for OSPF?
  • Options
    EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    Good stuff Kryolla, thanks for that, i was getting confused with the rip database, i see it now.Since R4 learns the route to the loopback via ospf, the route is removed from the rip database on R4,once its removed a poison route is sent to R5 and the cycle begins.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Options
    EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    EdTheLad,

    What is your VLSM subnetting for OSPF?

    What have you done with tech-airman, the other day you post about "the other side of the routing process", now asking about vlsm when the configs are included.The tech-airman of old would never have made these mishaps.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Options
    APAAPA Member Posts: 959
    so Ed, now that you understand what is occuring... do you know how to fix it???

    and I don't mean by taking away the redistribution command.... :)

    CCNA | CCNA:Security | CCNP | CCIP
    JNCIA:JUNOS | JNCIA:EX | JNCIS:ENT | JNCIS:SEC
    JNCIS:SP | JNCIP:SP
  • Options
    gojericho0gojericho0 Member Posts: 1,059 ■■■□□□□□□□
    A.P.A is the goal to get the routing to work with by keeping the AD on R5 to allow it to prefer RIP?
  • Options
    EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    A.P.A wrote: »
    so Ed, now that you understand what is occuring... do you know how to fix it???

    and I don't mean by taking away the redistribution command.... :)

    Yeah, fixing it is the easy part, just change ad on R4 to 109 for the loopback route.Or even filtering the redistribution on R5 would also work.Anyway i learned something from this, i always overlooked the rip database in the past, i now see its important when it comes to redistribution.Before i didnt realise that if a route was not present in the rib it would not be in the rip database,this is what caused my confusion,
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Options
    kryollakryolla Member Posts: 785
    There can be multiple solutions depending on what link is more prefered or more stable. I wouldnt do any filtering on R5 due to having redundant links to the same network but might make one less prefered than the other using prefix length or some other means. You can also put a distro list on R4 in from FR link.
    Studying for CCIE and drinking Home Brew
Sign In or Register to comment.