router on a stick...

snickeredsnickered Posts: 25Member ■□□□□□□□□□
I have R1->S1->S2->R2

The ports of the link between S1 and S2 are trunk ports on native VLAN1.
The port on S2 connected to R2 is a trunk port native VLAN1.
R2 has the IP addresses of:
fa0/0.1 - 192.168.51.2/24 (VLAN1)
fa0/0.2 - 192.168.52.2/24 (VLAN2)
R1 has the IP address of:
fa0/0 - 192.168.51.1/24

R2 cannot ping 192.168.51.1 when 192.168.52.2 is specified as the source IP address.

On R2 I have:
ip route 0.0.0.0 0.0.0.0 192.168.51.1

And R1 I have:
ip route 192.168.52.0 255.255.255.0 192.168.51.2

I suspect that I need to put a subinterface on R1 but I can't see why. When I ping to 192.168.51.1 from 192.168.52.2 I would think the packet would be able to get to R1 because the next-hop is 192.168.51.1 which is connected via 192.168.51.2.

I'm confused... can someone explain what I'm doing wrong?

Comments

  • luke_bibbyluke_bibby Posts: 162Member
    have u configured dot1q or isl encapsulation on the router?

    As an example on R2:
    R2(config)# int fa 0/0.1
    R2(config-subif)# encapsulation dot1q
    R2(config-subif)# ip address 192.168.51.2 255.255.255.0
    R2(config-subif)# int fa 0/0.2
    R2(config-subif)# encapsulation dot1q 2
    R2(config-subif)# ip address 192.168.51.2 255.255.255.0

    Are your trunks on the switch to the router configured to always trunk cause routers cant negotiate trunks using DTP.

    As an example on S2:
    S2(config-if)# descr Trunk to R2
    S2(config-if)# switchport mode trunk
    S2(config-if)# switchport trunk encapsulation dot1q

    S2(config-if)# switchport trunk nonegotiate
  • snickeredsnickered Posts: 25Member ■□□□□□□□□□
    Yes, AFAIK you can't assign an IP address to a subinterface without specifying the encapsulation first so I left that out. Also, 'sh int trunk' shows that the ports are all 802.1q.
  • luke_bibbyluke_bibby Posts: 162Member
    Ya good point, sorry!
  • kryollakryolla Posts: 785Member
    can r1 ping 192.168.51.2 and then ping 192.168.52.2. if r1 cant reach 52.2 then debug ip packet and see whats failing. if nothing is wrong then go to r2 and debug ip pack and see if you are receiving the pings and what is causing the failure of you responding to it.
    Studying for CCIE and drinking Home Brew
  • snickeredsnickered Posts: 25Member ■□□□□□□□□□
    Sorry guys... it ended up being an ACL that was causing the issue. Thanks for the tips though. I'll look for these things in the future.
Sign In or Register to comment.