EBGP issues/question
Ok I have four routers, connected in a string like this:
R1 <-> R2 <-> R3 <-> R4
R1 = AS200
R2 = AS100
R3 = AS300
R4 = AS400
Now, all routers can talk to each other (Directly connected neighbors, via ping and they all show as neighbors, just the directly connected neighbors).
However R1 doesn't get routing updates for R4 and R3.....
Here are the configs for BGP For reach router:
R1
router bgp 200
no synchronization
bgp log-neighbor-changes
network 12.0.1.0 mask 255.255.255.0
network 210.210.210.0
neighbor 10.0.0.2 remote-as 100
no auto-summary
!
R2
router bgp 100
no synchronization
bgp log-neighbor-changes
network 192.168.0.0
network 192.168.1.0
neighbor 10.0.0.1 remote-as 200
neighbor 172.16.0.1 remote-as 300
no auto-summary
!
R3
router bgp 300
no synchronization
bgp log-neighbor-changes
network 172.16.1.0 mask 255.255.255.0
neighbor 172.16.0.2 remote-as 100
neighbor 172.16.3.2 remote-as 400
no auto-summary
!
R4
router bgp 400
no synchronization
bgp log-neighbor-changes
network 11.1.1.0 mask 255.255.255.0
neighbor 172.16.3.1 remote-as 300
no auto-summary
!
Once again all routers can see, and ping directly connected neighbors. And all routers are getting route updates for all interfaces from all 4 routers... but I can't send traffic from R1 to R4 (even though there are routes in the routing tables for R4 in R1 etc.....).....
I am certain it is my configuration, but I could use a suggestion.
Thanks
R1 <-> R2 <-> R3 <-> R4
R1 = AS200
R2 = AS100
R3 = AS300
R4 = AS400
Now, all routers can talk to each other (Directly connected neighbors, via ping and they all show as neighbors, just the directly connected neighbors).
However R1 doesn't get routing updates for R4 and R3.....
Here are the configs for BGP For reach router:
R1
router bgp 200
no synchronization
bgp log-neighbor-changes
network 12.0.1.0 mask 255.255.255.0
network 210.210.210.0
neighbor 10.0.0.2 remote-as 100
no auto-summary
!
R2
router bgp 100
no synchronization
bgp log-neighbor-changes
network 192.168.0.0
network 192.168.1.0
neighbor 10.0.0.1 remote-as 200
neighbor 172.16.0.1 remote-as 300
no auto-summary
!
R3
router bgp 300
no synchronization
bgp log-neighbor-changes
network 172.16.1.0 mask 255.255.255.0
neighbor 172.16.0.2 remote-as 100
neighbor 172.16.3.2 remote-as 400
no auto-summary
!
R4
router bgp 400
no synchronization
bgp log-neighbor-changes
network 11.1.1.0 mask 255.255.255.0
neighbor 172.16.3.1 remote-as 300
no auto-summary
!
Once again all routers can see, and ping directly connected neighbors. And all routers are getting route updates for all interfaces from all 4 routers... but I can't send traffic from R1 to R4 (even though there are routes in the routing tables for R4 in R1 etc.....).....
I am certain it is my configuration, but I could use a suggestion.
Thanks
encrypt the encryption, never mind my brain hurts.
Comments
-
EdTheLad Member Posts: 2,111 ■■■■□□□□□□On quick glance R1 is peering with R2 neighbor 10.0.0.2, this suggests to me R1 probably has an ip address 10.0.0.1, you are not advertising network 10.0.0.0 into bgp.How will R4 know the return path to R1 if it doesnt know about 10.x.x.x ? Same thing goes on R4 for 172.16.3.0, how will R1 know this network?Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
-
kalebksp Member Posts: 1,033 ■■■■■□□□□□On quick glance R1 is peering with R2 neighbor 10.0.0.2, this suggests to me R1 probably has an ip address 10.0.0.1, you are not advertising network 10.0.0.0 into bgp.How will R4 know the return path to R1 if it doesnt know about 10.x.x.x ? Same thing goes on R4 for 172.16.3.0, how will R1 know this network?
Maybe I don't understand, but these are EBGP peers, why would R4 need NLRI for R1? The advertisements from R3 to R4 would have a next hop of R3, wouldn't it?
EDIT: Nevermind, I see what you're saying. I thought the problem was R1 not getting routes from R3 and R4. R4 does need NLRI for R1 if you're pinging from R1 (or ping using the loopbacks you are advertising as the source). -
kryolla Member Posts: 785the transit links shouldn't get advertised only networks but when he pings to a remote network he has to source his pings from the local network. OP did you ping x.x.x.x source x.x.x.xStudying for CCIE and drinking Home Brew
-
networker050184 Mod Posts: 11,962 Modthe transit links shouldn't get advertised only networks but when he pings to a remote network he has to source his pings from the local network. OP did you ping x.x.x.x source x.x.x.x
+1
This is a common issue I have seen with BGP in a lab enviroment where you are testing your config by pinging from one of the routers.An expert is a man who has made all the mistakes which can be made. -
liven Member Posts: 918On quick glance R1 is peering with R2 neighbor 10.0.0.2, this suggests to me R1 probably has an ip address 10.0.0.1, you are not advertising network 10.0.0.0 into bgp.How will R4 know the return path to R1 if it doesnt know about 10.x.x.x ? Same thing goes on R4 for 172.16.3.0, how will R1 know this network?
Well on R1 and R2 the 10.x.x.x is the /30 that connects R1, and R2.
Originally this lab environment is a three router setup from the cisco BCSI lab manual.
R1 <-> R2 <-> R3 were in the lab book from cisco. They can all communicate with each other and ping all addresses/interfaces on all devices. I added R4 and that is really where the problem is. R1, R2, and R3 can all communicate (ping all networks/interfaces), but R3 is the only router that can ping R4's interfaces. All of the other devices see R4's advertised routes, but R2 and R1 can not route traffic to it.encrypt the encryption, never mind my brain hurts. -
liven Member Posts: 918Post sh ip bgp and sh ip bgp summ.
R1
ISP1#show ip bgp
BGP table version is 7, local router ID is 210.210.210.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 11.1.1.0/24 10.0.0.2 0 100 300 400 i
*> 12.0.1.0/24 0.0.0.0 0 32768 i
*> 172.16.1.0/24 10.0.0.2 0 100 300 i
*> 192.168.0.0 10.0.0.2 0 0 100 i
*> 192.168.1.0 10.0.0.2 0 0 100 i
*> 210.210.210.0 0.0.0.0 0 32768 i
ISP1#show ip bgp summary
BGP router identifier 210.210.210.1, local AS number 200
BGP table version is 7, main routing table version 7
6 network entries using 702 bytes of memory
6 path entries using 312 bytes of memory
5/4 BGP path/bestpath attribute entries using 620 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1706 total bytes of memory
BGP activity 20/14 prefixes, 26/20 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.0.2 4 100 3097 3096 7 0 0 1d23h 4
R2
R2#show ip bgp
BGP table version is 7, local router ID is 192.168.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 11.1.1.0/24 172.16.0.1 0 300 400 i
*> 12.0.1.0/24 10.0.0.1 0 0 200 i
*> 172.16.1.0/24 172.16.0.1 0 0 300 i
*> 192.168.0.0 0.0.0.0 0 32768 i
*> 192.168.1.0 0.0.0.0 0 32768 i
*> 210.210.210.0 10.0.0.1 0 0 200 i
R2#show ip bg
R2#show ip bgp summ
R2#show ip bgp summary
BGP router identifier 192.168.1.1, local AS number 100
BGP table version is 7, main routing table version 7
6 network entries using 702 bytes of memory
6 path entries using 312 bytes of memory
5/4 BGP path/bestpath attribute entries using 620 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1706 total bytes of memory
BGP activity 13/7 prefixes, 29/23 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.0.1 4 200 3099 3103 7 0 0 1d23h 2
172.16.0.1 4 300 3076 3081 7 0 0 1d23h 2
R3
R3(config)#end
R3#show ip bg
*Mar 3 03:12:51.503: %SYS-5-CONFIG_I: Configured from console by consolep
BGP table version is 11, local router ID is 172.16.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 11.1.1.0/24 172.16.3.2 0 0 400 i
*> 12.0.1.0/24 172.16.0.2 0 100 200 i
*> 172.16.1.0/24 0.0.0.0 0 32768 i
*> 192.168.0.0 172.16.0.2 0 0 100 i
*> 192.168.1.0 172.16.0.2 0 0 100 i
*> 210.210.210.0 172.16.0.2 0 100 200 i
R3#show ip bgp summary
BGP router identifier 172.16.1.1, local AS number 300
BGP table version is 11, main routing table version 11
6 network entries using 702 bytes of memory
6 path entries using 312 bytes of memory
5/4 BGP path/bestpath attribute entries using 620 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1706 total bytes of memory
BGP activity 13/7 prefixes, 15/9 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
172.16.0.2 4 100 3080 3075 11 0 0 1d23h 4
172.16.3.2 4 400 2882 2887 11 0 0 1d23h 1
R4
R4#show ip bgp
BGP table version is 19, local router ID is 11.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 11.1.1.0/24 0.0.0.0 0 32768 i
*> 12.0.1.0/24 172.16.3.1 0 300 100 200 i
*> 172.16.1.0/24 172.16.3.1 0 0 300 i
*> 192.168.0.0 172.16.3.1 0 300 100 i
*> 192.168.1.0 172.16.3.1 0 300 100 i
*> 210.210.210.0 172.16.3.1 0 300 100 200 i
R4#show ip bgp sum
R4#show ip bgp summary
BGP router identifier 11.1.1.1, local AS number 400
BGP table version is 19, main routing table version 19
6 network entries using 702 bytes of memory
6 path entries using 312 bytes of memory
5/4 BGP path/bestpath attribute entries using 620 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1706 total bytes of memory
BGP activity 12/6 prefixes, 12/6 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
172.16.3.1 4 300 2898 2890 19 0 0 2d00h 5encrypt the encryption, never mind my brain hurts. -
ColbyG Member Posts: 1,264Sorry, I read the question wrong, those weren't needed. You said they weren't getting routing updates, but then later you said they were getting routes, you just weren't able to ping to R4, is that right or am I still confused?
Try a traceroute to see where the traffic is dropping, also try sourcing your ping from an interface that is known by R4. -
liven Member Posts: 918Sorry, I read the question wrong, those weren't needed. You said they weren't getting routing updates, but then later you said they were getting routes, you just weren't able to ping to R4, is that right or am I still confused?
Try a traceroute to see where the traffic is dropping, also try sourcing your ping from an interface that is known by R4.
The issue is None of the routers can ping R4, except R3....
Routes all seem to be in place.
I will try sourcing my pings.encrypt the encryption, never mind my brain hurts. -
kalebksp Member Posts: 1,033 ■■■■■□□□□□Are you running an IGP or have static routes on R3? If you don't I don't see how a ping from R1 with the default source could be replied to by R3.
-
liven Member Posts: 918Are you running an IGP or have static routes on R3? If you don't I don't see how a ping from R1 with the default source could be replied to by R3.
No IGP, just BGP....
Sourcing the pings works for most of the interfaces.....encrypt the encryption, never mind my brain hurts. -
ColbyG Member Posts: 1,264Sourcing the pings works for most of the interfaces.....
You are being so vague with everything. If sourcing the pings from other interfaces works then the issue is obviously that R4 doesn't know a way back to the interface it sees as the source of the pings (the pings that fail). -
liven Member Posts: 918You are being so vague with everything. If sourcing the pings from other interfaces works then the issue is obviously that R4 doesn't know a way back to the interface it sees as the source of the pings (the pings that fail).
It is not my intentions to be vague.....
Sorry if I frustrated you!encrypt the encryption, never mind my brain hurts. -
kpjungle Member Posts: 426Try and make a loopback on R1, advertise this loopback into BGP. Also try and make a loopback on R4, again advertise this into BGP.
From R1, source a ping to the loopback on R4 from R1's loopback. That way R4 will be able to reply to a source it knows how to reach.
See if that works.
Again, verify BGP table.Studying for CCNP (All done) -
rossonieri#1 Member Posts: 799 ■■■□□□□□□□hi liven,
let me help you a little bit, i've tried to simulate my gns as close as your scenario
[edited]
after fixing the route to be exactly like yours - indeed, R3 and R4 has that 172.16.3.0 disabled, hence R1, R2, R3 dont have it.
R4 :r4>sh ip bgp BGP table version is 21, local router ID is 10.10.50.1 Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, r RIB-failure, S Stale Origin codes: i - IGP, e - EGP, ? - incomplete Network Next Hop Metric LocPrf Weight Path *> 11.1.1.0/24 0.0.0.0 0 32768 i *> 12.0.1.0/24 172.16.3.1 0 300 100 200 i *> 172.16.1.0/24 172.16.3.1 0 0 300 i *> 192.168.0.0 172.16.3.1 0 300 100 i *> 192.168.1.0 172.16.3.1 0 300 100 i *> 210.210.210.0 172.16.3.1 0 300 100 200 i
work around? inject a static route into BGP.
HTH.the More I know, that is more and More I dont know.