Hosts plugged into 2801 WIC not receiving DHCP
I've got a bit of a random question, hopefully someone can shed a little light.
I often configure 2801 routers to act as DHCP servers. Another network admin, while working on a config, made a mistake and it got me wondering.
He has DHCP configured on the router:
ip dhcp pool client
network 192.168.1.0 255.255.255.0
dns-server 4.2.2.2 4.2.2.3
default-router 192.168.1.1
Normally, I configure VLAN1 as a routed interface (VRI):
interface Vlan1
ip address 192.168.1.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
Under the above config, DHCP will work fine, assuming the host is plugged into the 4 port WIC.
When the other admin did the config, he put the VLAN1 config under FA0/1. His VLAN1 config is blank, ie, the only command is 'no ip address'.
When a host is plugged into the 4 port WIC, they are not receiving an IP. Is this because the host is expecting the WIC port to be routed and it has no IP, or am I missing something?
I often configure 2801 routers to act as DHCP servers. Another network admin, while working on a config, made a mistake and it got me wondering.
He has DHCP configured on the router:
ip dhcp pool client
network 192.168.1.0 255.255.255.0
dns-server 4.2.2.2 4.2.2.3
default-router 192.168.1.1
Normally, I configure VLAN1 as a routed interface (VRI):
interface Vlan1
ip address 192.168.1.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
Under the above config, DHCP will work fine, assuming the host is plugged into the 4 port WIC.
When the other admin did the config, he put the VLAN1 config under FA0/1. His VLAN1 config is blank, ie, the only command is 'no ip address'.
When a host is plugged into the 4 port WIC, they are not receiving an IP. Is this because the host is expecting the WIC port to be routed and it has no IP, or am I missing something?
_______LAB________
2x 2950
2x 3550
2x 2650XM
2x 3640
1x 2801
2x 2950
2x 3550
2x 2650XM
2x 3640
1x 2801
Comments
-
Panzer919 Member Posts: 462This is how we do it on our 1811
ip dhcp excluded-address 192.168.2.1 192.168.2.9
ip dhcp excluded-address 192.168.3.1 192.168.3.9
ip dhcp excluded-address 192.168.4.1 192.168.4.9
ip dhcp excluded-address 192.168.5.1 192.168.5.9
ip dhcp excluded-address 192.168.6.1 192.168.6.9
ip dhcp excluded-address 192.168.7.1 192.168.7.9
ip dhcp excluded-address 192.168.8.1 192.168.8.9
ip dhcp excluded-address 192.168.9.1 192.168.9.9
!
ip dhcp pool 100
network 192.168.2.0 255.255.255.0
dns-server 24.29.161.129 24.29.161.137
default-router 192.168.2.1
lease 0 0 20
!
ip dhcp pool 101
network 192.168.3.0 255.255.255.0
dns-server 24.29.161.129 24.29.161.137
default-router 192.168.3.1
lease 0 0 20
!
ip dhcp pool 102
network 192.168.4.0 255.255.255.0
dns-server 24.29.161.129 24.29.161.137
default-router 192.168.4.1
lease 0 0 20
!
ip dhcp pool 103
network 192.168.5.0 255.255.255.0
dns-server 24.29.161.129 24.29.161.137
default-router 192.168.5.1
lease 0 0 20
!
ip dhcp pool 104
network 192.168.6.0 255.255.255.0
dns-server 24.29.161.129 24.29.161.137
default-router 192.168.6.1
lease 0 0 20
!
ip dhcp pool 105
network 192.168.7.0 255.255.255.0
dns-server 24.29.161.129 24.29.161.137
default-router 192.168.7.1
lease 0 0 20
!
ip dhcp pool 106
network 192.168.8.0 255.255.255.0
dns-server 24.29.161.129 24.29.161.137
default-router 192.168.8.1
lease 0 0 20
!
ip dhcp pool 107
network 192.168.9.0 255.255.255.0
dns-server 24.29.161.129 24.29.161.137
default-router 192.168.9.1
lease 0 0 20
!
ip dhcp pool 108
lease 0 0 20
!
interface FastEthernet2
description 100
switchport access vlan 100
duplex full
speed 10
!
interface FastEthernet3
description 101
switchport access vlan 101
duplex full
speed 10
!
interface FastEthernet4
description 102
switchport access vlan 102
duplex full
speed 10
!
interface FastEthernet5
description 103
switchport access vlan 103
duplex full
speed 10
!
!
interface Vlan1
no ip address
!
interface Vlan100
ip address 192.168.2.1 255.255.255.0
!
interface Vlan101
ip address 192.168.3.1 255.255.255.0
!
interface Vlan102
ip address 192.168.4.1 255.255.255.0
!
interface Vlan103
ip address 192.168.5.1 255.255.255.0Cisco Brat Blog
I think “very senior” gets stuck in there because the last six yahoos that applied for the position couldn’t tell a packet from a Snickers bar.
Luck is where opportunity and proper planning meet
I have not failed. I've just found 10,000 ways that won't work.
Thomas A. Edison -
APA Member Posts: 959The 4-Port HWIC is a essentially a 4-port switch for your router..... it in no way is a set of 4 routed ports....
Being switchports they have the ability for dot1q, switchport modes, vlan assignments etc....
So for DHCP to work in this instance you need to assign an SVI (Vlan1 being default) and then assign the relevant ports on your HWIC to the the same vlan as you created the SVI for.
Your configuration worked because VLAN1 is the default VLAN for all switchports... as soon as you assigned and address to SVI Vlan1 all you had to do was plug a host into one of the HWIC ports and away she went
If you colleague wants to use the inbuilt routed port for DHCP assignment... he needs to either leave the dot1q sub-inteface and connect the routed port to a dot1q trunked switchport (NOT THE HWIC!!!).... or remove the sub-interface configuration and assign 192.168.1.0/24 to the routed port (Fa0/1) then plug a host into that port directly or connect it to a switch so the hosts on that switch can get to the router and receive DHCP offers.
CCNA | CCNA:Security | CCNP | CCIP
JNCIA:JUNOS | JNCIA:EX | JNCIS:ENT | JNCIS:SEC
JNCIS:SP | JNCIP:SP -
mzinz Member Posts: 328Makes complete sense, thank you for your help.
I realize that not all 4 ports are actual routed ports, but because it's SVI, they are treated as one routed logical port, right?
Thanks again!_______LAB________
2x 2950
2x 3550
2x 2650XM
2x 3640
1x 2801 -
APA Member Posts: 959Makes complete sense, thank you for your help.
I realize that not all 4 ports are actual routed ports, but because it's SVI, they are treated as one routed logical port, right?
Thanks again!
nope... no routed port at all....all switchports... hence the need to create an SVI as you can't apply an IP address directly to the switchports.
CCNA | CCNA:Security | CCNP | CCIP
JNCIA:JUNOS | JNCIA:EX | JNCIS:ENT | JNCIS:SEC
JNCIS:SP | JNCIP:SP -
mzinz Member Posts: 328nope... no routed port at all....all switchports... hence the need to create an SVI as you can't apply an IP address directly to the switchports.
Thanks for the clarification._______LAB________
2x 2950
2x 3550
2x 2650XM
2x 3640
1x 2801