XMODEM image upgrade on MC3810v

pullin-gspullin-gs Posts: 38Member ■■□□□□□□□□
I deleted my IOS .bin image from flash.
I cant put it back on from ROMMON.
I have tried all the tried-and-true tools to do this including:
>copy xmodem flash
>copy xmodem: flash:
>xmodem
>dnld

I also tried:
>upgrade-bh
This is used for installing a new boot-helper (which by default is on EPROM, not flash) image onto flash: but to no avail. Came back as "invalid binary" which is not suprising since it is an IOS image and not the expected boot-helper image.

What's up with these things? I have never in my 15 years working with Cisco stuff not been able to do an xmodem or t.f.t.p upgrade of an IOS image.

Thanks

pullin'

PS: Anyone got an Avaya G350 or G700 they want to sell?

Comments

  • mikej412mikej412 Posts: 10,090Member
    pullin-gs wrote: »
    What's up with these things?
    It's been a while since I upgraded my MC3810s..... but I issued the boot command from ROMMON and it gave me a
    RouterName(boot)#
    prompt like the 2500 series.

    From there it looks like it works like a 2500 upgrade. I have the existing Ethernet configuration and can issue the copy tftp: flash: command and get the prompt for the Address or name of the remote host []?

    I'm on a MC3810-V -- but I may have upgraded the BIOS....
    :mike: Cisco Certifications -- Collect the Entire Set!
  • pullin-gspullin-gs Posts: 38Member ■■□□□□□□□□
    Thanks for the info.
    I cant get past rommon>....cant find boot-helper.
    I think at some point or another one of two things happened.
    #1) The BOOTLDR environment variable (is there such a thing?) got nulled out.
    Is there a way to get the boot-helper load process back to default? (eprom:mc3810-wboot-mz)?
    *****or*****:
    #2) Eprom is hosed...."no 1st file found"....I could bypass it entirely by loading up a flash-based boot-helper image using xmodem "upgrade-bh". The trouble with that is that boot-helper images "MC3810-wboot-mz.bin120xxxxx" are not to be found on CIO for MC3810. I suppose I could open a TAC case and may be able to get an image that way, however these things have been EOL now for years and they will most likely tell me to pound sand.
    I should be OK with new boot-helper even if I leave in old PROMS, for I am not using newer FLASH mem chips.

    P
Sign In or Register to comment.