NAT over frame relay

hodgey87hodgey87 Member Posts: 232
Afternoon guys,

Just a quick question =)

Ive got 2 routers set up using frame relay

Router 1
interface Serial1/0
no ip address
encapsulation frame-relay
no keepalive
ip ospf network broadcast
ip nat outside
clock rate 56000
!
interface Serial1/0.201 point-to-point
ip address 193.169.2.1 255.255.255.0
frame-relay interface-dlci 201

Router 2

interface Serial1/0
no ip address
encapsulation frame-relay
no keepalive
ip ospf network broadcast
!
interface Serial1/0.201 point-to-point
ip address 193.169.2.2 255.255.255.0
frame-relay interface-dlci 201

NAT

ip nat inside source list NAT_ADDRESSES interface Serial1/0 overload
ip access-list standard NAT_ADDRESSES
permit 192.168.1.0 0.0.0.255

NAT can translate if i encapsulate the interfaces using PPP but when i change over to frame relay like above it doesnt like it.

Just wondered if im missing a command or something from the frame relay config that i posted.

cheers

Comments

  • kryollakryolla Member Posts: 785
    try putting it under the sub-interface and see if it works
    Studying for CCIE and drinking Home Brew
  • luke_bibbyluke_bibby Member Posts: 162
    Both of the routers have the same configured DLCI on the PVC.. Try changing one to e.g 202 and see if that works.
  • JavonRJavonR Member Posts: 245
    luke_bibby wrote: »
    Both of the routers have the same configured DLCI on the PVC.. Try changing one to e.g 202 and see if that works.

    ^^ I agree :D. It's a good idea to check your IP connectivity first before adding any NAT configs or routing protocols in etc. This makes troubleshooting things like this a wholeeee lot easier.
  • mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    luke_bibby wrote: »
    Both of the routers have the same configured DLCI on the PVC..
    Since PPP worked, and frame relay is configured with the no keepalive command, it sounds like it could be a back-to-back configuration (with no frame-relay switch) -- which requires the DLCI be the same on both ends.

    It would be nice to know if this was the case.... and pinging before NAT was configured.
    kryolla wrote: »
    try putting it under the sub-interface and see if it works
    +1
    :mike: Cisco Certifications -- Collect the Entire Set!
  • hodgey87hodgey87 Member Posts: 232
    Cheers for the replies guys

    Yeh this was was just a back to back config ive only got 2 routers at the minute. I added the "ip nat outside" to the subinterface and thats seemed to have worked.
  • poguepogue Member Posts: 213
    hodgey87 wrote: »
    Cheers for the replies guys

    Yeh this was was just a back to back config ive only got 2 routers at the minute. I added the "ip nat outside" to the subinterface and thats seemed to have worked.

    Do you mean "ip nat inside"? It looks like you already had the outside command...

    Russ
    Currently working on: CCNA:Security
    Up next: CCNA:Voice
  • hodgey87hodgey87 Member Posts: 232
    pogue wrote: »
    Do you mean "ip nat inside"? It looks like you already had the outside command...

    Yeh sorry that was a typo!! So i can get through to a loop back address that ive set up on the isp router now. Just nothing is translating still on this frame relay link. Just tested with ppp and it works fine.
  • hodgey87hodgey87 Member Posts: 232
    Guys,

    Still not having much luck with this NAT over frame relay. I can ping fine over the cloud to a loopback address on the ISP router. But as soon as i add nat into the equation i can still ping the loopback but nothing is getting translated.
  • networker050184networker050184 Mod Posts: 11,962 Mod
    Are you sourcing the ping from the inside interface? If not it will use the address of the outgoing interface and not be NATed.
    An expert is a man who has made all the mistakes which can be made.
  • hodgey87hodgey87 Member Posts: 232
    My set up is

    pc
    SW1
    INTFA0/0 nat inside RTR1 INTS0/1 nat outside ----Frame Relay Cloud
    RTR2

    I can ping from my pc to a loop back address on RTR2 but nothing seems to get translated.
  • kryollakryolla Member Posts: 785
    do this

    sh run int fa0/0
    sh run int s0/1
    sh run | inc nat

    your posts is confusing are you using a sub-interface for nat outside and did you also change you nat command to include the sub-interface
    Studying for CCIE and drinking Home Brew
  • networker050184networker050184 Mod Posts: 11,962 Mod
    kryolla wrote: »
    do this

    sh run int fa0/0
    sh run int s0/1
    sh run | inc nat

    your posts is confusing are you using a sub-interface for nat outside and did you also change you nat command to include the sub-interface

    +1

    Throw us something to work with!
    An expert is a man who has made all the mistakes which can be made.
  • hodgey87hodgey87 Member Posts: 232
    Cheers for helping me out guys!!

    Ive just quickly built this network in packet tracer as im not at home but i always run into the sam problem anyways =)

    interface FastEthernet0/0
    ip address 192.168.20.1 255.255.255.0
    ip nat inside
    duplex auto
    speed auto
    !
    interface Serial1/0
    no ip address
    encapsulation frame-relay
    no keepalive
    ip ospf network broadcast
    ip nat outside
    clock rate 56000
    !
    interface Serial1/0.201 point-to-point
    ip address 192.168.10.1 255.255.255.0
    frame-relay interface-dlci 201
    !
    ip nat inside source list NAT_ADDRESSES interface Serial1/0 overload
    ip classless
    !
    !
    ip access-list standard NAT_ADDRESSES
    permit 192.168.20.0 0.0.0.255
    !

    thats what i have, this works with ppp i think its something to do with the subinterface but havent a clue.
  • kryollakryolla Member Posts: 785
    like I said earlier you need to move nat outside to your sub-interface, you know the one that has an IP address. Also change you nat command to include the sub-interface :)

    Also R2 should not have a route to your internal network 192.168.20.1 255.255.255.0 that what nat is for.
    Studying for CCIE and drinking Home Brew
  • hodgey87hodgey87 Member Posts: 232
    Cheers for helping me out with this =)

    Ill try it properly when i get home

    Edit....

    Just done what you said previously and its worked fine. Thanks for helping me out
Sign In or Register to comment.