another stupid BGP question

livenliven Member Posts: 918
ok... I am just fiddling around with BGP in GNS3.

I will admit I am doing something that I am not supposed to do... Redistributing Eigrp into BGP. Now I understand I am not supposed to do this, but I am just "practicing with BGP".

So, with that said my configuration is like this:


EIGRP - ISP3 -ISP2 - ISP4 - ISP1 - ISP3

So basically all of the ISP routers connect in a circle, and EIGRP hangs off like a spoke or leg or whatever.


All of these routers have a /30 connecting them with their neighbor, and all of them can ping their directly connected neighbor. Each of these routers has it's own AS
and they are all running BGP, and they have all successfully peered with their directly connected neighbors.



Hanging off of each router I have one directly connect router running a particular IGP. At the moment I only have one IGP running.

This is a router running EIGRP connected directly to ISP3.

EIGRP has three networks hanging off of it:

192.168.0.0/24
192.168.1.0/24
192.168.2.0/24

These routers being redistributed into ISP3's bgp.

Now all of the ISP routers can see the 192.x.x.x networks.


Orignally only ISP3 could ping the 192.x.x.x networks. After I added a default route to EIGRP router, ISP2 and ISP4 could ping the 192.x.x.x networks.



Problems I am having....

ISP4 has routes back to the networks on the EIGRP router, but it can not ping any of those networks....


I am pretty sure the interface configuration for all of these devices are ok (considering they can all ping their directly connected devices).


EIGRP


!
router eigrp 1
network 10.0.0.0 0.0.0.255
network 192.168.0.0
network 192.168.1.0
network 192.168.2.0
no auto-summary
neighbor 10.0.0.2 Ethernet0/0
!
ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
!



ISP3

router eigrp 1
redistribute bgp 65500
network 10.0.0.0 0.0.0.255
no auto-summary
neighbor 10.0.0.1 Ethernet2/0
!
router bgp 65500
no synchronization
bgp log-neighbor-changes
redistribute eigrp 1
neighbor 11.0.0.2 remote-as 65501
neighbor 12.0.0.2 remote-as 65502
no auto-summary
!

IPS2

!
router bgp 65501
no synchronization
bgp log-neighbor-changes
neighbor 11.0.0.1 remote-as 65500
neighbor 15.0.0.2 remote-as 65503
no auto-summary
!



IPS1


!
router bgp 65502
no synchronization
bgp log-neighbor-changes
neighbor 12.0.0.1 remote-as 65500
neighbor 17.0.0.1 remote-as 65503
no auto-summary
!

ISP4


!
router bgp 65503
no synchronization
bgp log-neighbor-changes
neighbor 15.0.0.1 remote-as 65501
neighbor 17.0.0.2 remote-as 65502
no auto-summary
!
encrypt the encryption, never mind my brain hurts.

Comments

  • livenliven Member Posts: 918
    I realize this might not make a lot of sense... and if I made a stupid mistake please let me know.... I am getting frustrated with to why I can't figure out why this isn't working....


    Thanks in advance for any suggestions/answers.
    encrypt the encryption, never mind my brain hurts.
  • networker050184networker050184 Mod Posts: 11,962 Mod
    We probably need to see the routing tables, but I'll give it a shot.

    Does the EIGRP router have a default route to R3? If so, does R3 have a route to the address R4 is sourcing the pings from (the outgoing interface)?
    An expert is a man who has made all the mistakes which can be made.
  • livenliven Member Posts: 918
    We probably need to see the routing tables, but I'll give it a shot.

    Does the EIGRP router have a default route to R3? If so, does R3 have a route to the address R4 is sourcing the pings from (the outgoing interface)?


    EIGRP has a defualt route to ISP3(I thought I mentioned that but if I neglected to I apologize)... At first I didn't have that so only ISP3 could ping the networks hanging off of EIGRP. But after I added the default route ISP2 and ISP1 could then ping the 192.x.x.x networks (hanging off the EIGRP router).

    Now... I have not explicity specified a route to ISP4 on IPS3... I can try that. What would be the best way to do this inside of BGP? I am trying to avoid muddling up the configs with a bunch of static routes.
    encrypt the encryption, never mind my brain hurts.
  • ColbyGColbyG Member Posts: 1,264
    Try sourcing the ping from an interface ISP4 has a route to.
  • networker050184networker050184 Mod Posts: 11,962 Mod
    ISP1 and ISP3 can ping because they are going to be sourcing the ping from an address that is directly connected to ISP3. When ISP4 pings it will use the outgoing interface that will not show as connected to ISP3.

    The way to get around this is to advertise the connected subnets in BGP or use static routes. You can also create a loopback and advertise that into BGP and use that as the source for you pings.

    This is the issue 90% of the time when I see someone asking BGP questions. Remember that just because a router knows how to get somewhere it doesn't mean the router on the other end knows how to get back.
    An expert is a man who has made all the mistakes which can be made.
  • livenliven Member Posts: 918
    ISP1 and ISP3 can ping because they are going to be sourcing the ping from an address that is directly connected to ISP3. When ISP4 pings it will use the outgoing interface that will not show as connected to ISP3.

    The way to get around this is to advertise the connected subnets in BGP or use static routes. You can also create a loopback and advertise that into BGP and use that as the source for you pings.

    This is the issue 90% of the time when I see someone asking BGP questions. Remember that just because a router knows how to get somewhere it doesn't mean the router on the other end knows how to get back.


    Adding the local subnets worked (to bgp)... I was just trying to avoid having to do that as ignorant as that sounds.... I guess I am was just being dense...
    encrypt the encryption, never mind my brain hurts.
Sign In or Register to comment.