Ran into Exchange Issue

win2k8win2k8 Users Awaiting Email Confirmation Posts: 262
Someone changed some security settings that was running our exchange server and we ran into some issues with OWA giving us a 404 error or something i tried reversing these and in the process changed some OWA virtual directory/CS role settings.

The problem is when i choose the use form-based authentication option now i get a 404 error. However if I used windows authentication I do not get the login screen for OWA just a box asking for username/password which works if i put it in correctly. Not sure what the best thing to do at this point, I think would be best to just recreate the OWA virtual directory?

We are using Exch2k7.

Thanks,

win2k8

Comments

  • blargoeblargoe Self-Described Huguenot NC, USAMember Posts: 4,174 ■■■■■■■■■□
    I don't know the steps off-hand, but I think you can just use the powershell cmdlets to remove the old OWA virtual directory settings and recreate them, and it will set them up correctly
    IT guy since 12/00

    Recent: 11/2019 - RHCSA (RHEL 7); 2/2019 - Updated VCP to 6.5 (just a few days before VMware discontinued the re-cert policy...)
    Working on: RHCE/Ansible
    Future: Probably continued Red Hat Immersion, Possibly VCAP Design, or maybe a completely different path. Depends on job demands...
  • royalroyal Member Posts: 3,352 ■■■■□□□□□□
    I just wrote this just now but haven't tested it. It should work though.

    Get-OwaVirtualDirectory -server serverhere | foreach-object { Remove-OWAVirtualDirectory | New-OWAVirtualDirectory -server serverhere -OwaVersion $_.Owaversion -Name $_.owaversion }

    I would test it in a lab before you run it. Set something incorrectly on each of the OWA Virtual Directores and then run the above to see if they are re-created successfully. Otherwise, you can just do each manually by reading something such as the following:
    How To: Recreate OWA Virtual Directory – Exchange 2007 Exchange Server Share
    “For success, attitude is equally as important as ability.” - Harry F. Banks
Sign In or Register to comment.