Voice network help - Boot process.

Guys, Im really scratching my head on this one. where to begin.. ok...
I have my voice lab setup and my phones are stuck @ configuring IP which tells me one simple thing, no communication with the dhcp server. Interesting enough, my laptop grabs an ip address just fine. attached is a sample of my voice network. the sample shows the pc connected to the phone, but in my case, the pc is connected to port 3 on the switch.
I am not sure if i am missing something but if someone can assist, i would be grateful.
Thank you.
DHCP router is setup for both voice/data pools.
interface FastEthernet0/0
ip address 172.16.2.5 255.255.255.0
duplex auto
speed auto
ip dhcp excluded-address 172.16.1.1 172.16.1.10
ip dhcp excluded-address 172.16.2.1 172.16.2.10
!
ip dhcp pool voice
network 172.16.1.0 255.255.255.0
default-router 172.16.1.1
option 150 ip 172.16.1.1
dns-server 4.2.2.2
!
ip dhcp pool data
network 172.16.2.0 255.255.255.0
default-router 172.16.2.1
dns-server 4.2.2.2
CME router it setup for router-on-stick
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 172.16.1.1 255.255.255.0
ip helper-address 172.16.2.5
!
interface FastEthernet0/0.50
encapsulation dot1Q 50
ip address 172.16.2.1 255.255.255.0
Switch A port 1 setup for VLAN 50 (to dhcp)
Switch A port 23 setup for Trunk (t0 cme)
Switch A port 24 setup for Trunk (to switch
interface FastEthernet0/1
switchport access vlan 50
switchport mode access
spanning-tree portfast
interface FastEthernet0/23
switchport mode trunk
!
interface FastEthernet0/24
switchport mode trunk
Switch B port 24 setup for Trunk (to switch A)
Switch B port 1 setup for Voice vlan 10 and access vlan 50
Switch B port 2 setup for Voice vlan 10 and access vlan 50
Switch B port 3 setup for Voice vlan 10 and access vlan 50
7940 IP phone connected to port 1 and 2, Laptop connected to port 3.
interface FastEthernet0/1
switchport access vlan 50
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 50
switchport voice vlan 10
spanning-tree portfast
!
interface FastEthernet0/3
switchport access vlan 50
switchport voice vlan 10
spanning-tree portfast
I have my voice lab setup and my phones are stuck @ configuring IP which tells me one simple thing, no communication with the dhcp server. Interesting enough, my laptop grabs an ip address just fine. attached is a sample of my voice network. the sample shows the pc connected to the phone, but in my case, the pc is connected to port 3 on the switch.
I am not sure if i am missing something but if someone can assist, i would be grateful.
Thank you.
DHCP router is setup for both voice/data pools.
interface FastEthernet0/0
ip address 172.16.2.5 255.255.255.0
duplex auto
speed auto
ip dhcp excluded-address 172.16.1.1 172.16.1.10
ip dhcp excluded-address 172.16.2.1 172.16.2.10
!
ip dhcp pool voice
network 172.16.1.0 255.255.255.0
default-router 172.16.1.1
option 150 ip 172.16.1.1
dns-server 4.2.2.2
!
ip dhcp pool data
network 172.16.2.0 255.255.255.0
default-router 172.16.2.1
dns-server 4.2.2.2
CME router it setup for router-on-stick
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 172.16.1.1 255.255.255.0
ip helper-address 172.16.2.5
!
interface FastEthernet0/0.50
encapsulation dot1Q 50
ip address 172.16.2.1 255.255.255.0
Switch A port 1 setup for VLAN 50 (to dhcp)
Switch A port 23 setup for Trunk (t0 cme)
Switch A port 24 setup for Trunk (to switch

interface FastEthernet0/1
switchport access vlan 50
switchport mode access
spanning-tree portfast
interface FastEthernet0/23
switchport mode trunk
!
interface FastEthernet0/24
switchport mode trunk
Switch B port 24 setup for Trunk (to switch A)
Switch B port 1 setup for Voice vlan 10 and access vlan 50
Switch B port 2 setup for Voice vlan 10 and access vlan 50
Switch B port 3 setup for Voice vlan 10 and access vlan 50
7940 IP phone connected to port 1 and 2, Laptop connected to port 3.
interface FastEthernet0/1
switchport access vlan 50
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 50
switchport voice vlan 10
spanning-tree portfast
!
interface FastEthernet0/3
switchport access vlan 50
switchport voice vlan 10
spanning-tree portfast
Comments
Resetting 7900 Series IP Phones to Factory Defaults [Cisco Unified IP Phones 7900 Series] - Cisco Systems
This has a bullet point under "Voice VLAN Configuration Guidelines" about CDP
Catalyst 2970 Switch Software Configuration Guide, 12.1(14)EA1 - Configuring Voice VLAN [Cisco Catalyst 2970 Series Switches] - Cisco Systems
i can also ping the CME router from the dhcp server on both sub interfaces and so forth from the CME router to the dhcp router.
the only thing i can think of is wiping out everything on all hardware and starting from scratch, with a clear config.
again, once i get time to throw that line on the CME router i will respond back and let you know.. thanks!
interface FastEthernet0/1
switchport access vlan 50
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 50
switchport voice vlan 10
spanning-tree portfast
fa0/1 is missing the voice vlan and fa0/2 and fa0/3 are missing the mode command.
im gonna kick myself if its something stupid i didnt put in..
I seriously think i need to wipe out my config on everything and start over, unless i need to add something to the config that i am not aware about.
what i know and can do so far with the dual router + 2 switch configuration...
1. DHCP router is able to ping CME router on both sub interfaces
2. CME router is able to ping FA0/0 interface on DHCP router.
3. PC connected to switch B is able to pull a DHCP IP of 172.16.2.11 and ping all interfaces.
4. IP phones on vpice vlan 10 wait for ip address.
Swtich B = 3524 power
Switch A = 2960 XL
For now though, chuck the dhcp config onto the CME and see if that works ?
CME = 2650XM
i simply removed "access vlan 50" on a single port from the 3524 switch as a test and bam, the ip phone got an address.
so wtf? lol seems that if i keep the port config simple, the phone gets an ip, but if i add the data vlan to it, then the problem comes about.
I'm using a UC520, also, for my CCNA:V studies. Are you getting into the IOS or just doing stuff with the Cisco Configuration Assistant?