Options

ISIS Adjacency issues

toufiqtoufiq Member Posts: 34 ■■□□□□□□□□
Dear All,

As I am preparing for my JNCIP-M/T exam.currently I am going through the ISIS Topic.I have configured ISIS on all seven routers with different area IDs.diagrame is available on page number 287 of JNCIP-M/T book.

After the complete configuration I checked the adjacency of routers and found that some adjacencies some time goies down and some times goes into initilization.
Please find below the onfiguration of R3,R4 and R5 and please guide if configuration issue is found.

R3-Configuration.
version 8.5R1.14;
system {
root-authentication {
encrypted-password "$1$vniFixHf$UehnJAbHqWb62cCgvL8Tr1"; ## SECRET-DATA
}
}
interfaces {
em0 {
unit 0 {
family inet {
address 10.0.4.13/30;
}
family iso;
}
}
em1 {
unit 0 {
family inet {
address 10.0.2.5/30;
}
family iso;
}
}
em2 {
unit 0 {
family inet {
address 10.0.4.1/30;
}
family iso;
}
}
em3 {
unit 0 {
family inet {
address 10.0.2.2/30;
}
family iso;
}
}
em4 {
unit 0 {
family inet {
address 172.16.0.13/30;
}
family iso;
}
}
lo0 {
unit 0 {
family inet {
address 10.0.3.3/32;
}
family iso {
address 49.0003.0100.0000.3003.00;
}
}
}
}
routing-options {
aggregate {
route 10.0.4.0/22;
}
}
protocols {
isis {
export [ leak1 summ ];
interface em0.0 {
level 2 disable;
}
interface em1.0 {
level 1 disable;
}
interface em2.0 {
level 2 disable;
}
interface em3.0 {
level 1 disable;
}
interface lo0.0 {
level 1 disable;
}
}
}
policy-options {
policy-statement leak1 {
term 1 {
from {
protocol isis;
level 2;
route-filter 10.0.3.0/24 longer;
}
to level 1;
then accept;
}
term 2 {
from {
protocol direct;
level 2;
route-filter 10.0.3.0/24 longer;
}
to level 1;
then accept;
}
}
policy-statement summ {
term 1 {
from protocol aggregate;
to level 2;
then accept;
}
term 2 {
from {
route-filter 10.0.4.0/22 longer;
}
to level 2;
then reject;
}
}
}

R4 Configuration.
system {
host-name R4;
root-authentication {
encrypted-password "$1$.jgU4LBm$3Amzz1g9nfwqV0RuG1lx10"; ## SECRET-DATA
}
}
interfaces {
em1 {
unit 0 {
family inet {
address 10.0.2.6/30;
}
family iso;
}
}
em2 {
unit 0 {
family inet {
address 10.0.2.10/30;
}
family iso;
}
}
em3 {
unit 0 {
family inet {
address 10.0.4.9/30;
}
family iso;
}
}
lo0 {
unit 0 {
family inet {
address 10.0.3.4/32;
}
family iso {
address 49.0003.0100.0000.3004.00;
}
}
}
}
protocols {
isis {
traceoptions {
file isis;
flag hello detail;
flag error detail;
}
export [ leak1 summ ];
interface all;
interface em1.0 {
level 1 disable;
}
interface em2.0 {
level 1 disable;
}
interface em3.0 {
level 2 disable;
}
interface lo0.0 {
level 1 disable;
}
}
}
policy-options {
policy-statement leak1 {
term 1 {
from {
protocol isis;
level 2;
route-filter 10.0.3.0/24 longer;
}
to level 1;
then accept;
}
term 2 {
from {
protocol direct;
level 2;
route-filter 10.0.3.0/24 longer;
}
to level 1;
then accept;
}
}
policy-statement summ {
term 1 {
from protocol aggregate;
to level 2;
then accept;
}
term 2 {
from {
route-filter 10.0.4.0/22 longer;
}
to level 2;
then reject;
}
}
}
R5 Configuration.
system {
host-name R5;
root-authentication {
encrypted-password "$1$qX5rqy8v$NOZebXK.1LiT1FTOcDigt0"; ## SECRET-DATA
}
}
interfaces {
em0 {
unit 0 {
family inet {
address 10.0.8.6/30;
}
family iso;
}
}
em1 {
unit 0 {
family inet {
address 10.0.8.9/30;
}
family iso;
}
}
em2 {
unit 0 {
family inet {
address 10.0.2.9/30;
}
family iso;
}
}
em3 {
unit 0 {
family inet {
address 10.0.2.1/30;
}
family iso;
}
}
lo0 {
unit 0 {
family inet {
address 10.0.3.5/32;
}
family iso {
address 49.0002.0100.0000.3005.00;
}
}
}
}
protocols {
isis {
traceoptions {
file isis;
flag hello detail;
flag error detail;
}
interface em0.0 {
level 2 disable;
}
interface em1.0 {
level 2 disable;
}
interface em2.0 {
level 1 disable;
}
interface em3.0 {
level 1 disable;
}
interface lo0.0 {
level 1 disable;
}
}
}

Please note that I am using olive for Lab practice.

Regards,
Toufiq

Comments

  • Options
    AldurAldur Member Posts: 1,460
    something to add is that toufiq did put the isis interfaces in a point-to-point mode which I've seen fix this issue in the past. But all it did here is cause the adjacencies not to even attempt to form.
    "Bribe is such an ugly word. I prefer extortion. The X makes it sound cool."

    -Bender
  • Options
    toufiqtoufiq Member Posts: 34 ■■□□□□□□□□
    Thanks, yes I have configured point-to-point interfaces on all router after send the configuration on this group but my issue is still not resolved and further before applying i have some adj and after configuring point-point, adj gone.

    ISIS diagrame is available on JNCIP book on page number 287.

    Regards,
    Toufiq
  • Options
    hoogen82hoogen82 Member Posts: 272
    show isis interface
    show isis interface detail
    show isis adjacency detail

    The best output I have learnt on isis is monitor traffic interface.. really tells you a lot..

    Please paste the output.. I have started to lab these.. but will be there soon :)
    IS-IS Sleeps.
    BGP peers are quiet.
    Something must be wrong.
  • Options
    toufiqtoufiq Member Posts: 34 ■■□□□□□□□□
    Thanks Boss!
    Its basically from JNCIP-M book at 287 page.
    please find be the out of commands which you have mentioned.

    R3 Commands:
    IS-IS interface database:
    Interface L CirID Level 1 DR Level 2 DR L1/L2 Metric
    em0.0 1 0x1 Point to Point Disabled 10/10
    em1.0 2 0x1 Disabled Point to Point 10/10
    em2.0 1 0x1 Point to Point Disabled 10/10
    em3.0 2 0x1 Disabled Point to Point 10/10
    lo0.0 0 0x1 Disabled Passive 0/0

    IS-IS interface database:
    em0.0
    Index: 64, State: 0x6, Circuit id: 0x1, Circuit type: 1
    LSP interval: 100 ms, CSNP interval: disabled
    Level Adjacencies Priority Metric Hello (s) Hold (s) Designated Router
    1 0 64 10 9.000 27
    em1.0
    Index: 65, State: 0x6, Circuit id: 0x1, Circuit type: 2
    LSP interval: 100 ms, CSNP interval: disabled
    Level Adjacencies Priority Metric Hello (s) Hold (s) Designated Router
    2 0 64 10 9.000 27
    em2.0
    Index: 66, State: 0x6, Circuit id: 0x1, Circuit type: 1
    LSP interval: 100 ms, CSNP interval: disabled
    Level Adjacencies Priority Metric Hello (s) Hold (s) Designated Router
    1 0 64 10 9.000 27
    em3.0
    Index: 67, State: 0x6, Circuit id: 0x1, Circuit type: 2
    LSP interval: 100 ms, CSNP interval: disabled
    Level Adjacencies Priority Metric Hello (s) Hold (s) Designated Router
    2 0 64 10 9.000 27
    lo0.0
    Index: 69, State: 0x6, Circuit id: 0x1, Circuit type: 0
    LSP interval: 100 ms, CSNP interval: disabled
    Level Adjacencies Priority Metric Hello (s) Hold (s) Designated Router
    2 0 64 0 Passive


    edit]
    root# run show isis adjacency detail

    [edit]
    root#

    No adjacency found after point-to-point configuration.
    Before this command, Adj were there but with some flapping.

    Please guide!

    Regards,
    Toufiq
  • Options
    hoogen82hoogen82 Member Posts: 272
    Could you do monitor traffic interface em0.. I mostly believe you are not receiving hello packets.
    IS-IS Sleeps.
    BGP peers are quiet.
    Something must be wrong.
Sign In or Register to comment.