OSPF NSSA Problem

Daniel333Daniel333 Member Posts: 2,077 ■■■■■■□□□□
Hey guys, shouldn't the 172 network configured on R3 show on R1's routing table?
R1#sho ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C       10.1.1.0/24 is directly connected, Loopback1
O       10.1.2.1/32 [110/2] via 10.1.12.2, 00:14:10, FastEthernet0/0
O IA    10.1.3.1/32 [110/3] via 10.1.12.2, 00:14:10, FastEthernet0/0
C       10.1.12.0/24 is directly connected, FastEthernet0/0
O IA    10.1.23.0/24 [110/2] via 10.1.12.2, 00:14:10, FastEthernet0/0
R1#

R1#show run
Building configuration...

Current configuration : 604 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
!
!
ip name-server 0.0.0.0
!
!
!
!
!
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.1.12.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 10.1.12.0 0.0.0.255 area 0
 network 10.1.1.0 0.0.0.255 area 0
!
ip classless
!
!
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end


R1#show run
Building configuration...

Current configuration : 604 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
!
!
ip name-server 0.0.0.0
!
!
!
!
!
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.1.12.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 10.1.12.0 0.0.0.255 area 0
 network 10.1.1.0 0.0.0.255 area 0
!
ip classless
!
!
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end




R2#sho run
Building configuration...

Current configuration : 643 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback2
 ip address 10.1.2.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.1.12.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.1.23.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 area 23 nssa
 network 10.1.12.0 0.0.0.255 area 0
 network 10.1.2.0 0.0.0.255 area 0
 network 10.1.23.0 0.0.0.255 area 23
!
ip classless
!
!
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end


R2#sho run
Building configuration...

Current configuration : 643 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback2
 ip address 10.1.2.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.1.12.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.1.23.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 area 23 nssa
 network 10.1.12.0 0.0.0.255 area 0
 network 10.1.2.0 0.0.0.255 area 0
 network 10.1.23.0 0.0.0.255 area 23
!
ip classless
!
!
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end






R3#show run
Building configuration...

Current configuration : 715 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
!
!
!
!
!
!
!
ip name-server 0.0.0.0
!
!
!
!
!
!
interface Loopback3
 ip address 10.1.3.1 255.255.255.0
!
interface Loopback20
 ip address 172.20.200.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 ip address 10.1.23.3 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 area 23 nssa
 redistribute connected subnets 
 network 10.1.23.0 0.0.0.255 area 23
 network 10.1.3.0 0.0.0.255 area 23
!
ip classless
!
!
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end


-Daniel

Comments

  • Daniel333Daniel333 Member Posts: 2,077 ■■■■■■□□□□
    Why is it that I can spend an hour staring at something and not get it, yet once I post it thus making a fool of myself I get it a minute later.

    For the record the area 23 nssa needed the "no-summ" on the the, since it' can't summerize the 172.x.x.x in to the 10.x.x.x....
    -Daniel
  • BennyLavaBennyLava Member Posts: 60 ■■□□□□□□□□
    Are you sure you didn't change something else also? Adding 'no-summary' on the ABR just stops type-3 LSAs from being sent into area 23, it shouldn't affect R1 at all. Your configs that you posted look fine to me as is.
  • BennyLavaBennyLava Member Posts: 60 ■■□□□□□□□□
    I just pasted your configs in, it seems to work fine for me:

    R1(config)#do sh ip rou
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    172.20.0.0/24 is subnetted, 1 subnets
    O E2 172.20.200.0 [110/20] via 10.1.12.2, 00:00:04, FastEthernet0/0
    10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
    C 10.1.12.0/24 is directly connected, FastEthernet0/0
    O 10.1.2.1/32 [110/2] via 10.1.12.2, 00:00:04, FastEthernet0/0
    O IA 10.1.3.1/32 [110/3] via 10.1.12.2, 00:00:04, FastEthernet0/0
    C 10.1.1.0/24 is directly connected, Loopback1
    O IA 10.1.23.0/24 [110/2] via 10.1.12.2, 00:00:04, FastEthernet0/0


    R2#sh ip rou
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    172.20.0.0/24 is subnetted, 1 subnets
    O N2 172.20.200.0 [110/20] via 10.1.23.3, 00:00:20, FastEthernet0/1
    10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
    C 10.1.12.0/24 is directly connected, FastEthernet0/0
    O 10.1.3.1/32 [110/2] via 10.1.23.3, 00:00:20, FastEthernet0/1
    C 10.1.2.0/24 is directly connected, Loopback2
    O 10.1.1.1/32 [110/2] via 10.1.12.1, 00:00:10, FastEthernet0/0
    C 10.1.23.0/24 is directly connected, FastEthernet0/1


    R3(config)#do sh ip rou
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    172.20.0.0/24 is subnetted, 1 subnets
    C 172.20.200.0 is directly connected, Loopback20
    10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
    O IA 10.1.12.0/24 [110/2] via 10.1.23.2, 00:00:17, FastEthernet0/1
    C 10.1.3.0/24 is directly connected, Loopback3
    O IA 10.1.2.1/32 [110/2] via 10.1.23.2, 00:00:17, FastEthernet0/1
    O IA 10.1.1.1/32 [110/3] via 10.1.23.2, 00:00:17, FastEthernet0/1
    C 10.1.23.0/24 is directly connected, FastEthernet0/1
  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    Daniel333 wrote: »

    For the record the area 23 nssa needed the "no-summ" on the the, since it' can't summerize the 172.x.x.x in to the 10.x.x.x....

    No-summary on R2 would just turn area 23 into a NSSA totally stubby area.I love this terminology!
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Daniel333Daniel333 Member Posts: 2,077 ■■■■■■□□□□
    Given that it worked for you, I am thinking Packet Tracer is at fault. It's not the first time it's acted weird. Ill fire up some real router tomorrow and try it out.

    But from your output it seems like even without the no-summ on there it still distributed the 172 network, and summerized it?
    -Daniel
  • kryollakryolla Member Posts: 785
    Daniel333 wrote: »
    Given that it worked for you, I am thinking Packet Tracer is at fault. It's not the first time it's acted weird. Ill fire up some real router tomorrow and try it out.

    But from your output it seems like even without the no-summ on there it still distributed the 172 network, and summerized it?

    I think you are confused what no-summary means. All it means is no LSA-3 will be going INTO the area it is not summarizing anything. In order to summarize you need area range command or for external it is summary-address
    Studying for CCIE and drinking Home Brew
  • XenzXenz Member Posts: 140
    Daniel333 wrote: »
    Given that it worked for you, I am thinking Packet Tracer is at fault. It's not the first time it's acted weird. Ill fire up some real router tomorrow and try it out.

    But from your output it seems like even without the no-summ on there it still distributed the 172 network, and summerized it?


    Packet tracer for CCNP stuff? No way to use dynamips/GNS? Packet tracer was shifty enough covering some of the late CCNA topics. I can't imagine trying to use it for CCNP studies.
    Currently working on:
    CCNP, 70-620 Vista 70-290 Server 2003
    Packet Tracer activities and ramblings on my blog:
    http://www.sbntech.info
  • Daniel333Daniel333 Member Posts: 2,077 ■■■■■■□□□□
    kryolla wrote: »
    I think you are confused
    No doubt about that! I think messing with this fancy Cisco stuff was a mistake.

    Xenz wrote:
    Packet tracer for CCNP stuff? No way to use dynamips/GNS? Packet tracer was shifty enough covering some of the late CCNA topics. I can't imagine trying to use it for CCNP studies.
    1ghz laptop, GNS3 doesn't have a chance :)
    -Daniel
  • kryollakryolla Member Posts: 785
    Daniel333 wrote: »
    No doubt about that! I think messing with this fancy Cisco stuff was a mistake.

    I dont think its a mistake you just have to keep on working on it and it will all make sense
    Studying for CCIE and drinking Home Brew
  • BosefusBosefus Member Posts: 67 ■■□□□□□□□□
    Daniel333 wrote: »
    Given that it worked for you, I am thinking Packet Tracer is at fault. It's not the first time it's acted weird.

    I second this. Packet tracer does some funky stuff sometimes.
    Working on CCNP, passed BSCI, Currently working on ONT.
Sign In or Register to comment.