Options

Multicast Help Required!

moss12moss12 Banned Posts: 220 ■■□□□□□□□□
Hey Guys,

I need some helpful direction with this topology with regared to QoS for webcam input traffic from the host 192.168.1.1 streaming to branch offices devices thank you

Please check my configurations as well if it is correct
this is my last year final project I can move on with my life next year with a degree, this project due next month jeez.

HO
!
hostname HO
!
ip multicast-routing
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
!
crypto isakmp policy 2
hash md5
authentication pre-share
group 2
crypto isakmp key zecret%$ address 202.168.2.2
!
crypto ipsec transform-set HO_BO esp-des esp-md5-hmac
!
crypto map SDM_CMAP_1 1 ipsec-isakmp
description Tunnel to202.168.2.2
set peer 202.168.2.2
set transform-set HO_BO
match address 100
!
interface Tunnel0
ip address 192.168.3.1 255.255.255.0
ip mtu 1420
ip pim sparse-mode
ip igmp version 3
tunnel source FastEthernet0/1
tunnel destination 202.168.2.2
tunnel path-mtu-discovery
crypto map SDM_CMAP_1
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
ip pim sparse-mode
ip igmp version 3
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 202.168.1.1 255.255.255.0
duplex auto
speed auto
crypto map SDM_CMAP_1
!
ip route 192.168.2.0 255.255.255.0 Tunnel0
ip route 202.168.2.2 255.255.255.255 FastEthernet0/1
!
ip pim rp-address 192.168.3.1
ip pim ssm default
!
access-list 100 remark SDM_ACL Category=4
access-list 100 permit gre host 202.168.1.1 host 202.168.2.2
!
ISP
!
hostname ISP
!
interface FastEthernet0/0
ip address 202.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 202.168.1.2 255.255.255.0
duplex auto
speed auto
!
BO
!
hostname BO
!
ip multicast-routing
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
!
crypto isakmp policy 2
hash md5
authentication pre-share
group 2
crypto isakmp key zecret%$ address 202.168.1.1
!
crypto ipsec transform-set BO_HO esp-des esp-md5-hmac
!
crypto map SDM_CMAP_1 1 ipsec-isakmp
description Tunnel to202.168.1.1
set peer 202.168.1.1
set transform-set BO_HO
match address 100
!
interface Tunnel0
ip address 192.168.3.2 255.255.255.0
ip mtu 1420
ip pim sparse-mode
ip igmp version 3
tunnel source FastEthernet0/0
tunnel destination 202.168.1.1
tunnel path-mtu-discovery
crypto map SDM_CMAP_1
!
interface FastEthernet0/0
ip address 202.168.2.2 255.255.255.0
duplex auto
speed auto
crypto map SDM_CMAP_1
!
interface FastEthernet0/1
ip address 192.168.2.2 255.255.255.0
ip pim sparse-mode
ip igmp join-group 232.2.2.2 source 192.168.1.1
ip igmp access-group mygroup
ip igmp version 3
ip igmp explicit-tracking
duplex auto
speed auto
!
ip route 192.168.1.0 255.255.255.0 Tunnel0
ip route 202.168.1.1 255.255.255.255 FastEthernet0/0
!
ip pim rp-address 192.168.3.1
ip pim ssm default
ip mroute 192.168.1.0 255.255.255.0 Tunnel0
ip mroute 192.168.3.1 255.255.255.255 Tunnel0
!
ip access-list extended mygroup
permit igmp host 192.168.1.1 host 232.2.2.2
deny igmp any any
!
access-list 100 remark SDM_ACL Category=4
access-list 100 permit gre host 202.168.2.2 host 202.168.1.1
!
HOSwitch
!
hostname HOSwitch
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/2
!
interface FastEthernet0/3
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/13
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/16
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/17
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/20
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/21
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/22
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/23
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/24
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
!
interface Vlan10
no ip address
!
ip classless
ip http server
ip http secure-server
!

I will be doing the wireless configuration this weekend

Project Specifications: http://i36.tinypic.com/2weylxu.jpg
Project Topology: http://i38.tinypic.com/2mxesef.jpg

Helpful hints appreciated techexams

One more thing do I need QoS on the access points as well ???

Comments

Sign In or Register to comment.