Options

Frame-relay

xzyanxzyan Member Posts: 34 ■■□□□□□□□□
I have 4 router

R1 , R2 , R3..are all connected to router 4 ( FRAME-SWITCH)

R1 can ping R2 and R3
R2 can ping R1
R3 can ping R1

R3 CAN'T ping R2 and R2 CAN'T ping R3

I need help w/ this Thanks


Thanks again


==================

R1#sho run
Building configuration...

Current configuration : 708 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
!
ip audit po max-events 100
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
no ip address
half-duplex
!
interface Serial0/0
ip address 172.12.123.1 255.255.255.0
encapsulation frame-relay
!
interface Serial0/1
no ip address
shutdown
!
ip http server
no ip http secure-server
ip classless
!

!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
!
end
===================================================================

R2#sho run
Building configuration...

Current configuration : 813 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
!
ip audit po max-events 100
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Ethernet0/0
no ip address
half-duplex
!
interface Serial0/0
ip address 172.12.123.2 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.12.123.1 221 broadcast
frame-relay map ip 172.12.123.2 221 broadcast
!
interface Serial0/1
no ip address
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
!
end

========================================================

R3#sho run
Building configuration...

Current configuration:
!
version 11.0
service udp-small-servers
service tcp-small-servers
!
hostname R3
!
enable password cisco
!
no ip domain-lookup
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
ip address 172.12.123.3 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.12.123.1 321 broadcast
frame-relay map ip 172.12.123.2 321 broadcast
!
interface Serial1
no ip address
!
!
line con 0
line aux 0
transport input all
line vty 0 4
password cisco
login
!
end

==========================================================

frame-switch#sho run
Building configuration...

Current configuration : 1428 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname frame-switch
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
!
ip audit po max-events 100
frame-relay switching
!
!
!
interface Ethernet0/0
no ip address
shutdown
half-duplex
!
interface Serial0/0
no ip address
shutdown
no fair-queue
!
interface Serial1/0
no ip address
shutdown
!
interface Serial1/1
no ip address
encapsulation frame-relay
logging event subif-link-status
logging event dlci-status-change
clock rate 56000
no frame-relay inverse-arp
frame-relay intf-type dce
frame-relay route 122 interface Serial1/2 221
frame-relay route 123 interface Serial1/3 321
!
interface Serial1/2
no ip address
encapsulation frame-relay
logging event subif-link-status
logging event dlci-status-change
clock rate 56000
no frame-relay inverse-arp
frame-relay intf-type dce
frame-relay route 221 interface Serial1/1 122
!
interface Serial1/3
no ip address
encapsulation frame-relay
logging event subif-link-status
logging event dlci-status-change
clock rate 56000
no frame-relay inverse-arp
frame-relay intf-type dce
frame-relay route 321 interface Serial1/1 123
!
ip http server
no ip http secure-server
ip classless
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

Comments

  • Options
    mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    xzyan wrote: »
    frame-relay map ip 172.12.123.2 221 broadcast
    This line should let R2 ping R2......

    Do you have a frame relay map statement with the correct IP address for R3 configured on R2?
    :mike: Cisco Certifications -- Collect the Entire Set!
  • Options
    kryollakryolla Member Posts: 785
    I can give you the answer but try debug frame packet and it will show you the issue
    Studying for CCIE and drinking Home Brew
  • Options
    phoeneousphoeneous Member Posts: 2,333 ■■■■■■■□□□
    Lookie here:
    R2
    
    interface Serial0/0
    ip address 172.12.123.2 255.255.255.0
    encapsulation frame-relay
    frame-relay map ip 172.12.123.1 221 broadcast
    frame-relay map ip 172.12.123.[b]2[/b] 221 broadcast
    

    Typo?
  • Options
    kryollakryolla Member Posts: 785
    phoeneous wrote: »
    Lookie here:
    R2
    
    interface Serial0/0
    ip address 172.12.123.2 255.255.255.0
    encapsulation frame-relay
    frame-relay map ip 172.12.123.1 221 broadcast
    frame-relay map ip 172.12.123.[b]2[/b] 221 broadcast
    

    Typo?

    it's not really a typo but maybe he didn't mean to do it :)
    Studying for CCIE and drinking Home Brew
  • Options
    KaminskyKaminsky Member Posts: 1,235
    cut n paste can be the debil
    Kam.
Sign In or Register to comment.