Options

Problem with Static Route.

amb1s1amb1s1 Member Posts: 408
Hi I'm have a lab on GNS3 that consist of 3 3600 routers and 2 pc (Routers acting as a PC). All routers have 255.255.255.252 mask on their serial interfaces. The two Fast interface that connect to the PC have a 255.255.255.0 mask. When I do all the ip route on all routers, I can ping all routers, but none of the PC. Does static work when mixing mask type? The following are my Configs.
Router_1(config)#do sh run
Building configuration...

Current configuration : 1050 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!         
interface Serial0/0
 ip address 10.1.1.1 255.255.255.252
 serial restart-delay 0
 clock rate 64000
 no fair-queue
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet1/0
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
ip http server
no ip http secure-server
!
ip forward-protocol nd
ip route 10.2.2.0 255.255.255.252 10.1.1.2
ip route 192.168.3.0 255.255.255.0 10.1.1.2
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!         
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
Router_2#sh run
Building configuration...

Current configuration : 952 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Serial0/0
 ip address 10.1.1.2 255.255.255.252
 serial restart-delay 0
 no fair-queue
!
interface Serial0/1
 ip address 10.2.2.2 255.255.255.252
 serial restart-delay 0
 clock rate 64000
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
ip http server
no ip http secure-server
!
ip forward-protocol nd
ip route 192.168.1.0 255.255.255.0 10.1.1.1
ip route 192.168.3.0 255.255.255.0 10.2.2.1
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!         
!
end
Router_3#sh run
Building configuration...

Current configuration : 1013 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Serial0/0
 ip address 10.2.2.1 255.255.255.252
 serial restart-delay 0
 no fair-queue
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet1/0
 ip address 192.168.3.1 255.255.255.0
 duplex auto
 speed auto
!
ip http server
no ip http secure-server
!
ip forward-protocol nd
ip route 10.1.1.0 255.255.255.252 10.2.2.2
ip route 192.168.1.0 255.255.255.0 10.2.2.2
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!         
line con 0
line aux 0
line vty 0 4
 login
!
!
end

This is the config for one of the PC (Router) the one that it is connect to Router_1 on FA1/0.
PC-A#sh run
Building configuration...

Current configuration : 648 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PC-A
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 15
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
!
!
!         
ip cef
ip audit po max-events 100
!
!
!
!
! 
!
!
!
interface Ethernet0
 no ip address
 shutdown
 half-duplex
!
interface FastEthernet0
 ip address 192.168.1.3 255.255.255.0
 speed auto
!
ip default-gateway 192.168.1.1
ip classless
no ip http server
no ip http secure-server
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end
David G.
http://gomezd.com <
My Tshoot test Blog
http://twitter.com/ipnet255

Comments

  • Options
    networker050184networker050184 Mod Posts: 11,962 Mod
    IP default gateway is used when the router is not routing traffic. You need a default route.
    An expert is a man who has made all the mistakes which can be made.
  • Options
    amb1s1amb1s1 Member Posts: 408
    IP default gateway is used when the router is not routing traffic. You need a default route.

    That router is not routing traffic, that router is used on my lab as a PC. I'm using the GNS3 emulator, they don't have a PC emulator for they use router as PCs.
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • Options
    mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    amb1s1 wrote: »
    When I do all the ip route on all routers, I can ping all routers, but none of the PC.
    Exactly what did you ping?

    Can the "PC" ping it's gateway IP on R1?
    Can R1 ping PC 1?

    Can PC1 ping the Serial port IP address on R1?
    Can R1 ping the R2 serial address?
    Can R2 ping the R1 fast ethernet address?
    Can PC1 ping the R2 serial address?

    Can R2 ping the R3 serial address?
    Can R2 ping the R3 fast ethernet address?
    Can R1 ping the R3 fast ethernet address?
    Can R3 ping P2's non-connected serial IP address (the 10.1.1.2 address)

    etc....
    :mike: Cisco Certifications -- Collect the Entire Set!
  • Options
    amb1s1amb1s1 Member Posts: 408
    This is the picture of my topology:

    Lab on Flickr - Photo Sharing!

    I can ping all the routers from each router. I can Ping PC-A from Router_1 and vice-versa.
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • Options
    miller811miller811 Member Posts: 897
    if you run a show ip route in the hosts (routers) they will show only one entry under the configuration you have entered..

    gateway of last resort is blank

    on those routers add
    ip route 0.0.0.0 0.0.0.0 fastEthernet0/0
    which tell the router that any address is does not recognize forward out through f0/0

    now run show ip route

    Gateway of last resort is 0.0.0.0 to network 0.0.0.0

    C 192.168.3.0/24 is directly connected, FastEthernet0/0
    S* 0.0.0.0/0 is directly connected, FastEthernet0/0

    everything will ping straight through
    I don't claim to be an expert, but I sure would like to become one someday.

    Quest for 11K pages read in 2011
    Page Count total to date - 1283
  • Options
    mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    He'd probably wants the no ip route command on the "PCs" so that they act like PCs and use the default gateway for non-local network traffic -- otherwise they are just more routers.

    If he can ping the default gateway address on R1 but not the Serial IP on R1 -- then it would come back to checking the "default gateway" on the "PC" -- either wrong IP or not used because routing is enabled on the "PC router"


    edit: should be no ip routing to make the router act like a stupid PC.
    :mike: Cisco Certifications -- Collect the Entire Set!
  • Options
    miller811miller811 Member Posts: 897
    mikej412 wrote: »
    He'd probably wants the no ip route command on the "PCs" so that they act like PCs and use the default gateway for non-local network traffic -- otherwise they are just more routers.

    If he can ping the default gateway address on R1 but not the Serial IP on R1 -- then it would come back to checking the "default gateway" on the "PC" -- either wrong IP or not used because routing is enabled on the "PC router"

    You the man.

    the "router" was acting like a router (imagine that) icon_surprised.gif, once the no ip routing was adding, it followed the default gateway and pinged PC to PC through the network.
    I don't claim to be an expert, but I sure would like to become one someday.

    Quest for 11K pages read in 2011
    Page Count total to date - 1283
  • Options
    amb1s1amb1s1 Member Posts: 408
    mikej412 wrote: »
    He'd probably wants the no ip route command on the "PCs" so that they act like PCs and use the default gateway for non-local network traffic -- otherwise they are just more routers.

    If he can ping the default gateway address on R1 but not the Serial IP on R1 -- then it would come back to checking the "default gateway" on the "PC" -- either wrong IP or not used because routing is enabled on the "PC router"
    I get the following when I do the no ip route command on PC-a:
    PC-A(config)#no ip route
    % Incomplete command.
    
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • Options
    amb1s1amb1s1 Member Posts: 408
    miller811 wrote: »
    You the man.

    the "router" was acting like a router (imagine that) icon_surprised.gif, once the no ip routing was adding, it followed the default gateway and pinged PC to PC through the network.

    OK I got it, I did the no ip routing and is pinging. Thanks for your help
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • Options
    mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    amb1s1 wrote: »
    no ip routing
    Yep -- that's it. I usually toss in the e and get the error, then I go for rout and tab completion. It's not something that you do everyday on routers in real life. :D
    :mike: Cisco Certifications -- Collect the Entire Set!
Sign In or Register to comment.