How do I open pix 501 ports?

mathelizemathelize Member Posts: 66 ■■□□□□□□□□
Hello, I'd like to open pix 501 ports to allow traffic from the internet to terminate on Windows server 2008 used as a VPN server. The pix is functioning already as a remote access vpn server and it's working fine. I wonder if I could use the win2k8 server as a site to site vpn server and the pix still sitting in front as a firewall.
Any help will be very much appreciated.
Thanks!
In my Lab
I have access to any cisco equipment I need

Comments

  • john-ciscojohn-cisco Member Posts: 6 ■□□□□□□□□□
    You could, but have to allow it.

    What access-list are on the pix?
    Do a "sh access-group" to see
    Then check those access-lists "sh access-list" based on the interface it is applied. ACL on a pix is applied INBOUND only.

    What VPN traffic do you want to allow?
    Is the server being accessed from a live internet IP? Is that IP natted as a static on the pix, check with sh static.

    hth
  • MentholMooseMentholMoose Member Posts: 1,525 ■■■■■■■■□□
    Why not use the PIX for the site to site VPN? Even if the other side isn't a PIX, it should still be possible to get working... I've done various combinations with no problems, such as PIX to Netscreen, ASA, and Sonicwall. The 501 is pretty weak though, so with stronger encryption you may get as low as 1MB/sec VPN throughput.

    Anyway to set up a forwarded port, you have to modify your ACL assigned to the outside interface to allow the port, then setup a static translation to map that port from the outside interface to the server. So a barebones config to forward 9999/tcp (assuming external IP is 172.16.0.50) to server 10.0.0.5 would be like this:

    Create ACL:
    access-list site_vpn_acl permit tcp any host 172.16.0.50 eq 9999

    Assign ACL to outside interface:
    access-group site_vpn_acl in interface outside

    Create static translation:
    static (inside,outside) tcp 172.16.0.50 9999 10.0.0.5 9999 netmask 255.255.255.255
    MentholMoose
    MCSA 2003, LFCS, LFCE (expired), VCP6-DCV
  • mathelizemathelize Member Posts: 66 ■■□□□□□□□□
    Why not use the PIX for the site to site VPN? Even if the other side isn't a PIX, it should still be possible to get working... I've done various combinations with no problems, such as PIX to Netscreen, ASA, and Sonicwall. The 501 is pretty weak though, so with stronger encryption you may get as low as 1MB/sec VPN throughput.

    Anyway to set up a forwarded port, you have to modify your ACL assigned to the outside interface to allow the port, then setup a static translation to map that port from the outside interface to the server. So a barebones config to forward 9999/tcp (assuming external IP is 172.16.0.50) to server 10.0.0.5 would be like this:

    Create ACL:
    access-list site_vpn_acl permit tcp any host 172.16.0.50 eq 9999

    Assign ACL to outside interface:
    access-group site_vpn_acl in interface outside

    Create static translation:
    static (inside,outside) tcp 172.16.0.50 9999 10.0.0.5 9999 netmask 255.255.255.255

    Thanks for your reply, so you mean I can use a pix 501 at one end and then maybe a windows server 2008 at the other end.
    In my Lab
    I have access to any cisco equipment I need
  • MentholMooseMentholMoose Member Posts: 1,525 ■■■■■■■■□□
    mathelize wrote: »
    Thanks for your reply, so you mean I can use a pix 501 at one end and then maybe a windows server 2008 at the other end.
    I think it's probably possible, although I haven't done it. Search the net for a tutorial or configuration guide.
    MentholMoose
    MCSA 2003, LFCS, LFCE (expired), VCP6-DCV
  • mathelizemathelize Member Posts: 66 ■■□□□□□□□□
    john-cisco wrote: »
    You could, but have to allow it.

    What access-list are on the pix?
    Do a "sh access-group" to see
    Then check those access-lists "sh access-list" based on the interface it is applied. ACL on a pix is applied INBOUND only.

    What VPN traffic do you want to allow?
    Is the server being accessed from a live internet IP? Is that IP natted as a static on the pix, check with sh static.

    hth

    Firewall# sh access-list
    access-list cached ACL log flows: total 0, denied 0 (deny-flow-max 256)
    alert-interval 300
    access-list inside_outbound_nat0_acl; 1 elements
    access-list inside_outbound_nat0_acl line 1 permit ip any 192.168.1.192 255.255.255.224 (hitcnt=0)
    access-list outside_cryptomap_dyn_20; 1 elements
    access-list outside_cryptomap_dyn_20 line 1 permit ip any 192.168.1.192 255.255.255.224 (hitcnt=0)
    Firewall# sh access-group
    Firewall# sh run
    : Saved
    :
    PIX Version 6.3(5)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password dSNg1WnOGfn/OyHV encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    hostname Firewall
    domain-name mathelize.com
    fixup protocol dns maximum-length 512
    fixup protocol ft.p 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol t.f.t.p 69
    names
    access-list inside_outbound_nat0_acl permit ip any 192.168.1.192 255.255.255.224
    access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.192 255.255.255.224
    pager lines 24
    icmp permit any outside
    icmp permit any inside
    mtu outside 1500
    mtu inside 1500
    ip address outside dhcp setroute
    ip address inside 192.168.1.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool VPN_POOL 192.168.1.201-192.168.1.209
    pdm location 192.168.1.2 255.255.255.255 inside
    pdm location 192.168.1.192 255.255.255.224 outside
    pdm history enable
    arp timeout 14400
    global (outside) 10 interface
    nat (inside) 0 access-list inside_outbound_nat0_acl
    nat (inside) 10 0.0.0.0 0.0.0.0 0 0
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout sip-disconnect 0:02:00 sip-invite 0:03:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    aaa authentication enable console LOCAL
    aaa authentication http console LOCAL
    aaa authentication serial console LOCAL
    aaa authentication ssh console LOCAL
    aaa authentication telnet console LOCAL
    aaa authorization command LOCAL
    http server enable
    http 0.0.0.0 0.0.0.0 outside
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-pptp
    sysopt connection permit-l2tp
    crypto ipsec transform-set TRANS_ESP_3DES_MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set TRANS_ESP_3DES_MD5 mode transport
    crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
    crypto dynamic-map outside_dyn_map 20 set transform-set TRANS_ESP_3DES_MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    telnet 192.168.1.0 255.255.255.0 inside
    telnet timeout 5
    ssh 0.0.0.0 0.0.0.0 outside
    ssh 192.168.1.0 255.255.255.0 inside
    ssh timeout 5
    management-access outside
    console timeout 0
    vpdn group PPTP-VPDN-GROUP accept dialin pptp
    vpdn group PPTP-VPDN-GROUP ppp authentication pap
    vpdn group PPTP-VPDN-GROUP ppp authentication chap
    vpdn group PPTP-VPDN-GROUP ppp authentication mschap
    vpdn group PPTP-VPDN-GROUP client configuration address local VPN_POOL
    vpdn group PPTP-VPDN-GROUP client configuration dns 4.2.2.1 208.67.222.222
    vpdn group PPTP-VPDN-GROUP pptp echo 60
    vpdn group PPTP-VPDN-GROUP client authentication local
    vpdn username molaleye password *********
    vpdn username sabidemi password *********
    vpdn username dmalomo password *********
    vpdn username dolaleye password *********
    vpdn username yemisi password *********
    vpdn enable outside
    vpdn enable inside
    dhcpd address 192.168.1.50-192.168.1.60 inside
    dhcpd dns 208.67.222.222 4.2.2.1
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd domain mathelize.com
    dhcpd enable inside
    privilege show level 0 command version
    privilege show level 0 command curpriv
    privilege show level 3 command pdm
    privilege show level 3 command blocks
    privilege show level 3 command ssh
    privilege configure level 3 command who
    privilege show level 3 command isakmp
    privilege show level 3 command ipsec
    privilege show level 3 command vpdn
    privilege show level 3 command local-host
    privilege show level 3 command interface
    privilege show level 3 command ip
    privilege configure level 3 command ping
    privilege show level 3 command uauth
    privilege configure level 5 mode enable command configure
    privilege show level 5 command running-config
    privilege show level 5 command privilege
    privilege show level 5 command clock
    privilege show level 5 command ntp
    privilege show level 5 mode configure command logging
    privilege show level 5 command fragment
    terminal width 80
    In my Lab
    I have access to any cisco equipment I need
Sign In or Register to comment.