eigrp redistribute connected
Hi,
I am so confused about (eigrp redistribute connected), I have below network
R1 (s1/0)<
>(s0/0) R2
And I configure R1 as below
!
interface Loopback0
ip address 10.10.10.1 255.255.255.0
!
interface Serial1/0
ip address 172.16.1.1 255.255.255.0
clock rate 64000
router eigrp 100
redistribute connected
network 172.16.0.0
auto-summary
And R2 as below
interface Serial0/0
ip address 172.16.1.2 255.255.255.0
!
router eigrp 100
network 172.16.0.0
auto-summary
It is very simple, but when I display the routing table for R2 (show ip route) it is mentioned the network (10.0.0.0) as /24 not as /8, why.
R2 routing table
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, Serial0/0
10.0.0.0/24 is subnetted, 1 subnets
D EX 10.10.10.0 [170/2297856] via 172.29.1.1, 00:15:05, Serial0/0
R1 routing table
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, Serial1/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, Loopback0
I am so confused about (eigrp redistribute connected), I have below network
R1 (s1/0)<
>(s0/0) R2
And I configure R1 as below
!
interface Loopback0
ip address 10.10.10.1 255.255.255.0
!
interface Serial1/0
ip address 172.16.1.1 255.255.255.0
clock rate 64000
router eigrp 100
redistribute connected
network 172.16.0.0
auto-summary
And R2 as below
interface Serial0/0
ip address 172.16.1.2 255.255.255.0
!
router eigrp 100
network 172.16.0.0
auto-summary
It is very simple, but when I display the routing table for R2 (show ip route) it is mentioned the network (10.0.0.0) as /24 not as /8, why.
R2 routing table
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, Serial0/0
10.0.0.0/24 is subnetted, 1 subnets
D EX 10.10.10.0 [170/2297856] via 172.29.1.1, 00:15:05, Serial0/0
R1 routing table
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, Serial1/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, Loopback0
Comments
-
jjbrog Member Posts: 149I'm still working on CCNA stuff(this being NP forum, seen the post on front page) but I'd imagine its cause you have the address configured as a /24 on the loopback interface?Started a forum for networking students, its new and needs people!
http://netadminstudents.zxq.net/phpBB3/
HTC students encouraged to join -
burbankmarc Member Posts: 460It's because it's an external route. You're assuming since the autosummarization is enabled, and that it's the classful edge that it should be advertised as 10.0.0.0/8, right?
Well EIGRP summary routes are trusted and have an AD of 5, external routes have an AD of 170, so external routes are not summarized.
I'm pretty sure that's why, I'm too lazy to look it up. -
networker050184 Mod Posts: 11,962 Modburbankmarc wrote: »It's because it's an external route. You're assuming since the autosummarization is enabled, and that it's the classful edge that it should be advertised as 10.0.0.0/8, right?
Well EIGRP summary routes are trusted and have an AD of 5, external routes have an AD of 170, so external routes are not summarized.
I'm pretty sure that's why, I'm too lazy to look it up.
Yep thats it.
If you use a network statement there instead of the redistribute command you will see your /8 like you are looking for.An expert is a man who has made all the mistakes which can be made. -
auos Member Posts: 186burbankmarc wrote: »Well EIGRP summary routes are trusted and have an AD of 5, external routes have an AD of 170, so external routes are not summarized.
External routes are not summarized even if I turn on auto-summary. -
networker050184 Mod Posts: 11,962 ModExternal routes are not summarized even if I turn on auto-summary.
Yes, that is correct.An expert is a man who has made all the mistakes which can be made.