Options

EIGRP not Peering

flipmadflipmad Member Posts: 184
I apologize I have been trying to delete the previous thread. But I am still having problems with EIGRP neigbors

ROUTER 1

interface FastEthernet0/0
description Connected to LAN
ip address 10.13.169.19 255.255.255.0 secondary
ip address 10.12.169.19 255.255.255.0

router eigrp 1
network 10.12.169.0 0.0.0.255
network 10.13.169.0 0.0.0.255
network 10.112.220.4 0.0.0.3
no auto-summary
neighbor 10.12.169.20 FastEthernet0/0

ROUTER 2

interface FastEthernet0/0
description LAN Connection
ip address 10.13.169.20 255.255.255.0 secondary
ip address 10.12.169.20 255.255.255.0

router eigrp 1
network 10.12.169.0 0.0.0.255
network 10.13.169.0 0.0.0.255
network 172.16.0.0
no auto-summary
no eigrp log-neighbor-changes


ROUTER 1

5#sh ip eigrp neigh
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.112.220.6 Tu1 14 3d18h 73 5000 0 83651


I have a tunnel built which is neighboring. But ROUTER 1 and ROUTER 2 will not neighbor up

Comments

  • Options
    Forsaken_GAForsaken_GA Member Posts: 4,024
    What do your debugs show?
  • Options
    flipmadflipmad Member Posts: 184
    I will perform some debugs and post them
  • Options
    hexemhexem Member Posts: 177
    R2 does not have a static neighbor set back to R1.

    this on R2:

    neighbor 10.12.169.19 FastEthernet0/0

    EIGRP: When you configure a static neighbor, EIGRP stops sending multicasts on the network, replacing them with the unicast. If you configure passive-interface, it blocks the unicast as well. Moreover, you cannot mix static and multicast between two neighbors; that is, you cannot configure a static neighbor on one side and the neighbor still sending multicast. They just don’t form the adjacency.
    ICND1 - Passed 25/01/10
    ICND2 - Passed 9/03/10

    Studying CCNA:S
  • Options
    flipmadflipmad Member Posts: 184
    Hmm, i have enabled term mon, but when I try to debug the EIGRP packets it does not show anything

    #debug eigrp packets
    EIGRP Packets debugging is on
    (UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB, SIAQUERY, SIAREPLY)



    sh ip eigrp interfaces detail
    IP-EIGRP interfaces for process 1
    Xmit Queue Mean Pacing Time Multicast Pending
    Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
    Fa0/0 0 0/0 0 0/1 0 0
    Hello interval is 5 sec
    Next xmit serial <none>
    Un/reliable mcasts: 0/0 Un/reliable ucasts: 0/0
    Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 0
    Retransmissions sent: 0 Out-of-sequence rcvd: 0
    Authentication mode is not set
    Use unicast



    I noticed on this interface I am showing

    32953 unknown protocol drops
  • Options
    hexemhexem Member Posts: 177
    see my post above
    ICND1 - Passed 25/01/10
    ICND2 - Passed 9/03/10

    Studying CCNA:S
  • Options
    flipmadflipmad Member Posts: 184
    hexem wrote: »
    R2 does not have a static neighbor set back to R1.

    this on R2:

    neighbor 10.12.169.19 FastEthernet0/0

    EIGRP: When you configure a static neighbor, EIGRP stops sending multicasts on the network, replacing them with the unicast. If you configure passive-interface, it blocks the unicast as well. Moreover, you cannot mix static and multicast between two neighbors; that is, you cannot configure a static neighbor on one side and the neighbor still sending multicast. They just don’t form the adjacency.


    I just removed my static neighbor off Router 1 but still no neighbors from the interface


    router eigrp 1
    network 10.12.169.0 0.0.0.255
    network 10.13.169.0 0.0.0.255
    network 10.112.220.4 0.0.0.3
    no auto-summary


    sh ip eigrp neigh
    IP-EIGRP neighbors for process 1
    H Address Interface Hold Uptime SRTT RTO Q Seq
    (sec) (ms) Cnt Num
    0 10.112.220.6 Tu1 12 3d20h 73 5000 0 83651
  • Options
    mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    Is this a lab issue or a production issue?

    Is this real hardware or a simulator/emulator?

    What's the routers and IOS versions?

    Are the interfaces up and up?

    If they are plugged into a switch, are the switch ports in the same VLAN?

    Can the two routers ping each other?
    :mike: Cisco Certifications -- Collect the Entire Set!
  • Options
    flipmadflipmad Member Posts: 184
    mikej412 wrote: »
    Is this a lab issue or a production issue?

    Is this real hardware or a simulator/emulator?

    What's the routers and IOS versions?

    Are the interfaces up and up?

    If they are plugged into a switch, are the switch ports in the same VLAN?

    Can the two routers ping each other?


    Mike these are production routers. I will post my results shortly (gotta finish up a conference call). Thanks for your help
  • Options
    mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    blake15 wrote: »
    I have a tunnel built which is neighboring. But ROUTER 1 and ROUTER 2 will not neighbor up
    What tunnel?
    :mike: Cisco Certifications -- Collect the Entire Set!
  • Options
    billscott92787billscott92787 Member Posts: 933
    Have you tried defining the neighbor statement on both routers to allow unicasts between the two? Have you got any debugs yet?
  • Options
    flipmadflipmad Member Posts: 184
    Is this a lab issue or a production issue? PRODUCTION

    Is this real hardware or a simulator/emulator? REAL 2611XM

    What's the routers and IOS versions? Advanced IP (The latest 12.4)

    Are the interfaces up and up? YES

    If they are plugged into a switch, are the switch ports in the same VLAN? No switches, there are directly connected

    Can the two routers ping each other? YES .19 can ping .20



    In regards to a tunnel. I have a VPN built back to another router (R3) which is UP and I see EIGRP neighbors to this router.


    interface Loopback1
    description VPN Loopback IP
    ip address 10.112.221.2 255.255.255.255
    !
    interface Tunnel1
    ip address 10.112.220.5 255.255.255.252
    ip ospf mtu-ignore
    tunnel source 10.112.221.2
    tunnel destination 10.112.221.1
    !
    interface FastEthernet0/0
    description Connected to LAN
    ip address 10.13.169.19 255.255.255.0 secondary
    ip address 10.12.169.19 255.255.255.0
    speed 100
    full-duplex
    !
    interface FastEthernet0/1
    description Connected to Internet
    ip address x.x.x.x x.x.x.x
    duplex auto
    speed auto
    crypto map xxxxx
    crypto ipsec df-bit clear
    crypto ipsec fragmentation before-encryption
    !
    router eigrp 1
    network 10.12.169.0 0.0.0.255
    network 10.13.169.0 0.0.0.255
    network 10.112.220.4 0.0.0.3
    no auto-summary


    I have the exact same setup at another location which is working perfectly (different IP). I just reboot the router and I am still not getting any DEBUG output on this router? (.19)

    Just FYI, I do not have access to router .20 to perform debug commands. I do have a sh run from that router.

    I have not tried creating static neighbors on both ends.

    What is really perplexing me is why the DEBUG output will not work.
  • Options
    Met44Met44 Member Posts: 194
    blake15 wrote: »
    What is really perplexing me is why the DEBUG output will not work.

    If you are connected via telnet/ssh, check that you have terminal monitor enabled.
  • Options
    flipmadflipmad Member Posts: 184
    Met44 wrote: »
    If you are connected via telnet/ssh, check that you have terminal monitor enabled.


    I am telnetted in and term mon it turned on. im satrting to think its a faulty router
  • Options
    hexemhexem Member Posts: 177
    Can you get a 'show ip protocols' for both router's
    ICND1 - Passed 25/01/10
    ICND2 - Passed 9/03/10

    Studying CCNA:S
  • Options
    chrisonechrisone Member Posts: 2,278 ■■■■■■■■■□
    It is not clear how your environment is. I don't fully understand why you need a neighbor statement on an Ethernet broadcast LAN to another neighbor in the same Ethernet broadcast LAN, the multicasts should reach each router fine.

    However now you say the two routers are in different locations. Are you trying to form an eigrp neighbor relationship via the internet with GRE tunnels? because your config is all wrong if thats the case.
    Certs: CISSP, EnCE, OSCP, CRTP, eCTHPv2, eCPPT, eCIR, LFCS, CEH, SPLK-1002, SC-200, SC-300, AZ-900, AZ-500, VHL:Advanced+
    2023 Cert Goals: SC-100, eCPTX
  • Options
    aldousaldous Member Posts: 105
    isn't eigrp funny with secondary addresses?
Sign In or Register to comment.