2511 Rxboot/break sequence?

Mrock4Mrock4 Banned Posts: 2,359 ■■■■■■■■□□
Hey all. So my 2511 was finally starting to function, or so it seemed, and now it will boot up until right before the line that lists the config register..then it hangs. No sequence of commands I've been able to find have remedied this. I'm just trying to find out how to break into rxboot in order to copy an image from my tftp server over to overwrite the flash. I'm confident that somehow I have a problem with memory/corrupted image..Here's what I get upon powering it up..

Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-INS-L), Version 12.0(21a), RELEASE SOFTWARE (fc1)
Image text-base: 0x030413E8, data-base: 0x00001000

cisco 2511 (68030) processor (revision L) with 14336K/2048K bytes of memory.
Processor board ID 05521395, with hardware revision 00000000
Bridging software.
X.25 software, Version 3.0.0.
1 Ethernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
16 terminal line(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read ONLY)

Then it hangs. Any ideas? I would GREATLY appreciate it. Right now I'm almost at a loss, but I'm doing the normal google thing..just can't seem to break the boot sequence. For what it's worth, I'm running Ubuntu and using minicom to console in.

Edit: I was able to simulate the break sequence by adjusting the baud rate to 1200, but this only worked once. Since then it hasn't worked again. Still trying, but who knows..


  • Mrock4Mrock4 Banned Posts: 2,359 ■■■■■■■■□□
    Ok, so I guess I posted for nothing. Got it working. Here's the process..

    1) Was only booting to the bootstrap prompt, thought it was odd that it kept reading "16384K bytes of processor board system flash (Read ONLY)", when it used to say "read/write"...

    2) Simulated a break by changing my terminal settings in minicom..changed baud rate to 1200, nothing else. Reloaded the router, held spacebar for 10-15 seconds to simulate a break sequence (per cisco docs)...disconnected terminal, changed baud back to 9600, opened another terminal..got the ">" prompt..

    3) Used o/r 0x42 (to bypass NVRAM)..reloaded with "I"

    4) Got the config, erased the startup config (thus blowing any config I had in there before, but I believe something in there may have caused this, so I am OK with that). Saved the running config to NVRAM, changed my conf reg back to the original value.....reloaded..voila.

    What a pain.
Sign In or Register to comment.