Newb DC issue

SephStormSephStorm Member Posts: 1,731 ■■■■■■■□□□
I have installed Windows Server 2003 and XP Pro in virtual machines in VMWare. The pro computer is currently a standalone machine, I want to add it to my domain.

I have installed DNS, DHCP, and Active Directory.

By performing query and recursive tests, I have determined that DNS is working. DHCP is not started, I assume because there are no clients in the domain to least IP addresses to.

I have verified that both machines are on the same network. The DC domain name is OffworldCorporation.local

When I attempt to join a domain through system properties-Computer/domain changes, I get a message saying "A domain controller for the domain OffworldCorporation.local could not be contacted." I have no idea what I am doing wrong.

Both computers can access the internet, however I cannot ping either computer from the other. Maybe I am using the wrong network connection on the VM?


  • Agent6376Agent6376 Member Posts: 201
    I've had much more luck with this when bridging the two connections to the existing network. However, you can statically set your IP addresses on each machine to see if you're able to get some communication before you try to implement DHCP. Also, once you get your machines pinging one another, try statically setting (or creating a DHCP option) your DNS to the Domain Controller. Most of the time that I've had issues joining a computer to a domain, it's been because of DNS.
  • SephStormSephStorm Member Posts: 1,731 ■■■■■■■□□□
    I am getting frustrated.

    I set the network type to bridged. I reinstalled everything but the OS on the server(VM), and I set static IP's for every host in my network.

    I can ping from the server to my host OS, but not from the host to the server.
  • leefdaddyleefdaddy Member Posts: 405
    Turn off Windows firewall on the server and hosts? Can you remote desktop to the server? Can you join the PCs to the domain, if they join the domain they are obviously communicating.
    Dustin Leefers
  • Hyper-MeHyper-Me Banned Posts: 2,059
    The XP client is using the IP of the DC for DNS, right?
  • dynamikdynamik Banned Posts: 12,312 ■■■■■■■■■□
    Hyper-Me wrote: »
    The XP client is using the IP of the DC for DNS, right?

    More than likely the problem. The XP machine requires the SRV records to locate the DC(s). If you're just using your gateway or your ISP's DNS servers to resolve domain names, it's not going to find those.
  • SephStormSephStorm Member Posts: 1,731 ■■■■■■■□□□
    ok, heres the config

    Netgear router:
    Dyn assigned IP.
    Dyn assigned DNS
    Router is configured as a DHCP server
    Router is configured as a DNS server

    Host Machine: laptop running W7.
    Static IP from router:
    DCHP svr:
    DNS server:

    Guest1: Win SVR 2003
    Static IP:
    Default gateway:
    DNS Server:

    Guest2: Win XP 2003
    Static IP:
    DNS Server: (This was the SVR, but changed until I can get on the domain)

    After allowing incoming ICMP echo requests, I was able to ping the server from bost the host and guest#2. I still cannot join the domain, nor can I Remote desktop to the pc, though that may be because I have never used it before.

    If someone wants to try remote desktop, let me know, i'll try it.
  • ZartanasaurusZartanasaurus Member Posts: 2,008 ■■■■■■■■■□
    Change the DNS address on all your machines to point to (your domain controller). Your router and ISP don't know that your domain exists, so it can't resolve "offworldcorporation.local". Your DC does and can. ;)
    Currently reading:
    IPSec VPN Design 44%
    Mastering VMWare vSphere 5​ 42.8%
  • SephStormSephStorm Member Posts: 1,731 ■■■■■■■□□□
    For some reason, after turning off windows firewall and doing the above, I can attempt to join at the next step(it askes for authentication. After that I am having another issue, which I think is a result of my domain length).

    What do I need to do to keep WF from blocking requests?
  • dynamikdynamik Banned Posts: 12,312 ■■■■■■■■■□
    It wasn't the firewall; you didn't have the DNS server configured correctly.

    Domain length isn't the problem. Check the event logs on Server 2003 to see what the problem is.

    You're using credentials for an account that can join computers to the domain?
  • SephStormSephStorm Member Posts: 1,731 ■■■■■■■□□□
    has to be the firewall, if I turn on the firewall, the host will come back with a message stating it can't find the domain(this is after changing the dns server)

    if i turn off the firewall, it finds the domain and asks for an account with permission to join the domain. (now my problem is I cant use the @ symbol in the xp vm for some reason.)
  • ZartanasaurusZartanasaurus Member Posts: 2,008 ■■■■■■■■■□
    SephStorm wrote: »
    (now my problem is I cant use the @ symbol in the xp vm for some reason.)

    You can do it NT style as well IE domain\administrator until you work out the @ problem.
    Currently reading:
    IPSec VPN Design 44%
    Mastering VMWare vSphere 5​ 42.8%
  • SephStormSephStorm Member Posts: 1,731 ■■■■■■■□□□
    I was finally able to join the domain, I copied the "@" symbol from the internet and pasted it into the window. So I am on the domain now, now I need to figure out the DHCP and DNS issues.

    First I need to figure out the firewall issue. I created account "mhunt" while the svr firewall was down. This user can log onto the domain whether the firewall is on or off. So I turned on the firewall and created account "dstorm" this user cannot log onto the domain when the fw is on, because the "domain is unreachable". I think my svr is in some high security mode where it doesn't except any connection not previously established. Thoughts?
  • Hyper-MeHyper-Me Banned Posts: 2,059
    you shouldnt need the @.

    I've always just typed in the username because it assumes the domain is the domain you just tried to join to.
  • SephStormSephStorm Member Posts: 1,731 ■■■■■■■□□□
    I don't need it when I login from the windows login screen, but like I said, the computer was "in a workgroup" and I had to join the domain from inside windows. right click my computer, properties, computer name, change (to join a domain).
  • rage_hograge_hog Banned Posts: 42 ■■□□□□□□□□
    Have you tried adding OffworldCorporation.local

    to the

    file on the XP box?
  • SephStormSephStorm Member Posts: 1,731 ■■■■■■■□□□
  • EssendonEssendon Member Posts: 4,546 ■■■■■■■■■■
    I too struggled with this when I first used VMware. This is what I now do, really simple.

    Leave your host machine alone. Dont worry what its config is. In VMware, make sure that the Ethernet is set to Host-only: A private network shared with the host. Now put the DC vm and the client vm on the same subnet. The client vm should point to the DC for DNS. As for letting the machines communicate on the internet (a DC shouldnt really communicate with the internet anyway), add another network adapter and leave it at the default option of bridged. This second network adapter should be able to pick up the network config from your Netgear router. Make sure that WF is off, otherwise you are going to have problems such as joining clients to the domain.

    NSX, NSX, more NSX..

    Blog >>
  • dynamikdynamik Banned Posts: 12,312 ■■■■■■■■■□
    Wait, you enabled the firewall in Server 2003?

    If so, yes, you're going to need to create exceptions for all the ports that a DC uses.

    I thought you were talking about the firewall in your client.

    Easier way to lock it down is to use the security configuration wizard (SCW).
Sign In or Register to comment.