Frame-relay switch config on J-Series
I though I post this rather than posting it inside Aldur's JNCIE-ER post..
For example say there are three routers.. R3,R4,R5 all connected to the frame relay switch you are looking at a config similar to this.. I did this for OSPF multipoint exercise in the JNCIP book...R3 is the hub and R4 and R5 are spoke
R3
interfaces {
t1-1/0/1 {
encapsulation frame-relay;
unit 0 {
multipoint;
family inet {
address 10.1.0.3/24 {
multipoint-destination 10.1.0.4 dlci 800;
multipoint-destination 10.1.0.5 dlci 1000;
}
}
}
}
protocols {
ospf {
area 0.0.0.0 {
interface t1-1/0/1.0 {
neighbor 10.1.0.4;
neighbor 10.1.0.5;
}
}
}
}
lab@R3> show ospf interface detail
Interface State Area DR ID BDR ID Nbrs
t1-1/0/1.0 PtToPt 0.0.0.0 0.0.0.0 0.0.0.0 2
Type: P2MP, Address: 10.1.0.3, Mask: 255.255.255.0, MTU: 1500, Cost: 65
Adj count: 2
Hello: 10, Dead: 40, ReXmit: 5, Not Stub
Auth type: None
lab@R3>
R4
interfaces {
t1-1/0/1 {
encapsulation frame-relay;
unit 0 {
point-to-point;
dlci 750;
family inet {
address 10.1.0.4/24;
}
}
}
protocols {
ospf {
area 0.0.0.0 {
interface t1-1/0/1.0;
}
}
}
[edit]
lab@R4#
lab@R4# run show ospf interface detail
Interface State Area DR ID BDR ID Nbrs
t1-1/0/1.0 PtToPt 0.0.0.0 0.0.0.0 0.0.0.0 1
Type: P2P, Address: 0.0.0.0, Mask: 0.0.0.0, MTU: 1500, Cost: 65
Adj count: 1
Hello: 10, Dead: 40, ReXmit: 5, Not Stub
Auth type: None
t1-1/0/1.0 PtToPt 0.0.0.0 0.0.0.0 0.0.0.0 0
Type: P2P, Address: 10.1.0.4, Mask: 255.255.255.0, MTU: 1500, Cost: 65
Adj count: 0, , Passive
Hello: 10, Dead: 40, ReXmit: 5, Not Stub
Auth type: None
R5
interfaces {
t1-1/0/1 {
encapsulation frame-relay;
unit 0 {
point-to-point;
dlci 750;
family inet {
address 10.1.0.5/24;
}
}
}
protocols {
ospf {
area 0.0.0.0 {
interface t1-1/0/1.0;
}
}
}
lab@R5>
lab@R5> show ospf interface detail
Interface State Area DR ID BDR ID Nbrs
t1-1/0/1.0 PtToPt 0.0.0.0 0.0.0.0 0.0.0.0 1
Type: P2P, Address: 0.0.0.0, Mask: 0.0.0.0, MTU: 1500, Cost: 65
Adj count: 1
Hello: 10, Dead: 40, ReXmit: 5, Not Stub
Auth type: None
t1-1/0/1.0 PtToPt 0.0.0.0 0.0.0.0 0.0.0.0 0
Type: P2P, Address: 10.1.0.5, Mask: 255.255.255.0, MTU: 1500, Cost: 65
Adj count: 0, , Passive
Hello: 10, Dead: 40, ReXmit: 5, Not Stub
Auth type: None
lab@R5>
Frame relay Switch configuration
interfaces {
t1-1/0/0 {
dce;
encapsulation frame-relay-ccc;
unit 400 {
encapsulation frame-relay-ccc;
point-to-point;
dlci 800;
}
unit 500 {
encapsulation frame-relay-ccc;
point-to-point;
dlci 1000;
}
}
t1-1/0/1 {
dce;
encapsulation frame-relay-ccc;
unit 100 {
encapsulation frame-relay-ccc;
point-to-point;
dlci 750;
}
}
t1-2/0/0 {
dce;
encapsulation frame-relay-ccc;
unit 100 {
encapsulation frame-relay-ccc;
point-to-point;
dlci 750;
}
}
}
protocols {
mpls {
interface all;
}
connections {
interface-switch R3-to-R4 {
interface t1-1/0/0.400;
interface t1-2/0/0.100;
}
interface-switch R3-to-R5 {
interface t1-1/0/0.500;
interface t1-1/0/1.100;
}
}
}
[edit]
root@Frame_Relay_Switch#
root@Frame_Relay_Switch>
root@Frame_Relay_Switch> show connections interface-switch
CCC and TCC connections [Link Monitoring On]
Legend for status (St) Legend for connection types
UN -- uninitialized if-sw: interface switching
NP -- not present rmt-if: remote interface switching
WE -- wrong encapsulation lsp-sw: LSP switching
DS -- disabled tx-p2mp-sw: transmit P2MP switching
Dn -- down rx-p2mp-sw: receive P2MP switching
-> -- only outbound conn is up
<- -- only inbound conn is up Legend for circuit types
Up -- operational intf -- interface
RmtDn -- remote CCC down tlsp -- transmit LSP
Restart -- restarting rlsp -- receive LSP
Connection/Circuit Type St Time last up # Up trans
R3-to-R4 if-sw Up Sep 9 05:54:43 1
t1-1/0/0.400 intf Up
t1-2/0/0.100 intf Up
R3-to-R5 if-sw Up Sep 9 06:24:00 1
t1-1/0/0.500 intf Up
t1-1/0/1.100 intf Up
R4-to-R5 if-sw Up Sep 9 06:24:00 1
t1-1/0/1.400 intf Up
t1-2/0/0.500 intf Up
root@Frame_Relay_Switch>
root@Frame_Relay_Switch> show interfaces t1-1/0/1
Physical interface: t1-1/0/1, Enabled, Physical link is Up
Interface index: 142, SNMP ifIndex: 38
Link-level type: Frame-Relay-CCC, MTU: 1504, Clocking: Internal, Speed: T1,
Loopback: None, FCS: 16, Framing: ESF
Device flags : Present Running
Interface flags: Point-To-Point SNMP-Traps Internal: 0x4000
Link flags : No-Keepalives DCE
ANSI LMI settings: n392dce 3, n393dce 4, t392dce 15 seconds
LMI: Input: 162 (00:00:06 ago), Output: 167 (00:00:06 ago)
DTE statistics:
Enquiries sent : 0
Full enquiries sent : 0
Enquiry responses received : 0
Full enquiry responses received : 0
DCE statistics:
Enquiries received : 135
Full enquiries received : 27
Enquiry responses sent : 140
Full enquiry responses sent : 27
Common statistics:
Unknown messages received : 0
Asynchronous updates received : 0
Out-of-sequence packets received : 0
Keepalive responses timedout : 1
CoS queues : 8 supported, 8 maximum usable queues
Last flapped : 2009-09-08 20:27:56 UTC (09:57:00 ago)
Input rate : 0 bps (0 pps)
Output rate : 0 bps (0 pps)
DS1 alarms : None
DS1 defects : None
Logical interface t1-1/0/1.100 (Index 6 (SNMP ifIndex 45)
Flags: Point-To-Point SNMP-Traps Encapsulation: FR-CCC
Input packets : 331
Output packets: 223
Protocol ccc, MTU: 1504
Flags: None
DLCI 750
Flags: Active
Total down time: 00:16:18 sec, Last down: 00:42:32 ago
Input packets : 331
Output packets: 223
Logical interface t1-1/0/1.400 (Index 70) (SNMP ifIndex 53)
Flags: Point-To-Point SNMP-Traps Encapsulation: FR-CCC
Input packets : 0
Output packets: 0
Protocol ccc, MTU: 1504
Flags: None
DLCI 1000
Flags: Active
Total down time: 0 sec, Last down: Never
Input packets : 0
Output packets: 0
DLCI statistics:
Active DLCI :2 Inactive DLCI :0
root@Frame_Relay_Switch>
All above done on a J-Series... But you could always do b2b connection on Jseries t1 interfaces...
For example say there are three routers.. R3,R4,R5 all connected to the frame relay switch you are looking at a config similar to this.. I did this for OSPF multipoint exercise in the JNCIP book...R3 is the hub and R4 and R5 are spoke
R3
interfaces {
t1-1/0/1 {
encapsulation frame-relay;
unit 0 {
multipoint;
family inet {
address 10.1.0.3/24 {
multipoint-destination 10.1.0.4 dlci 800;
multipoint-destination 10.1.0.5 dlci 1000;
}
}
}
}
protocols {
ospf {
area 0.0.0.0 {
interface t1-1/0/1.0 {
neighbor 10.1.0.4;
neighbor 10.1.0.5;
}
}
}
}
lab@R3> show ospf interface detail
Interface State Area DR ID BDR ID Nbrs
t1-1/0/1.0 PtToPt 0.0.0.0 0.0.0.0 0.0.0.0 2
Type: P2MP, Address: 10.1.0.3, Mask: 255.255.255.0, MTU: 1500, Cost: 65
Adj count: 2
Hello: 10, Dead: 40, ReXmit: 5, Not Stub
Auth type: None
lab@R3>
R4
interfaces {
t1-1/0/1 {
encapsulation frame-relay;
unit 0 {
point-to-point;
dlci 750;
family inet {
address 10.1.0.4/24;
}
}
}
protocols {
ospf {
area 0.0.0.0 {
interface t1-1/0/1.0;
}
}
}
[edit]
lab@R4#
lab@R4# run show ospf interface detail
Interface State Area DR ID BDR ID Nbrs
t1-1/0/1.0 PtToPt 0.0.0.0 0.0.0.0 0.0.0.0 1
Type: P2P, Address: 0.0.0.0, Mask: 0.0.0.0, MTU: 1500, Cost: 65
Adj count: 1
Hello: 10, Dead: 40, ReXmit: 5, Not Stub
Auth type: None
t1-1/0/1.0 PtToPt 0.0.0.0 0.0.0.0 0.0.0.0 0
Type: P2P, Address: 10.1.0.4, Mask: 255.255.255.0, MTU: 1500, Cost: 65
Adj count: 0, , Passive
Hello: 10, Dead: 40, ReXmit: 5, Not Stub
Auth type: None
R5
interfaces {
t1-1/0/1 {
encapsulation frame-relay;
unit 0 {
point-to-point;
dlci 750;
family inet {
address 10.1.0.5/24;
}
}
}
protocols {
ospf {
area 0.0.0.0 {
interface t1-1/0/1.0;
}
}
}
lab@R5>
lab@R5> show ospf interface detail
Interface State Area DR ID BDR ID Nbrs
t1-1/0/1.0 PtToPt 0.0.0.0 0.0.0.0 0.0.0.0 1
Type: P2P, Address: 0.0.0.0, Mask: 0.0.0.0, MTU: 1500, Cost: 65
Adj count: 1
Hello: 10, Dead: 40, ReXmit: 5, Not Stub
Auth type: None
t1-1/0/1.0 PtToPt 0.0.0.0 0.0.0.0 0.0.0.0 0
Type: P2P, Address: 10.1.0.5, Mask: 255.255.255.0, MTU: 1500, Cost: 65
Adj count: 0, , Passive
Hello: 10, Dead: 40, ReXmit: 5, Not Stub
Auth type: None
lab@R5>
Frame relay Switch configuration
interfaces {
t1-1/0/0 {
dce;
encapsulation frame-relay-ccc;
unit 400 {
encapsulation frame-relay-ccc;
point-to-point;
dlci 800;
}
unit 500 {
encapsulation frame-relay-ccc;
point-to-point;
dlci 1000;
}
}
t1-1/0/1 {
dce;
encapsulation frame-relay-ccc;
unit 100 {
encapsulation frame-relay-ccc;
point-to-point;
dlci 750;
}
}
t1-2/0/0 {
dce;
encapsulation frame-relay-ccc;
unit 100 {
encapsulation frame-relay-ccc;
point-to-point;
dlci 750;
}
}
}
protocols {
mpls {
interface all;
}
connections {
interface-switch R3-to-R4 {
interface t1-1/0/0.400;
interface t1-2/0/0.100;
}
interface-switch R3-to-R5 {
interface t1-1/0/0.500;
interface t1-1/0/1.100;
}
}
}
[edit]
root@Frame_Relay_Switch#
root@Frame_Relay_Switch>
root@Frame_Relay_Switch> show connections interface-switch
CCC and TCC connections [Link Monitoring On]
Legend for status (St) Legend for connection types
UN -- uninitialized if-sw: interface switching
NP -- not present rmt-if: remote interface switching
WE -- wrong encapsulation lsp-sw: LSP switching
DS -- disabled tx-p2mp-sw: transmit P2MP switching
Dn -- down rx-p2mp-sw: receive P2MP switching
-> -- only outbound conn is up
<- -- only inbound conn is up Legend for circuit types
Up -- operational intf -- interface
RmtDn -- remote CCC down tlsp -- transmit LSP
Restart -- restarting rlsp -- receive LSP
Connection/Circuit Type St Time last up # Up trans
R3-to-R4 if-sw Up Sep 9 05:54:43 1
t1-1/0/0.400 intf Up
t1-2/0/0.100 intf Up
R3-to-R5 if-sw Up Sep 9 06:24:00 1
t1-1/0/0.500 intf Up
t1-1/0/1.100 intf Up
R4-to-R5 if-sw Up Sep 9 06:24:00 1
t1-1/0/1.400 intf Up
t1-2/0/0.500 intf Up
root@Frame_Relay_Switch>
root@Frame_Relay_Switch> show interfaces t1-1/0/1
Physical interface: t1-1/0/1, Enabled, Physical link is Up
Interface index: 142, SNMP ifIndex: 38
Link-level type: Frame-Relay-CCC, MTU: 1504, Clocking: Internal, Speed: T1,
Loopback: None, FCS: 16, Framing: ESF
Device flags : Present Running
Interface flags: Point-To-Point SNMP-Traps Internal: 0x4000
Link flags : No-Keepalives DCE
ANSI LMI settings: n392dce 3, n393dce 4, t392dce 15 seconds
LMI: Input: 162 (00:00:06 ago), Output: 167 (00:00:06 ago)
DTE statistics:
Enquiries sent : 0
Full enquiries sent : 0
Enquiry responses received : 0
Full enquiry responses received : 0
DCE statistics:
Enquiries received : 135
Full enquiries received : 27
Enquiry responses sent : 140
Full enquiry responses sent : 27
Common statistics:
Unknown messages received : 0
Asynchronous updates received : 0
Out-of-sequence packets received : 0
Keepalive responses timedout : 1
CoS queues : 8 supported, 8 maximum usable queues
Last flapped : 2009-09-08 20:27:56 UTC (09:57:00 ago)
Input rate : 0 bps (0 pps)
Output rate : 0 bps (0 pps)
DS1 alarms : None
DS1 defects : None
Logical interface t1-1/0/1.100 (Index 6 (SNMP ifIndex 45)
Flags: Point-To-Point SNMP-Traps Encapsulation: FR-CCC
Input packets : 331
Output packets: 223
Protocol ccc, MTU: 1504
Flags: None
DLCI 750
Flags: Active
Total down time: 00:16:18 sec, Last down: 00:42:32 ago
Input packets : 331
Output packets: 223
Logical interface t1-1/0/1.400 (Index 70) (SNMP ifIndex 53)
Flags: Point-To-Point SNMP-Traps Encapsulation: FR-CCC
Input packets : 0
Output packets: 0
Protocol ccc, MTU: 1504
Flags: None
DLCI 1000
Flags: Active
Total down time: 0 sec, Last down: Never
Input packets : 0
Output packets: 0
DLCI statistics:
Active DLCI :2 Inactive DLCI :0
root@Frame_Relay_Switch>
All above done on a J-Series... But you could always do b2b connection on Jseries t1 interfaces...
IS-IS Sleeps.
BGP peers are quiet.
Something must be wrong.
BGP peers are quiet.
Something must be wrong.