multicast
Hello,
I have 3 routers connected like that: R1-R2-R3 and I am trying to run pim dense mode between them.
Can someone tell me why the ping from R1 (the source) to group 239.0.0.1 fails ?
R1:
mihai@juniper9.6# run ping logical-system R1 239.0.0.1 ttl 10 bypass-routing
PING 239.0.0.1 (239.0.0.1): 56 data bytes
^C
--- 239.0.0.1 ping statistics ---
242 packets transmitted, 0 packets received, 100% packet loss
R3
mihai@juniper9.6# show protocols igmp
interface em1.34;
interface em1.32 {
disable;
static {
group 239.0.0.1;
}
}
mihai@juniper9.6# run show multicast route logical-system R2
Family: INET
Group: 239.0.0.1
Source: 10.10.10.1/32
Upstream interface: em2.21
Family: INET6
mihai@juniper9.6# run show pim neighbors logical-system R2
Instance: PIM.master
B = Bidirectional Capable, G = Generation Identifier,
H = Hello Option Holdtime, L = Hello Option LAN Prune Delay,
P = Hello Option DR Priority
Interface IP V Mode Option Uptime Neighbor addr
em2.21 4 2 HPLG 00:07:21 10.10.10.1
em2.23 4 2 HPLG 00:07:21 10.10.20.3
Is there a way to configure a juniper router to join a multicast group? In cisco this can be done with 'ip igmp join-group' command.
Thanks
I have 3 routers connected like that: R1-R2-R3 and I am trying to run pim dense mode between them.
Can someone tell me why the ping from R1 (the source) to group 239.0.0.1 fails ?
R1:
mihai@juniper9.6# run ping logical-system R1 239.0.0.1 ttl 10 bypass-routing
PING 239.0.0.1 (239.0.0.1): 56 data bytes
^C
--- 239.0.0.1 ping statistics ---
242 packets transmitted, 0 packets received, 100% packet loss
R3
mihai@juniper9.6# show protocols igmp
interface em1.34;
interface em1.32 {
disable;
static {
group 239.0.0.1;
}
}
mihai@juniper9.6# run show multicast route logical-system R2
Family: INET
Group: 239.0.0.1
Source: 10.10.10.1/32
Upstream interface: em2.21
Family: INET6
mihai@juniper9.6# run show pim neighbors logical-system R2
Instance: PIM.master
B = Bidirectional Capable, G = Generation Identifier,
H = Hello Option Holdtime, L = Hello Option LAN Prune Delay,
P = Hello Option DR Priority
Interface IP V Mode Option Uptime Neighbor addr
em2.21 4 2 HPLG 00:07:21 10.10.10.1
em2.23 4 2 HPLG 00:07:21 10.10.20.3
Is there a way to configure a juniper router to join a multicast group? In cisco this can be done with 'ip igmp join-group' command.
Thanks
Comments
-
mumulox Member Posts: 31 ■■□□□□□□□□I turned on sap on R3 interface:
mihai@juniper9.6# show protocols
igmp {
interface em1.34;
interface em1.32 {
static {
group 239.0.0.1;
}
}
}
sap {
listen 239.0.0.1;
}
em1.32 is the interfaces connected to R2 em2.23. now, a ping from R1 to 239.0.01 generate te folowing result:
mihai@juniper9.6# run ping 239.0.0.1 bypass-routing ttl 10 interface em1.12
64 bytes from 10.10.20.3: icmp_seq=50 ttl=63 time=1.292 ms (DUP!)
64 bytes from 10.10.10.2: icmp_seq=51 ttl=64 time=0.849 ms
64 bytes from 10.10.20.3: icmp_seq=51 ttl=63 time=1.072 ms (DUP!)
64 bytes from 10.10.10.2: icmp_seq=52 ttl=64 time=0.850 ms
64 bytes from 10.10.20.3: icmp_seq=52 ttl=63 time=1.576 ms (DUP!)
Why i receive response from R2 ? This is the full config:
R1:
mihai@juniper9.6# show
interfaces {
em1 {
unit 12 {
description link-to-R2;
vlan-id 12;
family inet {
address 10.10.10.1/24;
}
protocols {
ospf {
area 0.0.0.0 {
interface em1.12;
}
}
pim {
interface em1.12 {
mode dense;
priority 30;
}
}
}
R2:
mihai@juniper9.6# show
interfaces {
em2 {
unit 21 {
description link-to-R1;
vlan-id 12;
family inet {
address 10.10.10.2/24;
}
family iso;
}
unit 23 {
description link-to-R3;
vlan-id 23;
family inet {
address 10.10.20.2/24;
}
protocols {
ospf {
area 0.0.0.0 {
interface em2.21;
interface em2.23;
}
}
pim {
interface em2.21 {
mode dense;
priority 20;
}
interface em2.23 {
mode dense;
}
}
}
R3:
mihai@juniper9.6# show
interfaces {
em1 {
unit 32 {
description link-to-R2;
vlan-id 23;
family inet {
address 10.10.20.3/24;
}
protocols {
igmp {
interface em1.34;
interface em1.32 {
static {
group 239.0.0.1;
}
}
}
sap {
listen 239.0.0.1;
}
ospf {
area 0.0.0.0 {
interface em1.32;
}
} -
mumulox Member Posts: 31 ■■□□□□□□□□[edit logical-systems R2]
mihai@juniper9.6# run show igmp group logical-system R2 239.0.0.1
Interface: local
Group: 239.0.0.1
Source: 0.0.0.0
Last reported by: Local
Timeout: 0 Type: Dynamic
The last reporter for 239.0.0.1 group shouldn`t be R3 ? -
mumulox Member Posts: 31 ■■□□□□□□□□[edit logical-systems R2]
mihai@juniper9.6# run show igmp group logical-system R2 239.0.0.1
Interface: local
Group: 239.0.0.1
Source: 0.0.0.0
Last reported by: Local
Timeout: 0 Type: Dynamic
The last reporter for 239.0.0.1 group shouldn`t be R3 ?
Solved. I just reloaded olive . Thanks for your help zrcheng