RIP/OSPF redistribute problem

Dilbert65Dilbert65 Posts: 73Member ■■□□□□□□□□
See attached pic of network lay out.

On R4 I have 3 loopbacks. R5 can see them with "show ip route" but cant ping them. I am trying to redistribute the rip route from R4/R1 to the ospf network through area 0 to area 34. All the routers in area 0 can ping the loopbacks on R4 that was learned by ospf via the rip injection on R1. R2/R5 are setup with a virtual-link.


R%: DTE
interface Serial0
ip address 172.12.34.5 255.255.255.0
router ospf 100
log-adjacency-changes
network 172.12.34.0 0.0.0.255 area 34


R2: DCE
interface Serial1
ip address 172.12.34.2 255.255.255.0
clockrate 56000

router ospf 100
network 172.12.34.0 0.0.0.255 area 34
network 172.12.123.0 0.0.0.255 area 0

simple point to point yet R5 cant ping the routes it learned about on R4 with ospf but can ping anything in Area 0 and Area 34. Any help would be great, Thanks

Comments

  • Dilbert65Dilbert65 Posts: 73Member ■■□□□□□□□□
    little more info. R4 does nto have any area 34 ip's in its route table. I do a tracert and the ping gets to R1 then stops so R4 does not know how to get the ping back to R5, but why?
  • Dilbert65Dilbert65 Posts: 73Member ■■□□□□□□□□
    OK I found the magic command.

    On R1 I had to put this in to get everything to work

    router rip
    redist ospf 100 match int metric 10


    I will leave this thread incase anybody else runs into this problem.
Sign In or Register to comment.