Bgp help!!
adriansizemore
Member Posts: 51 ■■□□□□□□□□
I am in need of some serious help. I am studying for my exam in June and i have a lab issue. pe1 is not receiving any prefixes from r1(as2).
Why is the vrf (ca1) on PE 1 receiving all the 172.16.0.0/16 routes via the longer AS path, 10 22 90 2 ?, instead of straight from r1?
There is a prefix on r6 to prevent it from sending 172.16.0.0/16 out to pe2:
===========
R6:
router bgp 22
bgp log-neighbor-changes
neighbor 125.68.3.2 remote-as 10
neighbor 172.16.0.9 remote-as 1
neighbor 172.16.5.1 remote-as 2
neighbor 172.16.6.1 remote-as 90
!
address-family ipv4
redistribute static
neighbor 125.68.3.2 activate
neighbor 125.68.3.2 prefix-list NO_TRANIST out
neighbor 172.16.0.9 activate
neighbor 172.16.0.9 prefix-list NO_TRANSIT out
no neighbor 172.16.5.1 activate
neighbor 172.16.6.1 activate
no auto-summary
no synchronization
exit-address-family
!
ip prefix-list NO_TRANSIT seq 5 deny 172.16.1.0/30
===============
Regardless of the prefix-list, the vrf ca1 on pe1 should be getting the prefixes from r1 right?
=================
CONFIGS:
r1#sho config
!
!
ip cef
!
!
interface Loopback0
ip address 128.20.0.1 255.255.255.255
!
interface FastEthernet0/0
description ce(r1) to pe1 0/0 (vrf-ca1)
ip address 172.16.0.5 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.1.1 255.255.255.252
ip ospf cost 5
duplex auto
speed auto
!
interface FastEthernet1/0
description r1 to r2 0/0
ip address 172.16.3.1 255.255.255.252
ip ospf cost 5
duplex auto
speed auto
!
router ospf 1
router-id 128.20.0.1
log-adjacency-changes
redistribute bgp 2 subnets
passive-interface FastEthernet0/0
network 128.20.0.1 0.0.0.0 area 0.0.0.0
network 172.16.0.0 0.0.255.255 area 0.0.0.0
!
router bgp 2
bgp log-neighbor-changes
neighbor 128.20.0.5 remote-as 2
neighbor 128.20.0.5 update-source Loopback0
neighbor 172.16.0.6 remote-as 1
!
address-family ipv4
redistribute ospf 1 match internal external 1 external 2
neighbor 128.20.0.5 activate
neighbor 172.16.0.6 activate
neighbor 172.16.0.6 prefix-list NO_TRANSIT out
no auto-summary
no synchronization
exit-address-family
!
!
ip prefix-list NO_TRANSIT seq 10 deny 125.68.0.0/24
ip prefix-list NO_TRANSIT seq 20 permit 0.0.0.0/0 ge 32
r5#sho config
!
ip cef
!
interface Loopback0
ip address 128.20.0.5 255.255.255.255
!
interface FastEthernet0/0
ip address 172.16.2.2 255.255.255.252
ip ospf cost 5
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 172.16.3.6 255.255.255.252
ip ospf cost 5
duplex auto
speed auto
!
interface Serial2/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial2/0.50 point-to-point
ip address 172.16.5.1 255.255.255.252
snmp trap link-status
frame-relay interface-dlci 50
!
router ospf 1
log-adjacency-changes
redistribute bgp 2 subnets
passive-interface Serial2/0.50
network 128.20.0.5 0.0.0.0 area 0.0.0.0
network 172.16.0.0 0.0.255.255 area 0.0.0.0
!
router bgp 2
no synchronization
bgp log-neighbor-changes
redistribute static
redistribute ospf 1 match internal external 1 external 2
neighbor 128.20.0.1 remote-as 2
neighbor 128.20.0.1 update-source Loopback0
neighbor 172.16.5.2 remote-as 90
no auto-summary
Why is the vrf (ca1) on PE 1 receiving all the 172.16.0.0/16 routes via the longer AS path, 10 22 90 2 ?, instead of straight from r1?
There is a prefix on r6 to prevent it from sending 172.16.0.0/16 out to pe2:
===========
R6:
router bgp 22
bgp log-neighbor-changes
neighbor 125.68.3.2 remote-as 10
neighbor 172.16.0.9 remote-as 1
neighbor 172.16.5.1 remote-as 2
neighbor 172.16.6.1 remote-as 90
!
address-family ipv4
redistribute static
neighbor 125.68.3.2 activate
neighbor 125.68.3.2 prefix-list NO_TRANIST out
neighbor 172.16.0.9 activate
neighbor 172.16.0.9 prefix-list NO_TRANSIT out
no neighbor 172.16.5.1 activate
neighbor 172.16.6.1 activate
no auto-summary
no synchronization
exit-address-family
!
ip prefix-list NO_TRANSIT seq 5 deny 172.16.1.0/30
===============
Regardless of the prefix-list, the vrf ca1 on pe1 should be getting the prefixes from r1 right?
=================
r1(as2)-------->[pe1vrf ca1(as1)] <-{rt import}---------\ | ^ | | {rt import} | (ospf) [pe2vrf ca2(as1)] [pe2vrf inet(as1)] | | | | | | r5(as2)--->isp2(as90)---->r6(as22)----------------->inet(as10) IP subnet of AS 2 is 172.16.0.0/16 I am redistributing bgp and ospf PE1: pe1#sh ip bgp v v ca1 BGP table version is 233, local router ID is 128.40.0.1 Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, r RIB-failure, S Stale Origin codes: i - IGP, e - EGP, ? - incomplete Network Next Hop Metric LocPrf Weight Path Route Distinguisher: 2:1 (default for vrf ca1) r>i172.16.0.4/30 128.40.0.2 0 100 0 10 22 90 2 ? Network Next Hop Metric LocPrf Weight Path *>i172.16.1.0/30 128.40.0.2 0 100 0 10 22 90 2 ? *>i172.16.2.0/30 128.40.0.2 0 100 0 10 22 90 2 ? *>i172.16.3.0/30 128.40.0.2 0 100 0 10 22 90 2 ? *>i172.16.3.4/30 128.40.0.2 0 100 0 10 22 90 2 ? *>i172.16.4.0/30 128.40.0.2 0 100 0 10 22 90 2 ? *>i172.16.5.0/30 128.40.0.2 0 100 0 10 22 90 2 ? *>i172.16.5.0/24 128.40.0.2 0 100 0 10 22 ? pe1# R1: * i172.16.1.0/30 172.16.3.5 15 100 0 ? *> 0.0.0.0 0 32768 ? * i172.16.2.0/30 128.20.0.5 0 100 0 ? *> 172.16.3.2 15 32768 ? * i172.16.3.0/30 172.16.3.5 10 100 0 ? *> 0.0.0.0 0 32768 ? * i172.16.3.4/30 128.20.0.5 0 100 0 ? *> 172.16.3.2 10 32768 ? * i172.16.4.0/30 172.16.2.1 105 100 0 ? *> 172.16.1.2 105 32768 ? * i172.16.5.0/30 128.20.0.5 0 100 0 ? *> 172.16.3.2 74 32768 ? * i172.16.5.0/24 172.16.5.2 0 100 0 90 22 ? *> 172.16.0.6 0 1 10 22 ? 172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks O 172.16.4.0/30 [110/105] via 172.16.1.2, 01:08:12, FastEthernet0/1 C 172.16.0.4/30 is directly connected, FastEthernet0/0 O 172.16.5.0/30 [110/74] via 172.16.3.2, 01:08:12, FastEthernet1/0 B 172.16.5.0/24 [20/0] via 172.16.0.6, 00:11:22 O 172.16.3.4/30 [110/10] via 172.16.3.2, 01:08:12, FastEthernet1/0 C 172.16.1.0/30 is directly connected, FastEthernet0/1 O 172.16.2.0/30 [110/15] via 172.16.3.2, 01:08:12, FastEthernet1/0 C 172.16.3.0/30 is directly connected, FastEthernet1/0 R5: *> 172.16.1.0/30 172.16.3.5 15 32768 ? * i 128.20.0.1 0 100 0 ? *> 172.16.2.0/30 0.0.0.0 0 32768 ? * i 172.16.3.2 15 100 0 ? *> 172.16.3.0/30 172.16.3.5 10 32768 ? * i 128.20.0.1 0 100 0 ? *> 172.16.3.4/30 0.0.0.0 0 32768 ? * i 172.16.3.2 10 100 0 ? *> 172.16.4.0/30 172.16.2.1 105 32768 ? * i 172.16.1.2 105 100 0 ? *> 172.16.5.0/30 0.0.0.0 0 32768 ? * i 172.16.3.2 74 100 0 ? * i172.16.5.0/24 172.16.0.6 0 100 0 1 10 22 ? *> 172.16.5.2 0 90 22 ? 172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks O 172.16.4.0/30 [110/105] via 172.16.2.1, 01:05:39, FastEthernet0/0 O 172.16.0.4/30 [110/11] via 172.16.3.5, 01:05:39, FastEthernet1/0 C 172.16.5.0/30 is directly connected, Serial2/0.50 B 172.16.5.0/24 [20/0] via 172.16.5.2, 00:10:57 C 172.16.3.4/30 is directly connected, FastEthernet1/0 O 172.16.1.0/30 [110/15] via 172.16.3.5, 01:05:39, FastEthernet1/0 C 172.16.2.0/30 is directly connected, FastEthernet0/0 O 172.16.3.0/30 [110/10] via 172.16.3.5, 01:05:39, FastEthernet1/0==========================================
CONFIGS:
r1#sho config
!
!
ip cef
!
!
interface Loopback0
ip address 128.20.0.1 255.255.255.255
!
interface FastEthernet0/0
description ce(r1) to pe1 0/0 (vrf-ca1)
ip address 172.16.0.5 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.1.1 255.255.255.252
ip ospf cost 5
duplex auto
speed auto
!
interface FastEthernet1/0
description r1 to r2 0/0
ip address 172.16.3.1 255.255.255.252
ip ospf cost 5
duplex auto
speed auto
!
router ospf 1
router-id 128.20.0.1
log-adjacency-changes
redistribute bgp 2 subnets
passive-interface FastEthernet0/0
network 128.20.0.1 0.0.0.0 area 0.0.0.0
network 172.16.0.0 0.0.255.255 area 0.0.0.0
!
router bgp 2
bgp log-neighbor-changes
neighbor 128.20.0.5 remote-as 2
neighbor 128.20.0.5 update-source Loopback0
neighbor 172.16.0.6 remote-as 1
!
address-family ipv4
redistribute ospf 1 match internal external 1 external 2
neighbor 128.20.0.5 activate
neighbor 172.16.0.6 activate
neighbor 172.16.0.6 prefix-list NO_TRANSIT out
no auto-summary
no synchronization
exit-address-family
!
!
ip prefix-list NO_TRANSIT seq 10 deny 125.68.0.0/24
ip prefix-list NO_TRANSIT seq 20 permit 0.0.0.0/0 ge 32
r5#sho config
!
ip cef
!
interface Loopback0
ip address 128.20.0.5 255.255.255.255
!
interface FastEthernet0/0
ip address 172.16.2.2 255.255.255.252
ip ospf cost 5
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 172.16.3.6 255.255.255.252
ip ospf cost 5
duplex auto
speed auto
!
interface Serial2/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial2/0.50 point-to-point
ip address 172.16.5.1 255.255.255.252
snmp trap link-status
frame-relay interface-dlci 50
!
router ospf 1
log-adjacency-changes
redistribute bgp 2 subnets
passive-interface Serial2/0.50
network 128.20.0.5 0.0.0.0 area 0.0.0.0
network 172.16.0.0 0.0.255.255 area 0.0.0.0
!
router bgp 2
no synchronization
bgp log-neighbor-changes
redistribute static
redistribute ospf 1 match internal external 1 external 2
neighbor 128.20.0.1 remote-as 2
neighbor 128.20.0.1 update-source Loopback0
neighbor 172.16.5.2 remote-as 90
no auto-summary
10 years Military (6 as data tech)
A.A.S Telecom/Network Technologies
CCNA
642-611
Backbone Engineer
A.A.S Telecom/Network Technologies
CCNA
642-611
Backbone Engineer
Comments
-
adriansizemore Member Posts: 51 ■■□□□□□□□□i had a prefix-list on r1 that was not configured correctly
old:
R1:
router bgp 2
bgp log-neighbor-changes
neighbor 128.20.0.5 remote-as 2
neighbor 128.20.0.5 update-source Loopback0
neighbor 172.16.0.6 remote-as 1
!
address-family ipv4
redistribute ospf 1 match internal external 1 external 2
neighbor 128.20.0.5 activate
neighbor 172.16.0.6 activate
neighbor 172.16.0.6 prefix-list NO_TRANSIT out
no auto-summary
synchronization
exit-address-family
!
ip prefix-list NO_TRANSIT seq 10 deny 125.68.0.0/24
ip prefix-list NO_TRANSIT seq 20 permit 0.0.0.0/0 ge 32
New:
ip prefix-list NO_TRANSIT seq 20 permit 0.0.0.0/0 le 32
Basically, r1 was not sending any bgp updates out that was not a /32 mask.
10 years Military (6 as data tech)
A.A.S Telecom/Network Technologies
CCNA
642-611
Backbone Engineer