Options

OSPF poblem

SephStormSephStorm Member Posts: 1,731 ■■■■■■■□□□
I have a simple setup in PT to use OSPF. Two of my routers, HQ and R1 work fine, and are communicating through OSPF, R2 is the third router and is not broadcasting or recieving updates that I can see. I am hoping for a little help in seeing why?

HQ:
HQ#sh run
Building configuration...

Current configuration : 586 bytes
!
version 12.3
no service password-encryption
!
hostname HQ
!
!
!
!
interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Loopback0
ip address 172.16.1.17 255.255.255.240
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 172.16.1.16 0.0.0.15 area 0
network 192.168.10.0 0.0.0.3 area 0
default-information originate
!
ip classless
ip route 0.0.0.0 0.0.0.0 Loopback0
!
!
!
!
line con 0
line vty 0 4
login
!
!
end

R1:
R1#sh run
Building configuration...

Current configuration : 516 bytes
!
version 12.3
no service password-encryption
!
hostname R1
!
!
!
!
interface FastEthernet0/0
ip address 192.168.10.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Loopback0
ip address 10.10.10.1 255.255.255.0
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 10.10.10.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.3 area 0
!
ip classless
!
!
!
!
line con 0
line vty 0 4
login
!
!
end

R2:
R2#sh run
Building configuration...

Current configuration : 518 bytes
!
version 12.3
no service password-encryption
!
hostname R2
!
!
!
!
interface FastEthernet0/0
ip address 192.168.10.6 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Loopback0
ip address 172.16.1.33 255.255.255.248
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 172.16.1.32 0.0.0.7 area 0
network 192.168.10.4 0.0.0.3 area 0
!
ip classless
!
!
!
!
line con 0
line vty 0 4
login
!
!
end

Please remember, I am a beginner, treat me kindly if I made any stupid mistakes. :)

Comments

  • Options
    Forsaken_GAForsaken_GA Member Posts: 4,024
    what is R2 actually connected to? I only see one interface up on all 3 routers, and HQ and R1 share a common subnet, but R2's /30 doesn't seem to share a common subnet with either of the other 2 routers.
  • Options
    rgutowski200rgutowski200 Member Posts: 4 ■□□□□□□□□□
    i agree with forsaken. There isnt anyway for R2 and HQ to connect. What you need is to use serial connections in each R1 and R2 (1T-WIC cards) and a 2T-WIC card in HQ. Make sure you keep track of which serial connect on HQ goes to each router. Also keep track of which end of the serial cable is the DTE/DCE and dont forget to set the clock rate.
    Good luck
  • Options
    Forsaken_GAForsaken_GA Member Posts: 4,024
    Well, if R2 is connected to HQ's other fa interface, he just needs to configure it, bring it up, and make sure it's included in OSPF and the adjacency will probably come right up.

    If R2 is connected to R1's, same thing. hard to say without knowing if this is a hub and spoke topology, or a daisy chain
  • Options
    alan2308alan2308 Member Posts: 1,854 ■■■■■■■■□□
    SephStorm wrote: »
    Please remember, I am a beginner, treat me kindly if I made any stupid mistakes. :)

    Don't worry, we were all beginners at one time too. The only difference is some of us have practiced a lot more than you have at this point. icon_mrgreen.gif

    It looks like the other guys already have this figured out. But one thing I can add is that a screen shot or quick drawing of your topology can help us out a lot.
  • Options
    SephStormSephStorm Member Posts: 1,731 ■■■■■■■□□□
    this configuration requires three routers connected directly with straight through cables, no serial connections.

    The Ip configuration is as follows:

    HQ L0: 172.16.1.17 255.255.255.240 wildcard 15
    HQ F0: 192.168.10.1 255.255.255.252 wc 3

    R1 L0: 10.10.10.1 255.255.255.0 wc 255
    R1 F0: 192.168.10.2 255.255.255.0 wc 3

    R2 L0: 172.16.1.33 255.255.255.248 wc 7
    R2 F0: 192.168.10.6 255.255.255.252 wc 3

    I'm not understanding you on the subets, none of the interfaces can be in the same subnet, or they would overlap.

    conf.png
  • Options
    alan2308alan2308 Member Posts: 1,854 ■■■■■■■■□□
    SephStorm wrote: »
    this configuration requires three routers connected directly with straight through cables, no serial connections.

    The Ip configuration is as follows:

    HQ L0: 172.16.1.17 255.255.255.240 wildcard 15
    HQ F0: 192.168.10.1 255.255.255.252 wc 3

    R1 L0: 10.10.10.1 255.255.255.0 wc 255
    R1 F0: 192.168.10.2 255.255.255.0 wc 3

    R2 L0: 172.16.1.33 255.255.255.248 wc 7
    R2 F0: 192.168.10.6 255.255.255.252 wc 3

    I'm not understanding you on the subets, none of the interfaces can be in the same subnet, or they would overlap.

    EDIT: picture incoming.

    Different interfaces on the same router cannot overlap (for example FastEthernet0/0 on R1 and FastEthernet0/1 on R1 cannot be on the same subnet). But for two routers to communicate, the interfaces that connect need to be on the same subnet or they won't be able to talk.

    In your example, FastEthernet 0/0 on HQ and FastEthernet 0/0 on R1 are on the same subnet (192.168.10.0/30), therefore if those two interfaces are connected, they can talk to each other. You have FastEthernet 0/0 on R2 on a different subnet, and nothing else on that same subnet, so it can't talk to anything at this point no matter what it is hooked to.

    A little clearer?
  • Options
    alan2308alan2308 Member Posts: 1,854 ■■■■■■■■□□
    Ok, I have the picture now. All 3 routers connect to the same Ethernet LAN, so they all need to have IP addresses in the same subnet. You're using a 255.255.255.252 subnet mask, which only allows for 2 hosts, so theres no way to connect a third host to the same network. If you change all three FastEthernet ports to use a 255.255.255.0 subnet mask (or anything higher than what you have actually), then all 3 routers will be able to communicate. You also will want to use the same subnet mask on all hosts on a single network.
  • Options
    Forsaken_GAForsaken_GA Member Posts: 4,024
    ok, the switch was the missing part. You're using a shared ethernet medium, so all interfaces have layer 2 adjacency.

    You need to change the mask on all of your interfaces to at least 255.255.255.248, and redo your ospf network statements to reflect the changed subnet mask (ie, change .3 to .7), and your adjacencies should come up.

    The mistake you made is that you're addressing your links like they're point to point links, when they're actually broadcast links.
  • Options
    SephStormSephStorm Member Posts: 1,731 ■■■■■■■□□□
    Okay, I understand, we didnt have a new IP addressing scheme, that worked with the setup we had, We had a drawing of the network used, and he got his ip addresses from somewhere. I didn't like them so I used a scheme from the book for a serial network, and of course, both of our schemes didn't work.

    We'll probably ask someone to make a usable scheme for us tomorrow, at least we know the commands are correct.

    EDIT: if someone wanted to think of one... that would be greatly appreciated... :P lol
  • Options
    alan2308alan2308 Member Posts: 1,854 ■■■■■■■■□□
    SephStorm wrote: »
    We'll probably ask someone to make a usable scheme for us tomorrow, at least we know the commands are correct.

    You'll get a lot more out of it if you're making your own addressing scheme. Sooner or later you're going to have to start doing yourself anyway. In a basic setup like this, all you need is a subnet mask that can accommodate the number of hosts you're using, and IP addresses that are all within that subnet.

    Edit: and I see you're a CNA student, so you surely have learned all about IP addressing, subnetting and VLSM at this point of the game.
  • Options
    Forsaken_GAForsaken_GA Member Posts: 4,024
    SephStorm wrote: »
    Okay, I understand, we didnt have a new IP addressing scheme, that worked with the setup we had, We had a drawing of the network used, and he got his ip addresses from somewhere. I didn't like them so I used a scheme from the book for a serial network, and of course, both of our schemes didn't work.

    We'll probably ask someone to make a usable scheme for us tomorrow, at least we know the commands are correct.

    EDIT: if someone wanted to think of one... that would be greatly appreciated... :P lol

    Well, you were kind of on the right track, using RFC1918 space for internal router links is fine, you just needed to do a little planning and understand how it communicates. Since your routers are using a shared communication medium (ethernet) they need to share the same ip space (subnet). Using a /29 mask will work fine, but doesn't give you much room for growth. If part of the exercise is to conserve as much IP space as possible, but still allow for growth, I'd probably use a /27 mask, and justify that as enough IP space to cover routers being plugged into all 24 ports of that switch.

    In reality, I'd just assign a /24 and be done with it.
Sign In or Register to comment.