Options

VLAN not spreading on GNS3

amb1s1amb1s1 Member Posts: 408
I'm having trouble with this lab. I created a VLAN on DW2 and the VLAN is not spreading to the other switches. I can ping DW2 to and from, but the switch is not spreading. I have DW1 and DW2 as a Servers and with a POD1 domain, and I have ASW1 and ASW2 as clients with a POD1 domain. I think this is a bug on GNS3
Lab on Flickr - Photo Sharing!

ASW1
Building configuration...

Current configuration : 1934 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ASW1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
ip audit po max-events 100
!         
!         
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/1
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/2
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/3
 description to Fa0/0 PC1
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/4
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/5
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/6
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/7
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/8
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/9
 switchport trunk allowed vlan 1,11,13,1002-1005
 switchport mode trunk
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/10
 switchport trunk allowed vlan 1,11,13,1002-1005
 switchport mode trunk
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/11
 switchport trunk allowed vlan 1,11,13,1002-1005
 switchport mode trunk
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/12
 switchport trunk allowed vlan 1,11,13,1002-1005
 switchport mode trunk
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/13
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/14
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/15
 no ip address
 duplex full
 speed 100
!
interface Vlan1
 ip address 10.1.1.3 255.255.0.0
!
ip http server
no ip http secure-server
ip classless
!
!
!         
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 logging synchronous
 login
!
!
end

ASW2
Building configuration...

Current configuration : 1926 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ASW2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
ip audit po max-events 100
!
!         
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/1
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/2
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/3
 description Connection to Fa0/0 PC2
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/4
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/5
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/6
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/7
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/8
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/9
 switchport trunk allowed vlan 1,12,14,1002-1005
 switchport mode trunk
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/10
 switchport trunk allowed vlan 1,12,14,1002-1005
 switchport mode trunk
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/11
 switchport trunk allowed vlan 1,12,14,1002-1005
 switchport mode trunk
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/12
 switchport trunk allowed vlan 1,12,14,1002-1005
 switchport mode trunk
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/13
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/14
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/15
 no ip address
 duplex full
 speed 100
!
interface Vlan1
 ip address 10.1.1.4 255.255.0.0
!
ip http server
no ip http secure-server
ip classless
!
!
!         
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 logging synchronous
 login
!
!
end

DW1
Building configuration...

Current configuration : 1841 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname DW1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
ip audit po max-events 100
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
!
interface FastEthernet0/1
 switchport trunk allowed vlan 1,11,13,1002-1005
 switchport mode trunk
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/2
 switchport trunk allowed vlan 1,11,13,1002-1005
 switchport mode trunk
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/3
 switchport trunk allowed vlan 1,12,14,1002-1005
 switchport mode trunk
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/4
 switchport trunk allowed vlan 1,12,14,1002-1005
 switchport mode trunk
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/5
 switchport mode trunk
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/6
 switchport mode trunk
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/7
 no ip address
 shutdown
!
interface FastEthernet0/8
 no ip address
 shutdown 
!
interface FastEthernet0/9
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/10
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/11
 no ip address
 shutdown
!
interface FastEthernet0/12
 no ip address
 shutdown
!
interface FastEthernet0/13
 no ip address
 shutdown
!         
interface FastEthernet0/14
 no ip address
 shutdown
!
interface FastEthernet0/15
 no ip address
 shutdown
!
interface Vlan1
 ip address 10.1.1.1 255.255.0.0
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
!
!         
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 logging synchronous
 login
!
!
end

DW2
Building configuration...

Current configuration : 1699 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname DW2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
ip audit po max-events 100
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex full
 speed 100
!
interface FastEthernet0/1
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/2
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/3
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/4
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/5
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/6
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/7
 no ip address
 shutdown
 duplex full
 speed 100
!
interface FastEthernet0/8
 no ip address
 shutdown
 duplex full
 speed 100
!
interface FastEthernet0/9
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/10
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/11
 no ip address
 shutdown
 duplex full
 speed 100
!
interface FastEthernet0/12
 no ip address
 shutdown
 duplex full
 speed 100
!
interface FastEthernet0/13
 no ip address
 shutdown
 duplex full
 speed 100
!
interface FastEthernet0/14
 no ip address
 shutdown
 duplex full
 speed 100
!
interface FastEthernet0/15
 no ip address
 shutdown
 duplex full
 speed 100
!
interface Vlan1
 ip address 10.1.1.2 255.255.0.0
!
ip http server
no ip http secure-server
ip classless
!
!
!         
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 logging synchronous
 login
!
!
end
David G.
http://gomezd.com <
My Tshoot test Blog
http://twitter.com/ipnet255

Comments

  • Options
    networker050184networker050184 Mod Posts: 11,962 Mod
    I don't think you are running into a bug, I've set up VTP on dynamips a few times and everything worked as it should.

    How are you adding the new VLAN? A show vlan-s should let you know if its being added to the database properly.
    An expert is a man who has made all the mistakes which can be made.
  • Options
    ilcram19-2ilcram19-2 Banned Posts: 436
    need to setup vlan data base
  • Options
    amb1s1amb1s1 Member Posts: 408
    I created a VLAN 11 on DW1 and VLAN 11 spreaded to all switches, but not to DW2. I do sh vlan and ASW1 and ASW2 have VLAN 11, but VLAN 12 that I created on DW2 is only on DW2.
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • Options
    ccie1yrccie1yr Member Posts: 19 ■□□□□□□□□□
    amb1s1 wrote: »
    I created a VLAN 11 on DW1 and VLAN 11 spreaded to all switches, but not to DW2. I do sh vlan and ASW1 and ASW2 have VLAN 11, but VLAN 12 that I created on DW2 is only on DW2.

    You don't have any interface configured as trunk on DW2 switch. VTP only flows on trunk ports. So configure DW1-DW2 port as trunk on DW2. If VLAN even than spread than it should be issue with VTP domain or password on DW2. Do have a look at that.

    Do share the output of VTP on DW1 and DW2, for us to have a look.
  • Options
    amb1s1amb1s1 Member Posts: 408
    ccie1yr wrote: »
    You don't have any interface configured as trunk on DW2 switch. VTP only flows on trunk ports. So configure DW1-DW2 port as trunk on DW2. If VLAN even than spread than it should be issue with VTP domain or password on DW2. Do have a look at that.

    Do share the output of VTP on DW1 and DW2, for us to have a look.
    Thanks, I swear taht I config the inter with the switch mde trunk, but I guess I didn't. Thanks
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
Sign In or Register to comment.