default route propagation

DevilWAHDevilWAH Member Posts: 2,997 ■■■■■■■■□□
Just wondering how people do this in the real world.

Jeremy from CBT nuggets suggest that to get a default route in to EIGRP you simple create a default route

#ip route 0.0.0.0 0.0.0.0 x.x.x.x/interface

then go under

#router eigrp x

and add the command

#network 0.0.0.0 0.0.0.0

which does work, but it also means the router will be configured to add all connected interfaces that have IP address assigned to the routing table..

doing the same but replacing the network 0.0.0.0 command with

#redistribute static has the same effect of adding all static routes to the table.

Is there any way to only inject the default route in to EIGRP. I know you could go back and explicitly remove any routes that have been added with the above two commands. But that seems like extra work and messy.
  • If you can't explain it simply, you don't understand it well enough. Albert Einstein
  • An arrow can only be shot by pulling it backward. So when life is dragging you back with difficulties. It means that its going to launch you into something great. So just focus and keep aiming.

Comments

  • networker050184networker050184 Mod Posts: 11,962 Mod
    You can also do an interface summary for the default only or you can use the ip default network command. If this was production though and I had a static default configured and only wanted that redistributed I'd do it like below.
    ip prefix-list DEFAULT_ONLY seq 5 permit 0.0.0.0/0
    !
    route-map DEFAULT_ONLY permit 10
     match ip address prefix-list DEFAULT_ONLY
    !
    router eigrp 1
     redistribute static route-map DEFAULT_ONLY
    
    An expert is a man who has made all the mistakes which can be made.
  • CyanicCyanic Member Posts: 289
    What if you just use network 0.0.0.0?

    edit: Nevermind it does the same.

    Here is a better way.

    R2(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1
    R2(config)#ip default-network 192.168.1.0
    R2(config)#router eigrp 10
    R2(config-router)#network 192.168.1.0 0.0.0.255
  • DevilWAHDevilWAH Member Posts: 2,997 ■■■■■■■■□□
    ever interface with IP gets added to the routing tables and in to eigrp. oh this is on a layer 3 switch, not checked if it is neater on a router
    • If you can't explain it simply, you don't understand it well enough. Albert Einstein
    • An arrow can only be shot by pulling it backward. So when life is dragging you back with difficulties. It means that its going to launch you into something great. So just focus and keep aiming.
  • DevilWAHDevilWAH Member Posts: 2,997 ■■■■■■■■□□
    networker you solution is what i had in mind. :) just curious if theres a neater way to achive it (ie built in by cisco)
    • If you can't explain it simply, you don't understand it well enough. Albert Einstein
    • An arrow can only be shot by pulling it backward. So when life is dragging you back with difficulties. It means that its going to launch you into something great. So just focus and keep aiming.
  • burbankmarcburbankmarc Member Posts: 460
    just do a passive-interface default then no passive the interfaces you want. Then you don't have to worry about all interfaces participating in EIGRP.
  • ColbyGColbyG Member Posts: 1,264
    just do a passive-interface default then no passive the interfaces you want. Then you don't have to worry about all interfaces participating in EIGRP.

    They won't participate, but they'll be advertised.
  • networker050184networker050184 Mod Posts: 11,962 Mod
    DevilWAH wrote: »
    networker you solution is what i had in mind. :) just curious if theres a neater way to achive it (ie built in by cisco)


    Like I said, you can use the default-network command, but I'm not a big fan of that. The way the default route appears in the table always throws me off. You can also use the interface summary address to send the default. This doesn't scale very well though and you will have to get into leak maps if you want more specifics alos. I'm not a big fan of that method either.

    There is always more than one way to skin a cat, but my preference is for redistribute with a route-map. Its easy to update later if you want to let other routes slip through as well.
    An expert is a man who has made all the mistakes which can be made.
  • DevilWAHDevilWAH Member Posts: 2,997 ■■■■■■■■□□
    R2(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1
    R2(config)#ip default-network 192.168.1.0
    R2(config)#router eigrp 10
    R2(config-router)#network 192.168.1.0 0.0.0.255

    one problem with this is that if you have

    ip route 0.0.0.0 0.0.0.0 int f0/1

    then the default network command does not work :)

    which is unfortunate for me because the default next work is connected by a switched port. I suppose I could point to an IP address an use the default network command but I think unless any other sugestions networker has the answer I need (route maps). Cheers guys.
    • If you can't explain it simply, you don't understand it well enough. Albert Einstein
    • An arrow can only be shot by pulling it backward. So when life is dragging you back with difficulties. It means that its going to launch you into something great. So just focus and keep aiming.
  • networker050184networker050184 Mod Posts: 11,962 Mod
    You shouldn't have a static route pointing to just an exit interface on a multiaccess segment like ethernet. When you do that your router is going ot have to ARP for every destination. This will fill your ARP table with lots of crap and can cause resource exhaustion. It also relies on proxy ARP in that situation since you aren't actually going to be able to get an ARP reply from every destination on that single segment.

    My suggestion is to use the below format for static routes.
    ip route x.x.x.x y.y.y.y outgoing interface next-hop 
    

    This will cut down your ARP issue and also prevent the router from learning the next hop over an invalid interface.
    An expert is a man who has made all the mistakes which can be made.
  • DevilWAHDevilWAH Member Posts: 2,997 ■■■■■■■■□□
    You shouldn't have a static route pointing to just an exit interface on a multiaccess segment like ethernet. When you do that your router is going ot have to ARP for every destination. This will fill your ARP table with lots of crap and can cause resource exhaustion. It also relies on proxy ARP in that situation since you aren't actually going to be able to get an ARP reply from every destination on that single segment.

    My suggestion is to use the below format for static routes.
    ip route x.x.x.x y.y.y.y outgoing interface next-hop 
    

    This will cut down your ARP issue and also prevent the router from learning the next hop over an invalid interface.

    on a layer 3 switch you dont have that option.

    It is simply

    ip route 0.0.0.0 0.0.0.0 fastethernet 0/1

    This interfaced has to use arp proxy any way at the moment. The third part who control the other end wont configrue it nicely
    • If you can't explain it simply, you don't understand it well enough. Albert Einstein
    • An arrow can only be shot by pulling it backward. So when life is dragging you back with difficulties. It means that its going to launch you into something great. So just focus and keep aiming.
  • zerglingszerglings Senior Member Member Posts: 295 ■■■□□□□□□□
    From our head-end to our remote sites we use distribute-list to filter just the default route. From anywhere else, I think we just use redistribute static. Forgot now.
    :study: Life+
  • networker050184networker050184 Mod Posts: 11,962 Mod
    DevilWAH wrote: »
    on a layer 3 switch you dont have that option.

    It is simply

    ip route 0.0.0.0 0.0.0.0 fastethernet 0/1

    This interfaced has to use arp proxy any way at the moment. The third part who control the other end wont configrue it nicely

    You do on my 3750s here, but it might just be an IOS version deal. Either way you really should be at least specifying a next hop IP on an ethernet segment. Even if it's point to point.
    An expert is a man who has made all the mistakes which can be made.
  • DevilWAHDevilWAH Member Posts: 2,997 ■■■■■■■■□□
    one last thing and I sure me being blind.

    but in OSPF you can hard code the router address for the OSPF process.

    can you do the same in EIGRP and if so how. I want to use the nebiour command to allow me to control how the switchs form relation ships. but it would be nice to be able to give each switch a easy to remember address. (1.1.1.1, 2.2.2.2, .... )

    cheers
    • If you can't explain it simply, you don't understand it well enough. Albert Einstein
    • An arrow can only be shot by pulling it backward. So when life is dragging you back with difficulties. It means that its going to launch you into something great. So just focus and keep aiming.
  • networker050184networker050184 Mod Posts: 11,962 Mod
    You have to use the "eigrp router-id blah" command under the EIGRP process.

    EDIT: One important thing to remember about the neighbor command. As soon as you enable a static neighbor that interface stops processing ALL EIGRP multicast packets. That means if you have more than one neighbor on an interface you must define them all as neighbors and not just a subset of them.
    An expert is a man who has made all the mistakes which can be made.
  • DevilWAHDevilWAH Member Posts: 2,997 ■■■■■■■■□□
    cool. cheers for that i have to check again but dont rember seeing it on my 3550's and that side effect of stopoing all multicast traffic on the interface is exactly what i want it to do.because i have mutiple nebiours on an interface but dont want it to form full mesh.
    • If you can't explain it simply, you don't understand it well enough. Albert Einstein
    • An arrow can only be shot by pulling it backward. So when life is dragging you back with difficulties. It means that its going to launch you into something great. So just focus and keep aiming.
  • jovan88jovan88 Member Posts: 393
    the default-network command sucks because it doesn't work properly on classless addresses
Sign In or Register to comment.