3500/2900 voice&access vlans

chmorinchmorin Member Posts: 1,446 ■■■■■□□□□□
Could anyone explain to me why it is on my 3500 and 2900 my phones will not connect to my CME router when I issue on the interface:
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#switchport voice vlan 20

But will connect when I issue just:
Switch(config-if)#switchport access vlan 20

There is no computer attached with them, but it was my understanding that they would use the voice vlan when the phone is attached and initiates that 'mini trunk'. This occurred on both my 7906's and 7960. How would I enable the 7960 to allow a computer to work in its switchport?
Currently Pursuing
WGU (BS in IT Network Administration) - 52%| CCIE:Voice Written - 0% (0/200 Hours)
mikej412 wrote:
Cisco Networking isn't just a job, it's a Lifestyle.

Comments

  • mwgoodmwgood Member Posts: 293
    Make sure CDP is enabled on the port the phone attaches to.

    To allow a computer to work through the phone, just plug it into the PC port on the back of the phone.
  • chmorinchmorin Member Posts: 1,446 ■■■■■□□□□□
    mwgood wrote: »
    Make sure CDP is enabled on the port the phone attaches to.

    If I type in show cdp neighbors, It finds its attached switches/routers and it sees the IP phone, but it is tagging it with an H for host, and not P for phone. Do I need to enable cdp? I cant find the IOS command for it. EDIT: is it cdp run in global config mode?
    mwgood wrote: »
    To allow a computer to work through the phone, just plug it into the PC port on the back of the phone.

    I am aware of that, but it will be using the wrong vlan if I leave the configuration as is, if it works at all.
    Currently Pursuing
    WGU (BS in IT Network Administration) - 52%| CCIE:Voice Written - 0% (0/200 Hours)
    mikej412 wrote:
    Cisco Networking isn't just a job, it's a Lifestyle.
  • pitviperpitviper CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT Member Posts: 1,376 ■■■■■■■□□□
    Is it a 3524? If so the config is a little flakey = You have to configure the ports that the phones connect to as trunk ports in addition to the voice and data VLAN items.
    CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT
  • chmorinchmorin Member Posts: 1,446 ■■■■■□□□□□
    Wow, it is a 3524. You hit the nail on the head pitviper, you are amazing. I'll give that a shot next time around. That is so weird, I don't recall seeing that in any of my CCNA:V studies!
    pitviper wrote: »
    Is it a 3524? If so the config is a little flakey = You have to configure the ports that the phones connect to as trunk ports in addition to the voice and data VLAN items.

    Ahh I found this now:

    VLAN management on the Cisco 3524

    That is crazy. Duely noted though. At least I am not crazy with my initial configurations though. Thanks a load pit.
    Currently Pursuing
    WGU (BS in IT Network Administration) - 52%| CCIE:Voice Written - 0% (0/200 Hours)
    mikej412 wrote:
    Cisco Networking isn't just a job, it's a Lifestyle.
  • pitviperpitviper CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT Member Posts: 1,376 ■■■■■■■□□□
    No problem – It’s one of those things that you won’t find in a text book because it’s a non-issue with newer hardware. I was stumped myself the first time that I tried to setup a 3524/phone (I had a few 3524s in my original voice lab).

    Here’s a sample config that I found online:

    interface FastEthernet0/3
    desc Paul Phone/Switch
    switch trunk encap dot1q
    switch trunk native vlan 100
    switch trunk allow vlan 100,200
    switch mode trunk
    switch voice vlan 200
    spanning-tree portfast trunk
    CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT
  • chmorinchmorin Member Posts: 1,446 ■■■■■□□□□□
    pitviper wrote: »
    No problem – It’s one of those things that you won’t find in a text book because it’s a non-issue with newer hardware. I was stumped myself the first time that I tried to setup a 3524/phone (I had a few 3524s in my original voice lab).

    Here’s a sample config that I found online:

    interface FastEthernet0/3
    desc Paul Phone/Switch
    switch trunk encap dot1q
    switch trunk native vlan 100
    switch trunk allow vlan 100,200
    switch mode trunk
    switch voice vlan 200
    spanning-tree portfast trunk

    How does this work for allowing the PC's attached to say a 7960 to use an access vlan? would I have the native vlan as the access vlan I want them to use?
    Currently Pursuing
    WGU (BS in IT Network Administration) - 52%| CCIE:Voice Written - 0% (0/200 Hours)
    mikej412 wrote:
    Cisco Networking isn't just a job, it's a Lifestyle.
  • peanutnogginpeanutnoggin Member Posts: 1,096 ■■■□□□□□□□
    chmorin wrote: »
    How does this work for allowing the PC's attached to say a 7960 to use an access vlan? would I have the native vlan as the access vlan I want them to use?

    Chmorin,

    That is correct. If you look at pitviper's example, the native vlan 100 is saying the untagged traffic (PC traffic) will be on vlan 100 which is the access vlan for his PC.

    -Peanut
    We cannot have a superior democracy with an inferior education system!

    -Mayor Cory Booker
Sign In or Register to comment.