HWIC-D-9ESW issue

Yesterday, I was given a c2811 router with the above mentioned module installed. Actually, the hardware configuration is as follows:
1 - WIC-1DSU-T1 V2
1 - VIC2-4FXO
1 - VIC2-2FXS
1 - NM-HD-2V
1 - HWIC-D-9ESW

IOS - AdvEnt K9 12.4-15T1

This is a great addition for me as I now have PoE capabilities! Hense the problem. When I plug the phone into one of the 9ESW (powered) ports, the phone powers up but does not see the dhcp server (router)!

My current VoIP router is a 1760V and my DHCP router is a VG200.

Building configuration...
Current configuration : 2586 bytes
!
! Last configuration change at 13:49:54 MDT Tue Jul 13 2010
! NVRAM config last updated at 13:49:57 MDT Tue Jul 13 2010
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Hermesz_R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone MST -7
clock summer-time MDT recurring
no network-clock-participate slot 1 
!
!
ip cef    
!
!
!
multilink bundle-name authenticated
!
!
voice-card 0
 no dspfarm
!
voice-card 1
 no dspfarm
!
!
!
!
!
!
username ############### privilege 15 password 0 #########
archive
 log config
  hidekeys
!
!
!
!
!
!
interface FastEthernet0/0
 description $ETH-LAN$
 ip address #.#.#.# #.#.#.#
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.101
 encapsulation dot1Q 101
 ip address 10.10.11.20 255.255.255.224
 ip nat inside
 ip virtual-reassembly
!
interface FastEthernet0/1.107
 encapsulation dot1Q 107
 ip address 10.10.11.198 255.255.255.224
!
interface FastEthernet0/1/0
 switchport access vlan 101
 switchport voice vlan 107
!
interface FastEthernet0/1/1
 switchport access vlan 101
 switchport voice vlan 107
!
interface FastEthernet0/1/2
 switchport access vlan 101
 switchport voice vlan 107
!
interface FastEthernet0/1/3
 switchport access vlan 101
 switchport voice vlan 107
!
interface FastEthernet0/1/4
 switchport access vlan 101
 switchport voice vlan 107
 shutdown
!
interface FastEthernet0/1/5
 switchport mode trunk
 shutdown
!
interface FastEthernet0/1/6
 switchport mode trunk
 shutdown
!
interface FastEthernet0/1/7
 switchport access vlan 101
!
interface FastEthernet0/1/8
 switchport mode trunk
!
interface Serial0/2/0
 no ip address
 shutdown
 no fair-queue
!
interface Vlan1
 no ip address
!
router ospf 1
 log-adjacency-changes
 passive-interface FastEthernet0/0
 passive-interface Serial0/2/0
 network 10.10.0.0 0.0.255.255 area 0
!
ip route 0.0.0.0 0.0.0.0 #.#.#.#
!
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.10.11.0 0.0.0.31
!
!
!
!
!
!
control-plane
!
!
!         
voice-port 0/3/0
!
voice-port 0/3/1
!
voice-port 0/3/2
!
voice-port 0/3/3
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login local
line vty 5 988
 login local
!
scheduler allocate 20000 1000
ntp server 64.183.56.58 key 0 prefer
!
webvpn cef
!
end

OSPF loads correctly and I am able to ping the VoIP router and the DHCP Router (both on VLAN 107) from the 2811.

What am I missing regarding this switch module????icon_cry.gif

John
John
Current Progress:
Studying:
CCNA Security - 60%, CCNA Wireless - 80%, ROUTE - 10% (Way behind due to major Wireless Project)
Exams Passed:
CCNA - 640-802 - 17 Jan 2011 -- CVOICE v6 - 642-436 - 28 Feb 2011
2011 Goals
CCNP/CCNP:Voice

Comments

  • chmorinchmorin Member Posts: 1,446 ■■■■■□□□□□
    Well it looks like you don't have a native vlan set up in your sub-interfaces, but I'm not sure if that is causing this issue.

    What kind of phone is this?

    You might consider doing the following to test:

    switchport mode access
    no switchport access vlan 101
    no switchport voice vlan 107
    switchport access vlan 107


    Then reload the port. I'm not sure, but it could be that the configuration on a faMod for voice is different than a switch. I have never done it before.

    Also try testing inter-vlan routing. Plug in a computer or laptop to one of the interfaces and set the access vlan to 107 with no voice vlan. (Yes, i know 107 is your voice vlan, you do this to test and make sure the voice side of your configs are reaching the dhcp server). If the computer pulls the dhcp IP address, and the phone does not, then that helps you troubleshoot the issue.
    Currently Pursuing
    WGU (BS in IT Network Administration) - 52%| CCIE:Voice Written - 0% (0/200 Hours)
    mikej412 wrote:
    Cisco Networking isn't just a job, it's a Lifestyle.
  • pitviperpitviper CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT Member Posts: 1,376 ■■■■■■■□□□
    As chmorin said, try fixing the data sub interface (encapsulation dot1Q 101 native).

    Do a "show vlan brief" to make sure that the VLANs exist in the database, and are correctly applied to the switchports.

    DHCP router - Do you have option 150 setup w/the IP of the TFTP server (CME in this case) in the voice network DHCP scope? Is it on a different subnet? If so you’ll need to use an ip helper address.
    CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT
  • hermeszdatahermeszdata Member Posts: 225
    pitviper wrote: »
    DHCP router - Do you have option 150 setup w/the IP of the TFTP server (CME in this case) in the voice network DHCP scope? Is it on a different subnet? If you you’ll need to use an ip helper address.

    Voice subnet = 10.10.11.192/27 - VLAN 107
    Data Subnet = 10.10.11.0/27 - VLAN 101

    Even if I set up one of the ports as:

    switchport access vlan 101
    switchport mode access

    and plug a PC into that port, I cannot successfully ping any known interface in the network including the 2811's f0/0 or f0/1 interfaces.

    The phones are 7910 and 7960. They register fine with CME @ 10.10.11.194/27 when plugged into my 3550 switch with power packs.

    When connected to the 8esw, the sit at Configuring IP.

    J
    John
    Current Progress:
    Studying:
    CCNA Security - 60%, CCNA Wireless - 80%, ROUTE - 10% (Way behind due to major Wireless Project)
    Exams Passed:
    CCNA - 640-802 - 17 Jan 2011 -- CVOICE v6 - 642-436 - 28 Feb 2011
    2011 Goals
    CCNP/CCNP:Voice
  • pitviperpitviper CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT Member Posts: 1,376 ■■■■■■■□□□
    try "show vlan-switch" and see if ports look correct.

    If you don’t see both VLANS assigned to the ports then you may need to create them in the VLAN DB manually.
    CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT
  • hermeszdatahermeszdata Member Posts: 225
    pitviper wrote: »
    try "show vlan-switch" and see if ports look correct.

    If you don’t see both VLANS assigned to the ports then you may need to create them in the VLAN DB manually.

    sh vlan-switch has both vlans showing.
    sh ip int br has both vlans UP/UP

    sh cdp nei has the 7910, plugged into f0/1/3, as a neighbor!
    logged into the router using CNA shows the CoreSW (3550) and the 7910 in the topology view!

    This would lead me to believe that the hardware is functioning properly!

    EDIT:
    I just set f0/1/8 to:
    switchport access vlan 107
    switchport mode access

    and connected this port to my 3550 (port set for static access on vlan 107) and now the 7910 gets an IP address.

    I also tried the following:
    vlan 101,107 
    !
    !
    !
    !
    !
    interface FastEthernet0/0
     ip address something or another!
     ip nat outside
     ip virtual-reassembly
     duplex auto
     speed auto
    !
    interface FastEthernet0/1
     no ip address
     duplex auto
     speed auto
    !
    interface FastEthernet0/1/0
     switchport access vlan 101
     switchport trunk native vlan 101
     switchport mode trunk
     switchport voice vlan 107
    !
    interface FastEthernet0/1/1
    !
    interface FastEthernet0/1/2
    !
    interface FastEthernet0/1/3
     switchport access vlan 101
     switchport trunk native vlan 101
     switchport mode trunk
     switchport voice vlan 107
    !
    interface FastEthernet0/1/4
    !
    interface FastEthernet0/1/5
    !
    interface FastEthernet0/1/6
    !
    interface FastEthernet0/1/7
    !
    interface FastEthernet0/1/8
     switchport mode trunk
    !
    interface Serial0/2/0
     no ip address
     shutdown
    !
    interface Vlan1
     no ip address
    !
    interface Vlan101
     ip address 10.10.11.20 255.255.255.224
     ip nat inside
     ip virtual-reassembly
    !
    interface Vlan107
     ip address 10.10.11.198 255.255.255.224
     ip nat inside
     ip virtual-reassembly
    

    Again, this would allow devices connected to the 8esw to communicate with each other, BUT, does not allow access to the internet through f0/0!icon_cry.gif
    John
    Current Progress:
    Studying:
    CCNA Security - 60%, CCNA Wireless - 80%, ROUTE - 10% (Way behind due to major Wireless Project)
    Exams Passed:
    CCNA - 640-802 - 17 Jan 2011 -- CVOICE v6 - 642-436 - 28 Feb 2011
    2011 Goals
    CCNP/CCNP:Voice
  • pitviperpitviper CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT Member Posts: 1,376 ■■■■■■■□□□
    You may want to block out your public IP :)
    CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT
  • pitviperpitviper CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT Member Posts: 1,376 ■■■■■■■□□□
    hmmm, which ports are the phones plugged into in that latest example?
    CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT
  • hermeszdatahermeszdata Member Posts: 225
    pitviper wrote: »
    hmmm, which ports are the phones plugged into in that latest example?

    f0/1/3

    The real problem is now trying to get this router working as a stand alone system so the use of an external switch is un-necessary. I can run my entire home/office, including VoIP from this router alone IF I can get communications going between the 9esw and the built in interfaces on the router.
    John
    Current Progress:
    Studying:
    CCNA Security - 60%, CCNA Wireless - 80%, ROUTE - 10% (Way behind due to major Wireless Project)
    Exams Passed:
    CCNA - 640-802 - 17 Jan 2011 -- CVOICE v6 - 642-436 - 28 Feb 2011
    2011 Goals
    CCNP/CCNP:Voice
  • LuckycharmsLuckycharms Member Posts: 267
    attachment.php?attachmentid=509&stc=1&d=1279120978


    I have drawn up some simple diagrams of what I think your setup might look like minus the 1760. The major difference's between the two diagrams are connection method's and the DHCP locations.

    Diagram 1 -
    Connecting the phones and the VG simply through a switch port. This diagram allows you to keep your current setup with the VG acting as the DHCP, and FA 0/0 acting as your internet connection. (with the assumption that you are not using the T1 for internet)... Need configuration commands are as follow's....

    !
    !
    Config# vlan database
    vlan 101
    vlan 107
    apply 
    exit
    !
    !
    
    
    
    
    
    Building configuration...
    Current configuration : 2586 bytes
    !
    ! Last configuration change at 13:49:54 MDT Tue Jul 13 2010
    ! NVRAM config last updated at 13:49:57 MDT Tue Jul 13 2010
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Hermesz_R1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    clock timezone MST -7
    clock summer-time MDT recurring
    no network-clock-participate slot 1 
    !
    !
    ip cef    
    !
    !
    !
    multilink bundle-name authenticated
    !
    !
    voice-card 0
     no dspfarm
    !
    voice-card 1
     no dspfarm
    !
    !
    !
    !
    !
    !
    username ############### privilege 15 password 0 #########
    archive
     log config
      hidekeys
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
     description $ETH-LAN$
     ip address #.#.#.# #.#.#.#
     ip nat outside
     ip virtual-reassembly
     duplex auto
     speed auto
    !
    interface FastEthernet0/1
     no ip address
     duplex auto
     speed auto
    !
    interface FastEthernet0/1/0
     switchport access vlan 101
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/1
     switchport access vlan 101
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/2
     switchport access vlan 101
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/3
     switchport access vlan 101
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/4
     switchport access vlan 101
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/5
     switchport access vlan 101
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/6
     switchport access vlan 101
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/7
     switchport access vlan 101
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/8
     description Connected-to-VG
     switchport access vlan 101
    !
    interface Serial0/2/0
     no ip address
     shutdown
     no fair-queue
    !
    interface Vlan1
     no ip address
    !
    interface Vlan 101
    ip address 10.10.11.20 255.255.255.224
    ip nat inside
    !
    interface Vlan 107
    ip address 10.10.11.198 255.255.255.224
    !
    router ospf 1
     log-adjacency-changes
     passive-interface FastEthernet0/0
     passive-interface Serial0/2/0
     network 10.10.0.0 0.0.255.255 area 0
    !
    ip route 0.0.0.0 0.0.0.0 #.#.#.#
    !
    !
    ip http server
    no ip http secure-server
    ip nat inside source list 1 interface FastEthernet0/0 overload
    !
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 10.10.11.0 0.0.0.31
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !         
    voice-port 0/3/0
    !
    voice-port 0/3/1
    !
    voice-port 0/3/2
    !
    voice-port 0/3/3
    !
    voice-port 1/0/0
    !
    voice-port 1/0/1
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
     login local
    line vty 5 988
     login local
    !
    scheduler allocate 20000 1000
    ntp server 64.183.56.58 key 0 prefer
    !
    webvpn cef
    !
    end
    
    Diagram 2 -
    Connecting VG to a routed port on the 2811 and connecting the Phones through the POE ports of the ESW. Allowing you for more Phones and better utilization of POE power. And for added complexity I changed the DHCP server to the 2811 so that you would have that configuration for future use. One thing to remember is that even though the ESW is in the 2811 it is still a separate module and should be treated as such. So the reason the first set of code that you posted would not have worked was simply because the vlan configuration was incorrect. IE. dot1Q 107 is not equal to vlan 107 on the ESW. As well as the native vlan for that particular trunk was not defined. (even though you really don't have to define it for it to work, as the dot1Q trunk don't tag the native vlan by default you could have just put an ip address on the FA0/0 and then created your sub interfaces with fa0/0.* and specified there id's there)
    !
    !
    Config# vlan database
    vlan 101
    vlan 107
    apply 
    exit
    !
    !
    
    
    
    
    
    Building configuration...
    Current configuration : 2586 bytes
    !
    ! Last configuration change at 13:49:54 MDT Tue Jul 13 2010
    ! NVRAM config last updated at 13:49:57 MDT Tue Jul 13 2010
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Hermesz_R1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    clock timezone MST -7
    clock summer-time MDT recurring
    no network-clock-participate slot 1 
    !
    !
    ip cef    
    !
    !
    !
    multilink bundle-name authenticated
    !
    !
    voice-card 0
     no dspfarm
    !
    voice-card 1
     no dspfarm
    !
    !
    !
    !
    !
    !
    username ############### privilege 15 password 0 #########
    archive
     log config
      hidekeys
    !
    !
    ip dhcp exclude 10.10.11.198 
    !
    ip dhcp pool Voice
    network 10.10.11.198 255.255.255.224
    default 10.10.11.198
    option 150 10.10.11.198 ; what ever the UCME is
    !
    !
    !
    !
    interface FastEthernet0/0
     description $ETH-LAN$
     ip address #.#.#.# #.#.#.#
     ip nat outside
     ip virtual-reassembly
     duplex auto
     speed auto
    !
    interface FastEthernet0/1
    ip address 10.10.11.195 255.255.255.252 ; giving the VG ip address of 10.10.11.196 /30
     duplex auto
     speed auto
    !
    interface FastEthernet0/1/0
     switchport access vlan 101
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/1
     switchport access vlan 101
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/2
     switchport access vlan 101
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/3
     switchport access vlan 101
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/4
     switchport access vlan 101
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/5
     switchport access vlan 101
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/6
     switchport access vlan 101
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/7
     switchport access vlan 101
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/8
     switchport access vlan 101
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface Serial0/2/0
     no ip address
     shutdown
     no fair-queue
    !
    interface Vlan1
     no ip address
    !
    interface Vlan 101
    ip address 10.10.11.20 255.255.255.224
    ip nat inside
    !
    interface Vlan 107
    ip address 10.10.11.198 255.255.255.224
    !
    router ospf 1
     log-adjacency-changes
     passive-interface FastEthernet0/0
     passive-interface Serial0/2/0
     network 10.10.0.0 0.0.255.255 area 0
    !
    ip route 0.0.0.0 0.0.0.0 #.#.#.#
    !
    !
    ip http server
    no ip http secure-server
    ip nat inside source list 1 interface FastEthernet0/0 overload
    !
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 10.10.11.0 0.0.0.31
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !         
    voice-port 0/3/0
    !
    voice-port 0/3/1
    !
    voice-port 0/3/2
    !
    voice-port 0/3/3
    !
    voice-port 1/0/0
    !
    voice-port 1/0/1
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
     login local
    line vty 5 988
     login local
    !
    scheduler allocate 20000 1000
    ntp server 64.183.56.58 key 0 prefer
    !
    webvpn cef
    !
    end
    
    -- You could do an Ip unnumbered on FA 0/1 if you were really hurting for IP address's... Have fun playing with this..
    The quality of a book is never equated to the number of words it contains. -- And neither should be a man by the number of certifications or degree's he has earned.
Sign In or Register to comment.