Options

home networking tutorials

albin1e4albin1e4 Member Posts: 24 ■□□□□□□□□□
I will be setting up my CCNA lab in the next week or so using a setup nearly identical to the one in TechLabs.

I want to incorporate my Comcast cable modem into this setup. Does anyone have a favorite link to a tutorial on setting up such a home network that would allow both CCNA hardware practice and Internet surfing.

I've found a few things on the web that talk about using NetBEUI over TCP/IP, but I'm still somewhat confused over the configuration.

Thanks in advance for any input.

Brian

Comments

  • Options
    tunerXtunerX Member Posts: 447 ■■■□□□□□□□
    You bought 2 2501s and a 1924. Connect the 1924 to the cable modem on port 2. Connect a 2501 to port 1 and connect the other 2501 to port 9. Connect port 10 to your PC. Assign ports 1-2 to vlan 2. Assign 9, 10 and the catalyst to VLAN 3.

    Connect serial 0 and 1 on the first router (DCE end of V.35 cable) to serial 0 and 1 on the second router.

    On your switch if it starts at a menu:
    k
    enable
    configure terminal
    vlan 2
    vlan 3
    ip mgmt-vlan 3
    ip address 192.168.0.2 255.255.255.0
    ip default-gateway 192.168.0.1
    interface e 0/1
    vlan-membership static 2
    interface e 0/2
    vlan-membership static 2
    interface e0/9
    vlan-membership static 3
    interface e0/10
    vlan-membership static 3

    On your 2501 connected to port 1.

    configure terminal

    interface ethernet 0
    ip address dhcp
    ip nat outside
    ip access-group 100 in
    no shut

    interface multilink 1
    ip address 10.0.0.1 255.255.255.252
    ip summary-address eigrp 1 0.0.0.0 0.0.0.0 90
    ip nat inside
    no shut

    interface serial 0
    encapsulation ppp
    clock rate 4000000
    multilink-group 1
    no shut

    interface serial 1
    encapsulation ppp
    clock rate 4000000
    multilink-group 1
    no shut

    ip nat inside source list 1 interface ethernet 0 overload

    access-list 1 permit any
    access-list 100 permit ip any any established

    router eigrp 1
    network 192.168.0.0
    network 10.0.0.0 255.255.255.252
    no auto-summary
    passive-interface ethernet 0

    On the other router do a little something like this:

    configure terminal
    service dhcp
    ip dhcp exluded-address 192.168.0.1 192.168.0.5
    ip dhcp pool mypool
    network 192.168.0.0 255.255.255.0
    dns-server <IP address of your ISP DNS server>
    default-router 192.168.0.1

    interface ethernet 0
    ip address 192.168.0.1 255.255.255.0
    no shut

    interface multilink 1
    ip address 10.0.0.2 255.255.255.252
    no shut

    interface serial 0
    encapsulation ppp
    multilink-group 1
    no shut

    interface serial 1
    encapsulation ppp
    multilink-group 1
    no shut

    router eigrp 1
    network 192.168.0.0
    network 10.0.0.0 255.255.255.252
    no auto-summary
    passive-interface ethernet 0
  • Options
    albin1e4albin1e4 Member Posts: 24 ■□□□□□□□□□
    Thank you for the detailed reponse. Any other more general tutorials / articles on this subject? The results of my Google search on Windows home networking has been less than spectacular.

    Brian
  • Options
    DrakonblaydeDrakonblayde Member Posts: 542
    well windows networking all depends on what OS's you're running, whether you're running in a domain, or just a workgroup. Basically, if you're running a domain, it's easier to access network resources. But a workgroup is fairly simple too... just make sure all the machines have the same workgroup defined, and it helps if all the machines have the same account information so you don't have to enter it when you're connecting to a share. If you're running XP then the peer to peer thing gets to be a bit more of a pain in the behind as you HAVE to define at least one passworded account on each machine, but all in all, still not that much of an effort.

    This is assuming, of course, all your machines are going to be on the same segment. If not, then it gets a bit more complicated ;)
    = Marcus Drakonblayde
    ================
    CCNP-O-Meter:
    =[0%]==[25%]==[50%]==[75%]==[100%]
    ==[X]===[X]====[ ]=====[ ]====[ ]==
    =CCNA==BSCI==BCMSN==BCRAN==CIT=
Sign In or Register to comment.