Router Configuration( Frame Relay, HDLC, PPP)

dot1Qdot1Q Registered Users Posts: 1 ■□□□□□□□□□
topology1.jpg


Frame Relay

ena
config t
hostname router
no ip domain lookup
enable secret cisco
banner motd

line con 0
password class
login
logging synchronous
exit

line vty 0 4
password class
login
exit

copy run start

int serial 0/1
ip address
clock rate ( for DCE)
no shut
exit

int fa 0/1
ip address
no shut
exit

router rip
network
network
version 2

int serial 0/1
encapsulation frame-relay
no frame-relay inverse-arp

frame-relay map ip
no shut

copy run start

username ccna password cisco
aaa new-model
aaa authentication login LOCAL_AUTH local

line con 0
login authentication LOCAL_AUTH

line vty 0 4
login authentication LOCAL_AUTH

PPP

int serial 0/1.
encapsulation PPP
PPP authentication chap
username router password class
exit

HDLC


Is on by default.

Could anyone have a look at this and tell me if it looks ok? cant get it to work on packet tracer icon_redface.gif

Comments

  • peanutnogginpeanutnoggin Member Posts: 1,096 ■■■□□□□□□□
    Welcome to TE...

    What's not working? By looking at your config and your diagram, I will tell you... you need PPP enabled on both routers that's connected via PPP. I see you have one end setup for PPP, but you would need the other end of the PPP. Second, the same rule applies for your Frame Relay... you can have it enabled on one router, but if all other routers aren't configured for Frame Relay then you will not be able to communicate via Frame Relay... As you mentioned... HDLC is enabled by default... so without seeing your configs, I'm not sure what's working or what's not working... Can you post a running config for each router and then tell us what you're having problems getting to work? HTH

    -Peanut
    We cannot have a superior democracy with an inferior education system!

    -Mayor Cory Booker
  • billscott92787billscott92787 Member Posts: 933
    In addition looks like your using Packet Tracer, the only way Frame-relay will work probably in Packet Tracer, is you have to implement a WAN cloud in between the two devices, then you have to click on the cloud and configure frame-relay with the proper DLCI's. icon_thumright.gif
  • phoeneousphoeneous Member Posts: 2,333 ■■■■■■■□□□
    In addition looks like your using Packet Tracer, the only way Frame-relay will work probably in Packet Tracer, is you have to implement a WAN cloud in between the two devices, then you have to click on the cloud and configure frame-relay with the proper DLCI's. icon_thumright.gif

    Too much is missing from the op's post, like a cloud, dlci's and ip's. Need more info.
  • billscott92787billscott92787 Member Posts: 933
    phoeneous wrote: »
    Too much is missing from the op's post, like a cloud, dlci's and ip's. Need more info.


    I agree. Can you show us the entire configs, because it honestly looks like there have just been a few devices thrown up, with not much done to them. Plus your diagram shows the links as red, meaning they are down/disabled. Did you even enable the interfaces on all sides on each router? If so, they should be green in PT.
  • mastropieromastropiero Registered Users Posts: 2 ■□□□□□□□□□
    I've got same problem. These are all the information i have. And my configuration that dont works in frame relay and hdlc

    4864492topolog.jpg

    [FONT=&quot]
    [/FONT]
    4864562tab.jpg

    My configuration in PT is the next, but i can´t ping from R3 to R2 (HDLC) and R2 to R1 (Frame Relay)

    !
    version 12.4
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname R1
    !
    !
    !
    !
    !
    !
    username cisco password 0 cisco
    !
    !
    !
    !
    !
    no ip domain-lookup
    ip name-server 0.0.0.0
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface FastEthernet0/1
    ip address 10.0.0.1 255.255.255.128
    duplex auto
    speed auto
    !
    interface Serial0/0/0
    description PPP Encapsulation CHAP autentication R1 - R2
    bandwidth 64
    ip address 172.16.0.1 255.255.255.252
    encapsulation ppp
    ppp authentication chap
    clock rate 64000
    !
    interface Serial0/0/1
    description Frame Relay Encapsulation R1 - R3
    bandwidth 64
    ip address 172.16.0.9 255.255.255.252
    encapsulation frame-relay
    frame-relay map ip 172.16.0.6 100 broadcast
    frame-relay lmi-type ansi
    no keepalive
    !
    interface Vlan1
    no ip address
    shutdown
    !
    router rip
    network 172.16.0.0
    !
    ip classless
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    logging synchronous
    line vty 0 4
    login
    !
    !
    !
    end


    !
    version 12.4
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname R2
    !
    !
    !
    !
    !
    !
    username cisco password 0 cisco
    !
    !
    !
    !
    !
    no ip domain-lookup
    ip name-server 0.0.0.0
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 209.165.200.161 255.255.255.224
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial0/0/0
    description PPP Encapsulation CHAP autentication R2 - R1
    bandwidth 64
    ip address 172.16.0.2 255.255.255.252
    encapsulation ppp
    ppp authentication chap
    !
    interface Serial0/0/1
    description HDLC Encapsulation R2 - R3
    bandwidth 64
    ip address 172.16.0.5 255.255.255.252
    clock rate 64000
    !
    interface Serial0/1/0
    no ip address
    shutdown
    !
    interface Serial0/1/1
    no ip address
    shutdown
    !
    interface Vlan1
    no ip address
    shutdown
    !
    router rip
    network 10.0.0.0
    network 172.16.0.0
    !
    ip classless
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    logging synchronous
    line vty 0 4
    login
    !
    !
    !
    end


    !
    version 12.4
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname R3
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    no ip domain-lookup
    ip name-server 0.0.0.0
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface FastEthernet0/1
    ip address 10.0.0.129 255.255.255.128
    duplex auto
    speed auto
    !
    interface Serial0/0/0
    description Frame Relay Encapsulation R3 - R1
    bandwidth 64
    ip address 172.16.0.6 255.255.255.252
    encapsulation frame-relay
    frame-relay map ip 172.16.0.9 100 broadcast
    frame-relay lmi-type ansi
    no keepalive
    clock rate 64000
    !
    interface Serial0/0/1
    description HDLC Encapsulation R3 - R2
    bandwidth 64
    ip address 172.16.0.10 255.255.255.252
    !
    interface Vlan1
    no ip address
    shutdown
    !
    router rip
    network 172.16.0.0
    !
    ip classless
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    logging synchronous
    line vty 0 4
    login
    !
    !
    !
    end


    Thanks in advance
  • chmorinchmorin Member Posts: 1,446 ■■■■■□□□□□
    What exactly is not working? What can communicate and what can not? It's to early here for me to cycle through running configs for a needle in a haystack.
    Currently Pursuing
    WGU (BS in IT Network Administration) - 52%| CCIE:Voice Written - 0% (0/200 Hours)
    mikej412 wrote:
    Cisco Networking isn't just a job, it's a Lifestyle.
  • mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    If this is your homework it kind of defeats the purpose if you ask us rather than your instructor.

    If the HDLC isn't working between R2 and R3 -- what does show ip int brief show on for those interfaces? What do you want it to show? If that looks good but they still can't ping each other, are they on the same network (are the IP addresses and subnet mask correct)?

    What's that table? The current configurations? Are the configurations on the Diagram the ones to be considered correct?

    And if you post configurations, use code blocks and tell us which device they are for outside of the code block -- I don't have time to scan a blob of code and hunt for host names and page up and down looking for individual configurations.
    :mike: Cisco Certifications -- Collect the Entire Set!
  • gouki2005gouki2005 Member Posts: 197
    frame relay in packet tracer...??? to use FR you need one of those clouds is a mess...my advice practice FR in GNS3 is much easier understand there
  • JaCkNiFeJaCkNiFe Member Posts: 96 ■■□□□□□□□□
    mastropiero: Your problem between R2 and R3 is the subnet.

    R2 = S0/0/1 172.16.0.5 /30
    The range of addresses here is
    172.16.0.4 subnet
    172.16.0.5 and .6 host addresses
    with a broadcast address of 172.16.0.7

    R3 = S0/0/1 172.16.0.10 /30
    The range of addresses here is
    172.16.0.8 subnet
    172.16.0.9 and .10 host addresses
    with a broadcast address of 172.16.0.11

    Take a look at ALL your links and apply your sub-netting skills, I am sure you can get it fixed up.

    As for R2 to R1 when you use CHAP authentication you have to have a
    "username (neighbor routers hostname on the other end of the point to point link) password (password)"
    placed on both routers with a matching password to authenticate.
    Lab on!
  • mastropieromastropiero Registered Users Posts: 2 ■□□□□□□□□□
    icon_cheers.gificon_thumright.gif
    Thank you very much JaCkNiFe.
    I spent lot of time and i couldn't see the problem because i believe all data whitch was given to me were ok. Now all is working perfectly.
    One million of thanks. I hope I can return the favor.
    Thank very much again.
    Best regards.

    icon_thumright.gificon_wink.gif
  • mrcspl571mrcspl571 Member Posts: 11 ■□□□□□□□□□
    You need the frame-relay switch between R1 and R3 and you need to make both of them DTE devices (ie no "clock rate" command) on both serial lines connecting to the cloud.

    Here's what mine looks like:

    labtl.jpg

    Frame-relay configuration in Packet Tracer:

    103cm.jpg

    301i.jpg

    framerelay.jpg

    Relevant portions from my show runs:
    R1#show run

    interface Serial0/0/1
    ip address 172.16.0.9 255.255.255.252
    encapsulation frame-relay
    frame-relay map ip 172.16.0.10 103 broadcast cisco
    R3#show run

    interface Serial0/0/0
    ip address 172.16.0.10 255.255.255.252
    encapsulation frame-relay
    frame-relay map ip 172.16.0.9 301 broadcast cisco
    ip nat outside
Sign In or Register to comment.