arsalan921arsalan921 Member Posts: 56 ■■□□□□□□□□
hello all,

studying 802.1x based authentication, and i checked the commands required for this 802.1x on gns3.. these commands are supported there but i would like to ask that how on gns3 can we use a radius server...

routers there accepts the command radius-server host <ip adress > key <anykey>

but how can i use a radius server here ?

thank you


  • Ryan82Ryan82 Member Posts: 428
    You could run the radius server on your PC and then have gns3 communicate to it through a loopback interface. Instructions here:

    blindhog.net How to integrate a Microsoft Loopback interface with GNS3
  • arsalan921arsalan921 Member Posts: 56 ■■□□□□□□□□
    thank you for you reply

    i have created loopback interface on microsoft os.
    now trying to telnet to connect to gns3..
    in tutorial there was a part where he clicks on network device list and sees which one is loopback interface and then he adds that to the cloud..
    when i run network device list.. it says unable to create lock file..

    here is an image of what i get when i run network device list...
    can u pls tell what should i do here ?

    2nd question,
    which radius server did you use ? tekradius ?

    thank you for your help
  • DevilWAHDevilWAH Member Posts: 2,997 ■■■■■■■■□□
    arsalan921 wrote: »

    2nd question,
    which radius server did you use ? tekradius ?

    thank you for your help

    CISCO ACS :) the latest version I do like :)

    but I learnt by using the radius server built in to windows
    • If you can't explain it simply, you don't understand it well enough. Albert Einstein
    • An arrow can only be shot by pulling it backward. So when life is dragging you back with difficulties. It means that its going to launch you into something great. So just focus and keep aiming.
  • arsalan921arsalan921 Member Posts: 56 ■■□□□□□□□□
    here is the image which i got when i run "network device list" from desktop... it says the system cannot find the path specified


    the previous image i got when i run it from folder in programfiles\gns3
  • arsalan921arsalan921 Member Posts: 56 ■■□□□□□□□□

    this problem is only for vista os...

    solution is ..

    control-panel -- > user-accounts --> turn user accounts control off ( uncheck the box)

    would like to get some details on radius server..

    i have understood this part that how to connect a loopback interface of ms with gns3... but how to use radius server with loopback interface ?

  • QHaloQHalo Member Posts: 1,488
    Add the loopback, assign it an IP address that is on the same network as the router that you want it to talk with and then add the loopback's network device ID to the router ethernet port in the net file and ping to verify connectivity. Using ACS, which is a free download from Cisco as a trial (go get it, it's great and worth learning) go to Network Configuration and then create an AAA Server and set the IP address to the IP address that you put on the Loopback. Add the server in the AAA configuration and viola. HTH
Sign In or Register to comment.