CCIP track - Please help me.

Dears in CCIP,
I would like to finish my CCIP certification, I already pass QoS exam last week, I have two questions: -
1. Should I start with MPLS exam first or BGP exam.
2. What is the best book for BGP exam?

Comments

  • mikej412mikej412 Posts: 10,090Member
    Start with BGP.

    You can use Doyle's Routing TCP/IP BGP chapters as a review of your BSCI/ROUTE BGP studies and a warmup for Halabi's Cisco Press Internet Routing Architectures book for the BGP exam.
    :mike: Cisco Certifications -- Collect the Entire Set!
  • auosauos Posts: 186Member
    Many thanks mike.
  • mkomonmkomon Posts: 37Member ■■□□□□□□□□
    I did what Mike has just written and with some labtime the BGP exam was a cake. icon_smile.gif There was still a couple of things that were not covered in neither of the books but it was not a big deal.
  • SettSett Posts: 187Member
    mkomon wrote: »
    I did what Mike has just written and with some labtime the BGP exam was a cake. icon_smile.gif There was still a couple of things that were not covered in neither of the books but it was not a big deal.

    Like what ? Not anything specific of course, just the topics :)
    Non-native English speaker
  • mikej412mikej412 Posts: 10,090Member
    Sett wrote: »
    Like what ? Not anything specific of course, just the topics :)
    Anything on the exam blueprint is fair game -- including vague references to things in the Description Section of the blueprint that aren't mentioned again or covered by the listed topics.

    And luck of the draw on the questions -- and the inclusion of ungraded beta questions -- means you may not see "one of those" questions or that it may just actually be ungraded.

    The NDA wouldn't let us tell you the topic. We can tell you the listed topics on the blueprint we studied the most or were glad we studied the hard, but we can't say which topics were tested on the exam. And then throwing out an unlisted topic that could only be answered by disclosing knowledge of something you saw on the exam would definitely be an NDA violation.

    But I've always assumed that the "uncovered questions" were salted into the exam as ungraded questions by Cisco for them to get a good measure of people cheating on the exam. If everyone has to guess on a question, then only about 20% of the people should get it right. But if 60-70% of the people are getting "one of those" questions right -- then you know who's exam and exam metrics to review for other testing anomalies.

    As mkomon said -- don't worry about it. :D
    :mike: Cisco Certifications -- Collect the Entire Set!
  • mkomonmkomon Posts: 37Member ■■□□□□□□□□
    Yeah, can't be more specific because of the NDA.

    Having scored >910 pts it did not have too much effect. It just pointed me at a couple of things to take a look at to fill in gaps in those little details.

    Read the BGP chapter in Doyle II and Halabi, spend enough time labbing to fully understand all of the protocol features and routing policy concepts and you will be good to go. Also Cisco Systems, Inc is a great resource I used (BGP Command Reference Guide etc).
  • jovan88jovan88 Posts: 393Member
    mikej412 wrote: »
    Start with BGP.

    Why Mike? With a basic understanding of BGP, would you be able to jump right into MPLS and leave BGP last?
  • APAAPA Posts: 959Member
    I'll always say it......... but don't skimp on reading the following.....

    BGP Design and Implementation - by Randy Zhang

    Awesome book...and mike is right..... For the BGP exam anything is fair game..... Even if the objectives don't explicitly state it!

    CCNA | CCNA:Security | CCNP | CCIP
    JNCIA:JUNOS | JNCIA:EX | JNCIS:ENT | JNCIS:SEC
    JNCIS:SP | JNCIP:SP
  • deth1kdeth1k Posts: 312Member
    I would have to disagree with you my friend, this book is not for someone who just jumped into BGP world, it's quite complex and would be more useful for someone working in ISP core/design. Internet Routing Architectures is the best one IMHO.
    APA wrote: »
    I'll always say it......... but don't skimp on reading the following.....

    BGP Design and Implementation - by Randy Zhang

    Awesome book...and mike is right..... For the BGP exam anything is fair game..... Even if the objectives don't explicitly state it!
  • j4sj4s Posts: 18Member ■□□□□□□□□□
    I started the CCIP with MPLS, now I am studying BGP, and QOS for last.

    I decided to take the exams in the order I thought I would have most difficulty, not having looked at MPLS I decided to take it first, BGP I have a good knowledge of, and QOS very good.

    Might not make sense to some, but it is so far working for me.

    I am reading the Sam Halabi book for BGP (Internet Routing Architectures). Currently on my third read through, although I have just spend the last week reading Chapters 11-12 constantly, I am also doing lab work in GNS, and looking through the command reference.
    Hoping to take the exam towards the end of September.

    For MPLS I read MPLS Fundamentals by Luc De Ghein which was a good read, that with GNS labs was enough to get me through.

    JC
  • Ryan82Ryan82 Posts: 428Member
    For anyone interested INE has a CCIP bootcamp class on demand out..
  • tomaifauchaitomaifauchai Posts: 301Member
    Geez, that LDP chapter made me go crazy icon_twisted.gif
    I've opened GNS3 to try to understand this stuff a bit! I think i get the concept but there's something i don't get yet.
    Is it normal that an Edge router who run BGP one side with "no mpls ip" and run eigrp the other side with mpls enabled can't peer with a P router?

    BGP (No mpls)
    R1
    EIGRP---MPLS enabled
    R2

    R1 can't peer with R2 - LDP

    I've watched a few labs from gns3vault.com and to be honest, when he threw me some VRF stuff with family and communities...i was totally lost :)
    6 hours on MPLS today...time to go dream about it lol
    [X] - 350-001 (300h)
    [ ] - Lab exam (60h)
    Personal blog: http://www.tommyf.net/
  • Ryan82Ryan82 Posts: 428Member
    As long as R1 has IP reachability to R2, they should be able to form an LDP relationship. Make sure "mpls ip" is enabled globally, on the interfaces connecting R1 and R2, and cef is enabled on both devices.
  • tomaifauchaitomaifauchai Posts: 301Member
    Ryan82 wrote: »
    As long as R1 has IP reachability to R2, they should be able to form an LDP relationship. Make sure "mpls ip" is enabled globally, on the interfaces connecting R1 and R2, and cef is enabled on both devices.

    I confirm! But it's R3 and R1 in this example

    mpls1.jpg
    R3
    interface FastEthernet0/0
     ip address 200.1.1.2 255.255.255.0
     duplex auto
     speed auto
    !
    interface FastEthernet0/1
     ip address 10.0.0.1 255.255.255.252
     duplex auto
     speed auto
     mpls ip
    
    router eigrp 1
     network 10.0.0.0
     no auto-summary
    !
    router bgp 65000
     no synchronization
     bgp log-neighbor-changes
     network 200.1.1.0
     neighbor 10.2.2.2 remote-as 65000
     neighbor 200.1.1.1 remote-as 65100
     no auto-summary
    
    
    R1
    interface FastEthernet0/1
     ip address 10.0.0.2 255.255.255.252
     duplex auto
     speed auto
     mpls ip
    !
    router eigrp 1
     network 10.0.0.0
     no auto-summary
    
    
    R3#sh mpls ldp neighbor
    
    R3#
    
    This show the R1 neighbor on fa0/0, but no neighborship with R3
    R1#sh mpls ldp neighbor
        Peer LDP Ident: 10.2.2.1:0; Local LDP Ident 10.1.1.1:0
            TCP connection: 10.2.2.1.41798 - 10.1.1.1.646
            State: Oper; Msgs sent/rcvd: 26/26; Downstream
            Up time: 00:17:25
            LDP discovery sources:
              FastEthernet0/0, Src IP addr: 10.1.1.2
            Addresses bound to peer LDP Ident:
              10.1.1.2        10.2.2.1
    R1#
    
    
    Tracing route through my opposite Edge router...no mpls.
    R3#traceroute 10.2.2.2
    
    Type escape sequence to abort.
    Tracing the route to 10.2.2.2
    
      1 10.0.0.2 60 msec 80 msec 8 msec
      2 10.1.1.2 16 msec 8 msec 8 msec
      3 10.2.2.2 52 msec *  92 msec
    R3#
    
    

    There's also no LDP neighborship between R2 and R4.
    I suspect a BGP issue?
    [X] - 350-001 (300h)
    [ ] - Lab exam (60h)
    Personal blog: http://www.tommyf.net/
  • mkomonmkomon Posts: 37Member ■■□□□□□□□□
    My guess is: LDP sets LDP ID the same was as OSPF. If you have no loopbacks set, it picks the IP address of R3.Fa0/0 (200.1.1.2), since it is the highest. R1 needs to have a route for the LDP-ID in the routing table, which it doesn't (EIGRP routes 10.0.0.0/8 ).

    There are two workarounds/solutions for the situation, I'll let you think about it. It is covered in the LDP chapter of MPLS fundamentals. Of course you can ask for them but I think you'll figure it out soon.

    Martin

    Edit: the same applies for R2-R4. And a LDP problem is never a BGP issue (I can't think of such scenario, as long as we're not talking about targeted LDP for example).
  • tomaifauchaitomaifauchai Posts: 301Member
    Brillant Martin!
    I think i found one :)

    R3
    *Mar  1 00:00:27.519: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.0.0.2 (FastEthernet0/1) is up: new adjacency
    *Mar  1 00:00:30.251: %LDP-5-NBRCHG: LDP Neighbor 1.1.1.1:0 (1) is UP
    *Mar  1 00:00:51.387: %BGP-5-ADJCHANGE: neighbor 200.1.1.1 Up
    *Mar  1 00:01:00.427: %BGP-5-ADJCHANGE: neighbor 10.2.2.2 Up
    
    
    R1
    *Mar  1 00:00:18.447: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.0.0.1 (FastEthernet0/1) is up: new adjacency
    *Mar  1 00:00:21.347: %LDP-5-NBRCHG: LDP Neighbor 3.3.3.3:0 (1) is UP
    *Mar  1 00:00:34.983: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.1.2 (FastEthernet0/0) is up: new adjacency
    *Mar  1 00:00:37.947: %LDP-5-NBRCHG: LDP Neighbor 2.2.2.2:0 (2) is UP
    
    I created a loopback on each Router and include it in eigrp but since i don't know how to reset MPLS, i've restarted the routers!

    The second thing, probably less best practice, would have been to use the mpls ldp router-id fa0/1 command ?

      1 10.0.0.2 [MPLS: Label 18 Exp 0] 52 msec 104 msec 8 msec
      2 10.1.1.2 20 msec 12 msec 8 msec
      3 10.2.2.2 40 msec *  76 msec
    


    This subtleties remind me something like announcing a BGP network not in the routing table by creating a Null route
    [X] - 350-001 (300h)
    [ ] - Lab exam (60h)
    Personal blog: http://www.tommyf.net/
  • mkomonmkomon Posts: 37Member ■■□□□□□□□□
    Nice! icon_smile.gif You've found another one - to change LDP ID using the R3.F0/1. My two were:
    -add a route for 200.1.1.2 on R1 or add the network into EIGRP
    -create the loopbacks and use them for LDP ID

    You don't have to reload the router after changing the LDP ID. Add the keyword "force" at the end of the command to force LDP to use the ID immediately.

    In a real word scenario I would go with loopbacks and LDP IDs bound to them.

    Martin
  • tomaifauchaitomaifauchai Posts: 301Member
    mkomon wrote: »
    -add a route for 200.1.1.2 on R1 or add the network into EIGRP

    redistribute connected would only include the 200.1.1.0 subnet so it's great!
    Thanks for your help ! I'll be able to advance a bit
    [X] - 350-001 (300h)
    [ ] - Lab exam (60h)
    Personal blog: http://www.tommyf.net/
  • tomaifauchaitomaifauchai Posts: 301Member
    Implementing VRFs with MP-BGP on MPLS network is just brillant stuff. I've listened to the old ISCW videos about it and i'm really impressed of the technology. I understand better now, why Cisco still include frame-relay in the CCNA though.

    It helps to compare the old technologies with the new ones.

    I don't know if i'm correct comparing MPLS to frame-relay, because the way i see it, MPLS is much more powerful than just a layer 2 protocol because it can run on top of them but it can do the same job without all the hassle of configuring PVCs.
    [X] - 350-001 (300h)
    [ ] - Lab exam (60h)
    Personal blog: http://www.tommyf.net/
  • tomaifauchaitomaifauchai Posts: 301Member
    IRA is a nice refresh and goes a bit deeper from what i've read in the 902 actually.

    I have a question based on chapter 6: AS prepend
    If you prepend your AS by adding 1 or 2 duplicate, will it propagate worldwide or just throughout your ISP?

    Basically, i want to know if the NAP of your ISP(s) will strip off duplicate AS entries from different routes they learnt before reaching another AS?

    Thanks
    [X] - 350-001 (300h)
    [ ] - Lab exam (60h)
    Personal blog: http://www.tommyf.net/
  • mkomonmkomon Posts: 37Member ■■□□□□□□□□
    Your "AS prepends" will propagate globally. They will become a part of the AS_PATH attribute and won't be stripped off by anybody.
  • tomaifauchaitomaifauchai Posts: 301Member
    mkomon wrote: »
    Your "AS prepends" will propagate globally. They will become a part of the AS_PATH attribute and won't be stripped off by anybody.

    Thanks, i can't see an advantage of using MED over prepending now. I guess it depends on ISP policies
    [X] - 350-001 (300h)
    [ ] - Lab exam (60h)
    Personal blog: http://www.tommyf.net/
  • mkomonmkomon Posts: 37Member ■■□□□□□□□□
    You will after reading IRA. I guess it's better to leave this now and let you read IRA first.
  • tomaifauchaitomaifauchai Posts: 301Member
    Yeah i think it's a good idea! But i love labbing at the same time i read so i will design a new topology and try to find what would be the best in X situations and i will report back
    [X] - 350-001 (300h)
    [ ] - Lab exam (60h)
    Personal blog: http://www.tommyf.net/
  • tomaifauchaitomaifauchai Posts: 301Member
    Just finished chapter 10 and i was wondering, where are the show run's? Case studies? Examples?

    Found them to be in Chap 11-12...Quite a different method of presenting the content but can't wait to read it :)

    For the MED vs AS_PATH, i've got 1 situation where it would be tricky to prepend AS_PATH and 1 situation using MED.

    For the AS_PATH, i think it is uncommon to prepend AS when using confederations because the PE router would strip it?

    For the MED, i think it is unlikely to have 2 different ISP enable "bgp always-compare-med" each others on their link?

    So i went to the conclusions that, it is probably better to run MED under a Dual Homing scenario running confederations inside your AS and it is probably better to prepend AS_PATH while you run Single multihoming scenario.

    I think that under a Dual multihoming scenario, you could run MED for "dual" and AS_PATH prepending for "multihoming" sections in the case both ISP wouldn't share their MED values.

    I don't know if it is a common practice, but tweaking the routes ORIGIN doesn't seem to be a bad idea?

    Cheers
    [X] - 350-001 (300h)
    [ ] - Lab exam (60h)
    Personal blog: http://www.tommyf.net/
Sign In or Register to comment.