Olive building help in VMWare

Ryan82Ryan82 Member Posts: 428
I'm attempting to get an olive up and running in vmware. I have partially installed freebsd but when I get to the section for configuring the interface parameters, I am not presented with the option of selecting an ethernet "em0" interface.

Is there something I need to do in vmware prior to this installation in order to be able to select my physical NIC? It is my understanding from the tutorial I am following at Dailyconfig: Installing JunOS Olive in VMWare that I should set the NIC up as bridged in VMware.

Any pointers are appreciated as I am linux/vmware/juniper challenged! :D

Comments

  • mkomonmkomon Member Posts: 37 ■■□□□□□□□□
    The NIC needs to be "connected" to the virtual host, "connect at power on" is a good idea. I installed Olive in VMware Workstation 6.5.x and had no problem at all with the NICs. I'll join a couple of side notes I made from my experience:

    - use FreeBSD 4.something. I used 4.11. I tried the 7.x or 8.x releases (not sure which one) but failed to install Junos on them.
    - the virtual host MUST NOT have any SCSI devices, otherwise Junos will fail to install/boot. Use IDE hard drive driver instead.
    - you can directly install Junos 10.x on a clean FreeBSD, no need to waste time with step-by-step upgrading as some tutorials suggest
    - to install Junos >9 you need at least 512 MB of RAM. you can decrease the RAM allocation once the Junos is installed
    - you don't need to go through the 'console access via TCP proxied named pipes' pain or similar stuff with Junos > 7.4
    - create the virtual host manually, get rid of the floppy drive, serial port, add more NICs (one for remote access, the others for playing with stuff)
    - make a snapshot of a nice clean Olive install with remote access set in case something goes wrong once you're done

    Hope you have fun with your Olive(s).
  • Ryan82Ryan82 Member Posts: 428
    Thanks. Well, I have made some headway. Now I am stuck at the section where I am supposed to run the:

    pkg_add jinstalll-8.3R2.8-export-signed.tgz command in the /var/tmp folder.

    When I run this command I receive a bunch of output:

    gzip: stdin: invalid compressed data--format violated
    /usr/bin/tar: Archive contains obsolescent base-64 headers
    /usr/bin/tar: Child returned status 1
    pkg_add: tar extract of /var/tmp/jinstalll-8.3R2.8-export-signed.tgz failed!
    pkg_add: Unable to extract /var/tmp/jinstalll-8.3R2.8-export-signed.tgz !

    Anyone run into this? I think I saw somewhere that there is a workaround that has to occur if using a junos post 7.3 or something but the steps didn't work for me.
  • mkomonmkomon Member Posts: 37 ■■□□□□□□□□
    Looks like a corrupted .tgz or invalid file format.

    Why don't you go for a more recent Junos anyway? There is 10.3 around AFAIK.
  • m4rtinm4rtin Member Posts: 170
    Ryan82, you can check integrity(compare hash of the compressed file in the HTTP/FTP server, in your desktop machine and finally under FreeBSD) of your .tgz file using md5(md5sum under Linux) utility under FreeBSD.

    I have successfully installed four Olive VM machines using VMware® Workstation 7.1.2. Olive0 has IP address 192.168.1.100, Olive1 has 192.168.1.101, Olive2 has 192.168.1.102 and Olive3 has 192.168.1.103. Problem is, that for example if I ping 192.168.1.101 from Olive0(192.168.1.100), I get following reply:
    [email protected]> show interfaces em0.0 terse                                
    Interface               Admin Link Proto    Local                 Remote 
    em0.0                   up    up   inet     192.168.1.100/24            
                                                                            
    [email protected]> ping 192.168.1.101 source 192.168.1.100                    
    PING 192.168.1.101 (192.168.1.101): 56 data bytes                       
    64 bytes from 192.168.1.101: icmp_seq=0 ttl=64 time=0.660 ms            
    64 bytes from 192.168.1.101: icmp_seq=0 ttl=64 time=0.737 ms (DUP!)     
    64 bytes from 192.168.1.101: icmp_seq=0 ttl=64 time=0.752 ms (DUP!)     
    64 bytes from 192.168.1.101: icmp_seq=0 ttl=64 time=0.764 ms (DUP!)      
    ^C                                                                       
    --- 192.168.1.101 ping statistics ---                                    
    1 packets transmitted, 1 packets received, +3 duplicates, 0% packet loss
    round-trip min/avg/max/stddev = 0.660/0.728/0.764/0.041 ms               
                                                                             
    [email protected]>        
    

    Tcpdump output as well:

    pingissue.th.png

    Any ideas, what might cause such issue?icon_rolleyes.gif
  • bermovickbermovick Member Posts: 1,135 ■■■■□□□□□□
    Don't know if this has been resolved or not, but if not, something that might be happening:

    If he's using BSD's ftp command to transfer the image over from another PC, make sure you're entering the 'bin' command before 'get'ing the file so you transfer in binary (instead of ascii) mode.
    Latest Completed: CISSP

    Current goal: Dunno
Sign In or Register to comment.