Win 2003 Server...feeling extremely dumb.

/usr/usr Member Posts: 1,768
Simply trying to share a printer which is hooked up to the server. I can ping the server through both interfaces, wireless and LAN, but can't connect to the printer on either. The dialog comes up asking me to connect, but I get an error that says ,
"Windows could not connect to the printer. Operation could not be completed."

Anyone know what I'm doing wrong? I shared this printer the exact same way, on this same machine, when I was running 2K.



  • /usr/usr Member Posts: 1,768
    Installed AD and it's working fine. icon_wink.gif
  • /usr/usr Member Posts: 1,768
    Can someone tell me why this is the case?

    Why wouldn't the server just act as a regular machine and let me share the printer if AD wasn't installed?
  • WebmasterWebmaster Admin Posts: 10,292 Admin
    "Windows could not connect to the printer. Operation could not be completed." This message (and similar others) are often not very descriptive or useful and sometimes even misleading, but it usually means there's a network or permission/authentication problem. Considering that installing AD solved it and you could ping it, it was probably the latter. Did you create identical username and password on both the client and the server to access the printer?
  • /usr/usr Member Posts: 1,768
    No, but I didn't when I had it setup on the 2000 box either. I even left the passwords blank, just to ensure that wasn't the problem. The authentication should have been wide open. One thing I did notice is that when I went to search for the printer, it would show me the 2003 server, but not the printer attached to it, even though it was shared.
  • garv221garv221 Member Posts: 1,914
    Thats usualy the case of a workgroup. Once you installed AD you now have a username thats universal to log onto both machines, instead only local group policy.
  • DrakonblaydeDrakonblayde Member Posts: 542
    I've noticed that on XP (and I would guess it extends to 2k3 as well), when you're running the boxes in workgroup mode and you don't password your accounts, it will not let you connect to shares on that box by default. Some nonsense about a security measure. I think there was a registry setting you could hack to change that behavior
    = Marcus Drakonblayde
    ==[X]===[X]====[ ]=====[ ]====[ ]==
Sign In or Register to comment.