Linux does not detect Hard drive

StupporedStuppored Senior MemberMember Posts: 150
I installed ESXi on a server. Now I am trying to install any distro of linux on a 15GB partition I setup for it. I've gone through the bios and disabled RAID and set IDE to compatible... still no go... attached is an image just illustrating my stuck point. Any advice would be excellent - I can install windows on any partition I create no problem. I'm guessing it's either the BIOS or ESXi configuration... Anyone?

Oh, and if I click on that button in the middle 'Advanced storage configuration' - the installation craps out. I've tried this with various linux distros and come across the same no HDD detect. Google hasn't helped much on this one.

Comments

  • Bl8ckr0uterBl8ckr0uter Senior Member Inactive Imported Users Posts: 5,031 ■■■■■■■■□□
    Can you delete and recreate the vhd?
  • StupporedStuppored Senior Member Member Posts: 150
    Can you delete and recreate the vhd?

    I've deleted and re-created the virtual machine multiple times.

    UGH... I put it on another datastore and it picks it up correctly now.... now I have to figure out exactly what settings in the config of the datastore I added that were incorrect.
  • MentholMooseMentholMoose Senior Member Member Posts: 1,525 ■■■■■■■■□□
    It should work as long as the disk is attached to the VM via a SCSI controller supported by the OS. The datastore configuration shouldn't make a difference.
    MentholMoose
    MCSA 2003, LFCS, LFCE (expired), VCP6-DCV
Sign In or Register to comment.