Help needed with BGP
Trying to do this in a lab with MPLS. I had ip connectivity between the CE and PE. When I logged into the PE and added the command " ip vrf forwarding site1" , it removed the ip off of the interface facing the CE. so I re-added it. Ever since then, the PE and CE have not had IP connectivity.
Because of this, I cannot establish a BGP session to PE. it says "connection refused." diagram attached. It is the CE on the left I'm referring to
Because of this, I cannot establish a BGP session to PE. it says "connection refused." diagram attached. It is the CE on the left I'm referring to
Comments
-
wera711 Member Posts: 23 ■□□□□□□□□□PE config:
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname sl-mpls-pe
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
ip vrf site1
rd 1:1
route-target export 1:1
route-target import 1:1
!
!
mpls label protocol ldp
!
!
!
!
interface Loopback0
ip address 20.1.1.1 255.255.255.255
!
interface Ethernet0/0
description ***Connected to Customer equip***
ip vrf forwarding site1
ip address 63.238.101.221 255.255.255.252
half-duplex
!
interface Serial0/0
no ip address
shutdown
no dce-terminal-timing-enable
!
interface Ethernet0/1
description ***Connected to MPLS Core***
ip address 68.1.1.2 255.255.255.252
half-duplex
mpls ip
!
router ospf 10 vrf site1
log-adjacency-changes
redistribute bgp 209 subnets
network 63.238.101.220 0.0.0.3 area 0
!
router ospf 2
log-adjacency-changes
network 20.1.1.1 0.0.0.0 area 0
network 68.1.1.0 0.0.0.3 area 0
!
router bgp 209
no synchronization
bgp router-id 20.1.1.1
bgp log-neighbor-changes
neighbor 40.1.1.1 remote-as 209
neighbor 40.1.1.1 update-source Loopback0
neighbor 63.238.101.222 remote-as 65100
no auto-summary
!
address-family vpnv4
neighbor 40.1.1.1 activate
neighbor 40.1.1.1 send-community extended
exit-address-family
!
address-family ipv4 vrf site1
redistribute ospf 10 vrf site1 match internal external 1 external 2
no synchronization
exit-address-family
#####################################################
some show commands
sl-mpls-pe#sh ip bgp summ
BGP router identifier 20.1.1.1, local AS number 209
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
40.1.1.1 4 209 0 0 0 0 0 never Active
63.238.101.222 4 65100 0 0 0 0 0 never Idle
sl-mpls-pe#
sl-mpls-pe#sho
*Mar 1 20:40:08.883: %SYS-5-CONFIG_I: Configured from console by consolew ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
68.0.0.0/30 is subnetted, 1 subnets
C 68.1.1.0 is directly connected, Ethernet0/1
20.0.0.0/32 is subnetted, 1 subnets
C 20.1.1.1 is directly connected, Loopback0
88.0.0.0/30 is subnetted, 1 subnets
O 88.1.1.0 [110/20] via 68.1.1.1, 00:20:05, Ethernet0/1
30.0.0.0/32 is subnetted, 1 subnets
O 30.1.1.1 [110/11] via 68.1.1.1, 00:20:05, Ethernet0/1
sl-mpls-pe# -
wera711 Member Posts: 23 ■□□□□□□□□□config from core router (first time trying to setup MPLS)
P
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname MPLS-CORE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
!
mpls label protocol ldp
!
!
interface Loopback0
ip address 30.1.1.1 255.255.255.255
!
interface Ethernet0/0
description ***connected to SL_PE***
ip address 68.1.1.1 255.255.255.252
half-duplex
mpls ip
!
!
interface Ethernet0/1
description ***Connected to Colo-PE***
ip address 88.1.1.1 255.255.255.252
half-duplex
mpls ip
!
router ospf 2
log-adjacency-changes
network 30.1.1.1 0.0.0.0 area 0
network 68.1.1.0 0.0.0.3 area 0
network 88.1.1.0 0.0.0.3 area 0
##############################################
some show commands
MPLS-CORE#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
68.0.0.0/30 is subnetted, 1 subnets
C 68.1.1.0 is directly connected, Ethernet0/0
20.0.0.0/32 is subnetted, 1 subnets
O 20.1.1.1 [110/11] via 68.1.1.2, 00:21:38, Ethernet0/0
88.0.0.0/30 is subnetted, 1 subnets
C 88.1.1.0 is directly connected, Ethernet0/1
30.0.0.0/32 is subnetted, 1 subnets
C 30.1.1.1 is directly connected, Loopback0
MPLS-CORE# -
Forsaken_GA Member Posts: 4,024When you say IP connectivity, you mean from PE to CE, ie, you can't ping each end of the tunnel?
If so, which router are you pining from? -
Forsaken_GA Member Posts: 4,024Ok, what exactly are you trying to accomplish? It looks like you're trying to run OSPF CE-PE, but you're also trying to peer CE-PE BGP globally? That's not going to work. As soon as you assign the vrf to the interface, the address attached to that interface no longer has a route in the global routing table, so your BGP neighbor statement to the CE is going to fail.
If all you're trying to do is run BGP CE-PE, get rid of the OSPF vrf configuration, and set your neighbor statement to the CE router under the address family vrf site 1 configuration.
There's no need to do redistribution when eBGP is the PE-CE routing protocol, it redistributes them into MP-BGP automatically