Options

different networks in the same VLAN

m4rtinm4rtin Member Posts: 170
I have a following simple network:
lanv.th.png

Is it possible to segregate PC network and IP-cameras/door-controllers network? I mean it would be easy if I have a switch, which supports VLAN tagging, but mine does not. Is there any benefit to put two IP addresses like this:
Cisco881#sh run int fa4
Building configuration...

Current configuration : 142 bytes
!
interface FastEthernet0
 ip address 192.168.2.1 255.255.255.0 secondary
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
end

Cisco881#
..to a Cisco 881 Fa0 interface? As addresses are in the same broadcast domain and both address spaces can reach each other, are there any benefits at all to have different networks in the same VLAN? icon_rolleyes.gif

Comments

  • Options
    mtorresmtorres Member Posts: 63 ■■□□□□□□□□
    The only time i have heard of someone doing this very same thing is if they run out of IP address for one subnet so they add another one on the same vlan. But not sure if that is a good way to do it but I know people who have done this.
  • Options
    Forsaken_GAForsaken_GA Member Posts: 4,024
    itll work fine, the only thing is that, assuming these are all connected to a switch, if one IP space needs to talk to the other IP space, it has to go up to the router and then back down the same wire, but if you're not pushing enough traffic for it to matter, it's a non issue
  • Options
    PhildoBagginsPhildoBaggins Member Posts: 276
    It would be the same exact process as intervlan routing or ROaS except the Vlans are the same

    Router setup would be

    Int Fa0/1
    no ip address
    int Fa0/1.1
    ip address 10.1.1.1 255.255.255.0 (gives you one class C subnet)
    no shut
    int Fa0/1.2
    ip address 10.1.2.1 255.255.255.0 (gives you another class C subnet)
    no shut

    Turn on rip
    router rip
    version 2
    no auto
    network 10.0.0.0


    Switch config is fine, you just need to remember which subnet your running the switch into its gateway for administration.


    PC on 10.1.1.0
    gateway = 10.1.1.1

    PC on 10.1.2.0
    gateway = 10.1.2.1
  • Options
    Forsaken_GAForsaken_GA Member Posts: 4,024
    It would be the same exact process as intervlan routing or ROaS except the Vlans are the same

    No it's not, they're in the same vlan. He has the config correct, all he needs to do is add the secondary IP address for the gateway for the other IP space and it'll work fine. It's not doing intervlan routing, it's just doing routing. Same layer 2 domain, so both IP spaces will see each others broadcasts, and any traffic that needs to travel between the boxes at layer 3 will utilize the same link. He was asking if there's any advantage to doing things this way, and the answer to that is no, there's a few disadvantages. If he were doing RoAS, he'd at least be breaking up the broadcast domains.

    The only advantage to doing it like this is if you need to address more machines on a segment than you have allocated for. It works to prevent a total renumbering of the subnet. It's also useful if you need to do wasteful stuff like give a server or group of servers IP's from different IP spaces because you think Google penalizes your PageRank because you have too many sites on one IP.
Sign In or Register to comment.